summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-07-26 19:09:17 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-07-26 19:09:17 +0000
commit3b7aa7eb0c939f180f88a285d2970fd176f2e235 (patch)
treea818a0fe46804ed156250d3f7c2cb971dad04081 /dev-python
parentEnable optional support for graphite via graphite2 package. (diff)
downloadhistorical-3b7aa7eb0c939f180f88a285d2970fd176f2e235.tar.gz
historical-3b7aa7eb0c939f180f88a285d2970fd176f2e235.tar.bz2
historical-3b7aa7eb0c939f180f88a285d2970fd176f2e235.zip
Initial import to the main tree. Fixed tests, added doc.
Package-Manager: portage-2.1.10.7/cvs/Linux x86_64
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyamg/ChangeLog19
-rw-r--r--dev-python/pyamg/Manifest14
-rw-r--r--dev-python/pyamg/metadata.xml21
-rw-r--r--dev-python/pyamg/pyamg-2.0.0.ebuild53
4 files changed, 107 insertions, 0 deletions
diff --git a/dev-python/pyamg/ChangeLog b/dev-python/pyamg/ChangeLog
new file mode 100644
index 000000000000..eb6fd27fb2e2
--- /dev/null
+++ b/dev-python/pyamg/ChangeLog
@@ -0,0 +1,19 @@
+# ChangeLog for dev-python/pyamg
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyamg/ChangeLog,v 1.1 2011/07/26 19:09:17 bicatali Exp $
+
+ 26 Jul 2011; Sébastien Fabbro <bicatali@gentoo.org> +pyamg-2.0.0.ebuild,
+ +metadata.xml:
+ Initial import to the main tree. Fixed tests, added doc.
+
+*pyamg-2.0.0 (21 Mar 2011)
+
+ 21 Mar 2011; Nico Schlömer <nico.schloemer@gmail.com>
+ +pyamg-2.0.0.ebuild:
+ bumped to 2.0.0
+
+*pyamg-1.0.0 (13 Dec 2010)
+
+ 13 December 2010; Nico Schlömer <nico.schloemer@gmail.com>
+ +metadata.xml, +pyamg-1.0.0.ebuild:
+ Initial import.
diff --git a/dev-python/pyamg/Manifest b/dev-python/pyamg/Manifest
new file mode 100644
index 000000000000..c3a8df05782f
--- /dev/null
+++ b/dev-python/pyamg/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST pyamg-2.0.0.tar.gz 1364498 RMD160 4de005d7716042e0e90877996564de14c60455fd SHA1 ffb7fef3f29b5aeb0b2ff3155ee871e865d9fb00 SHA256 293e85e61b245f034e2346d9ecc476e084148fa68084eab267cffdd269f30c2b
+EBUILD pyamg-2.0.0.ebuild 1297 RMD160 501b7906ab3e2ba37fb38af4889c9b64ed06049c SHA1 6d3a853e4ddddb08dc3468f830754549875c542a SHA256 a5803b4bb6122068dad33c638c16ac1326f1dc165a334bba85ef5cbcc43b7561
+MISC ChangeLog 633 RMD160 3e58e517c38b1f45e4f452cf6c106c05cba36346 SHA1 b253ad0202127583c3ae86ea7ac59d658ada5411 SHA256 2d3df61ad410db2171309fccbc4f988d72121bffff9a2ac7c65c1e5a1911ec50
+MISC metadata.xml 972 RMD160 21aee9bd738add10d04bf9520162b0ed6cbcb188 SHA1 8d4fff40f607044a8f157cc41645d13675aa7f38 SHA256 b9cc96bfec5b7d61edff3e321eaa59a7d815c61049087e117476b53ffe15714c
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iEYEARECAAYFAk4vEOYACgkQ1ycZbhPLE2Al2ACgjAe5Drlh5yZfCaBcEx1QsP20
+5KgAoI1wYxjWks7sxgcnUcJPZVBgKSa6
+=cQdP
+-----END PGP SIGNATURE-----
diff --git a/dev-python/pyamg/metadata.xml b/dev-python/pyamg/metadata.xml
new file mode 100644
index 000000000000..26e721d94308
--- /dev/null
+++ b/dev-python/pyamg/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ AMG is a multilevel technique for solving large-scale linear systems
+ with optimal or near-optimal efficiency. Unlike geometric multigrid,
+ AMG requires little or no geometric information about the underlying
+ problem and develops a sequence of coarser grids directly from the
+ input matrix. This feature is especially important for problems
+ discretized on unstructured meshes and irregular grids.
+ PyAMG features implementations of:
+ * Ruge-Stuben (RS) or Classical AMG
+ * AMG based on Smoothed Aggregation (SA)
+ and experimental support for:
+ * Adaptive Smoothed Aggregation (αSA)
+ * Compatible Relaxation (CR)
+ The predominant portion of PyAMG is written in Python with a smaller
+ amount of supporting C++ code for performance critical operations.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/pyamg/pyamg-2.0.0.ebuild b/dev-python/pyamg/pyamg-2.0.0.ebuild
new file mode 100644
index 000000000000..efd0125ca1c9
--- /dev/null
+++ b/dev-python/pyamg/pyamg-2.0.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyamg/pyamg-2.0.0.ebuild,v 1.1 2011/07/26 19:09:17 bicatali Exp $
+
+EAPI=3
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Algebraic multigrid solvers in Python"
+HOMEPAGE="http://code.google.com/p/pyamg/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc test"
+
+RESTRICT="test" # quite buggy
+
+RDEPEND="sci-libs/scipy"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/nose )"
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ cd "${S}/Docs"
+ PYTHONPATH=$(ls -d "${S}"/build-$(PYTHON -f --ABI)/lib*) emake html
+ fi
+}
+
+src_test() {
+ testing() {
+ "$(PYTHON)" setup.py \
+ build -b "build-${PYTHON_ABI}" \
+ install --home="${S}/test-${PYTHON_ABI}"
+ pushd "${S}/test-${PYTHON_ABI}/lib/python" > /dev/null
+ PYTHONPATH=. "$(PYTHON)" -c "import pyamg; pyamg.test()" 2>&1 | tee test.log
+ grep -Eq "^(ERROR|FAIL):" test.log && return 1
+ popd > /dev/null
+ rm -fr test-${PYTHON_ABI}
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ use doc && dohtml -r Docs/build/html/*
+}