summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-03-19 06:41:56 +0000
committerMichał Górny <mgorny@gentoo.org>2013-03-19 06:41:56 +0000
commit0ce3582374b1ea746fc90e6378e7e8ec0adbe5fc (patch)
tree25ad154e960c1733c5914c42f8afac4959bdae8d /dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild
parentQt version detection fixed, closing #461658; thanks to Reinis Danne <rei4dan@... (diff)
downloadhistorical-0ce3582374b1ea746fc90e6378e7e8ec0adbe5fc.tar.gz
historical-0ce3582374b1ea746fc90e6378e7e8ec0adbe5fc.tar.bz2
historical-0ce3582374b1ea746fc90e6378e7e8ec0adbe5fc.zip
Use separate platlib & purelib build directory, fixes bug #455332.
Package-Manager: portage-2.2.0_alpha166/cvs/Linux x86_64 Manifest-Sign-Key: 0x9627F456F9DA7643!
Diffstat (limited to 'dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild')
-rw-r--r--dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild b/dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild
index dc0f71c5a723..85f04f8c3206 100644
--- a/dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild
+++ b/dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild,v 1.2 2013/03/04 06:15:37 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild,v 1.3 2013/03/19 06:41:44 mgorny Exp $
EAPI=5
@@ -84,8 +84,15 @@ python_configure_all() {
)
}
+python_compile() {
+ # We need to have separate libdirs due to hackery, bug #455332.
+ distutils-r1_python_compile \
+ build --build-purelib "${BUILD_DIR}"/lib.common
+}
+
python_install() {
- distutils-r1_python_install
+ distutils-r1_python_install \
+ build --build-purelib "${BUILD_DIR}"/lib.common
# adjust the filenames for wxPython slots.
local file