summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-10-11 08:38:25 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-10-11 08:38:25 +0000
commit6c602ffdd10ed4cb7fc0ce7369bfaa28cc5197d1 (patch)
treec1e1c698a7cdc1c2525a60892dba7763b16766ad /dev-python/validation
parentversion bump, source is now inside archetypes (diff)
downloadhistorical-6c602ffdd10ed4cb7fc0ce7369bfaa28cc5197d1.tar.gz
historical-6c602ffdd10ed4cb7fc0ce7369bfaa28cc5197d1.tar.bz2
historical-6c602ffdd10ed4cb7fc0ce7369bfaa28cc5197d1.zip
version bump, source is now inside archetypes
Diffstat (limited to 'dev-python/validation')
-rw-r--r--dev-python/validation/Manifest4
-rw-r--r--dev-python/validation/files/digest-validation-1.0.11
-rw-r--r--dev-python/validation/validation-1.0.1.ebuild44
3 files changed, 47 insertions, 2 deletions
diff --git a/dev-python/validation/Manifest b/dev-python/validation/Manifest
index 059a7527f011..113c4706ed7b 100644
--- a/dev-python/validation/Manifest
+++ b/dev-python/validation/Manifest
@@ -1,6 +1,6 @@
-MD5 103d0ff6ab879a2dda537aefe29b627d validation-1.0.1.ebuild 1264
+MD5 348f51bce7c7837c899db21969297fe0 validation-1.0.1.ebuild 1266
MD5 b61ff26d1df283c70a35d6a3259d5807 validation-1.0.ebuild 1197
-MD5 2929fa3b5be21c94a079e9278ccb06d1 ChangeLog 413
+MD5 27efc6048224d65479059b2f75329201 ChangeLog 573
MD5 7890d88c5c6d189fbe6b187a3ebb6532 metadata.xml 161
MD5 12418119718245666bf678e376f890e7 files/digest-validation-1.0 64
MD5 223af5173c7341daf23e517d356b0a0e files/digest-validation-1.0.1 65
diff --git a/dev-python/validation/files/digest-validation-1.0.1 b/dev-python/validation/files/digest-validation-1.0.1
new file mode 100644
index 000000000000..ff4e085f1de3
--- /dev/null
+++ b/dev-python/validation/files/digest-validation-1.0.1
@@ -0,0 +1 @@
+MD5 53f3ccf5a88ce3a91b50e8a82165c2de archetypes-1.0.1.tgz 342999
diff --git a/dev-python/validation/validation-1.0.1.ebuild b/dev-python/validation/validation-1.0.1.ebuild
new file mode 100644
index 000000000000..5aa244a04258
--- /dev/null
+++ b/dev-python/validation/validation-1.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/validation/validation-1.0.1.ebuild,v 1.1 2003/10/11 08:38:22 robbat2 Exp $
+SLOT=0
+IUSE=""
+DESCRIPTION="Generic validators originally defined for Archetypes"
+SRC_PN=archetypes
+SRC_PV=1.0.1
+SRC_P=${SRC_PN}-${SRC_PV}
+SRC_URI="mirror://sourceforge/${SRC_PN}/${SRC_P}.tgz"
+S=${WORKDIR}/${SRC_P}/${PN}
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+if [ "${PYTHON_SLOT_VERSION}" = 'VIRTUAL' ] ; then
+ RDEPEND="virtual/python"
+else
+ RDEPEND="dev-lang/python"
+fi
+DEPEND="${RDEPEND}"
+
+src_install() {
+ local python=""
+ if [ "${PYTHON_SLOT_VERSION}" = 'VIRTUAL' ] ; then
+ python='python'
+ einfo "Building with virtual python"
+ else
+ if has_version '=dev-lang/python-2.1*'; then
+ python="${python} python2.1"
+ einfo "Building with Python 2.1"
+ fi
+ if has_version '=dev-lang/python-2.2*'; then
+ python="${python} python2.2"
+ einfo "Building with Python 2.2"
+ fi
+ fi
+
+ for i in ${python}; do
+ $i setup.py clean
+ # ok, so this actually compiles them here, but it was the only way I could find to
+ # compile both versions
+ $i setup.py build install --prefix=${D}/usr || die
+ done;
+ dodoc ChangeLog PKG-INFO README
+}