summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2009-07-25 16:13:11 +0000
committerJesus Rivero <neurogeek@gentoo.org>2009-07-25 16:13:11 +0000
commit8dd6578930f6723de75f204208e31d9bcc5c2753 (patch)
tree8c59a8af8c4cb45d08b63d62c4670521650d8929 /dev-python/utidylib/utidylib-0.2-r1.ebuild
parentVersion bump. Remove old. (diff)
downloadhistorical-8dd6578930f6723de75f204208e31d9bcc5c2753.tar.gz
historical-8dd6578930f6723de75f204208e31d9bcc5c2753.tar.bz2
historical-8dd6578930f6723de75f204208e31d9bcc5c2753.zip
Revision bump. Fixed tests. Closes bug #276881
Package-Manager: portage-2.2_rc23/cvs/Linux i686
Diffstat (limited to 'dev-python/utidylib/utidylib-0.2-r1.ebuild')
-rw-r--r--dev-python/utidylib/utidylib-0.2-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/utidylib/utidylib-0.2-r1.ebuild b/dev-python/utidylib/utidylib-0.2-r1.ebuild
new file mode 100644
index 000000000000..2fa98c202f24
--- /dev/null
+++ b/dev-python/utidylib/utidylib-0.2-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/utidylib/utidylib-0.2-r1.ebuild,v 1.1 2009/07/25 16:13:11 neurogeek Exp $
+
+EAPI="2"
+inherit distutils
+
+MY_P="uTidylib-${PV}"
+
+DESCRIPTION="TidyLib Python wrapper"
+HOMEPAGE="http://utidylib.berlios.de/"
+SRC_URI="mirror://berlios/${PN}/${MY_P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-lang/python-2.3
+ app-text/htmltidy
+ dev-python/ctypes"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ doc? ( dev-python/epydoc )
+ test? ( dev-python/twisted )"
+
+PYTHON_MODNAME="tidy"
+S="${WORKDIR}/${MY_P}"
+
+src_prepare(){
+ epatch "${FILESDIR}/${P}-no-docs-in-site-packages.patch"
+ epatch "${FILESDIR}/${P}-fix_tests.patch"
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ python gendoc.py || die "building api docs failed"
+ fi
+}
+
+src_test() {
+ einfo "${S}"
+ einfo "$(ls ${S}/foo.htm)"
+ PYTHONPATH="." trial tidy || die "tests failed"
+}
+
+src_install() {
+ distutils_src_install
+ use doc && dohtml -r apidoc
+}