summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-28 17:54:40 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-28 17:54:40 +0000
commit72979143a675ad0463e6429d344e2c6bedb42643 (patch)
tree0f72bdc849e53030806a2c1f0d67107b38ebeddc /dev-python/twistedsnmp
parentalpha/ia64/sparc stable wrt #281427 (diff)
downloadhistorical-72979143a675ad0463e6429d344e2c6bedb42643.tar.gz
historical-72979143a675ad0463e6429d344e2c6bedb42643.tar.bz2
historical-72979143a675ad0463e6429d344e2c6bedb42643.zip
Version bump. Set SUPPORT_PYTHON_ABIS. Fix dependencies (bug #266763).
Package-Manager: portage-14914-svn/cvs/Linux x86_64
Diffstat (limited to 'dev-python/twistedsnmp')
-rw-r--r--dev-python/twistedsnmp/ChangeLog8
-rw-r--r--dev-python/twistedsnmp/twistedsnmp-0.3.13.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-python/twistedsnmp/ChangeLog b/dev-python/twistedsnmp/ChangeLog
index c6bb8b841012..9cb1390a6299 100644
--- a/dev-python/twistedsnmp/ChangeLog
+++ b/dev-python/twistedsnmp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/twistedsnmp
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twistedsnmp/ChangeLog,v 1.5 2009/02/15 14:22:35 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twistedsnmp/ChangeLog,v 1.6 2009/11/28 17:54:40 arfrever Exp $
+
+*twistedsnmp-0.3.13 (28 Nov 2009)
+
+ 28 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +twistedsnmp-0.3.13.ebuild:
+ Version bump. Set SUPPORT_PYTHON_ABIS. Fix dependencies (bug #266763).
*twistedsnmp-0.3.12 (15 Feb 2009)
diff --git a/dev-python/twistedsnmp/twistedsnmp-0.3.13.ebuild b/dev-python/twistedsnmp/twistedsnmp-0.3.13.ebuild
new file mode 100644
index 000000000000..3a6b09c32957
--- /dev/null
+++ b/dev-python/twistedsnmp/twistedsnmp-0.3.13.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twistedsnmp/twistedsnmp-0.3.13.ebuild,v 1.1 2009/11/28 17:54:40 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="TwistedSNMP"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="SNMP protocols and APIs for use with the Twisted networking framework"
+HOMEPAGE="http://twistedsnmp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="=dev-python/pysnmp-3*
+ >=dev-python/twisted-1.3"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose )"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" nosetests-${PYTHON_ABI}
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ dohtml doc/index.html
+ insinto /usr/share/doc/${PF}/html/style/
+ doins doc/style/sitestyle.css
+}