summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2007-01-11 22:13:21 +0000
committerMarien Zwart <marienz@gentoo.org>2007-01-11 22:13:21 +0000
commitc795ce9527daa1b67c435f8cbfee1b8159b3fdab (patch)
tree44eb59bbda7959f3dd6458f568a28fbed3bc6a24 /dev-python/twisted-web
parentVersion bump, drop revision patched to work with python 2.5 (use the new bump... (diff)
downloadhistorical-c795ce9527daa1b67c435f8cbfee1b8159b3fdab.tar.gz
historical-c795ce9527daa1b67c435f8cbfee1b8159b3fdab.tar.bz2
historical-c795ce9527daa1b67c435f8cbfee1b8159b3fdab.zip
Version bump, make twisted dependency stricter, drop revision patched to work with python 2.5 (use the new bump instead).
Package-Manager: portage-2.1.2_rc4-r8
Diffstat (limited to 'dev-python/twisted-web')
-rw-r--r--dev-python/twisted-web/ChangeLog11
-rw-r--r--dev-python/twisted-web/files/digest-twisted-web-0.7.03
-rw-r--r--dev-python/twisted-web/twisted-web-0.6.0.ebuild6
-rw-r--r--dev-python/twisted-web/twisted-web-0.7.0.ebuild19
4 files changed, 34 insertions, 5 deletions
diff --git a/dev-python/twisted-web/ChangeLog b/dev-python/twisted-web/ChangeLog
index 4164ed002650..3149add80234 100644
--- a/dev-python/twisted-web/ChangeLog
+++ b/dev-python/twisted-web/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/twisted-web
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/ChangeLog,v 1.25 2006/10/20 20:39:20 kloeri Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/ChangeLog,v 1.26 2007/01/11 22:13:21 marienz Exp $
+
+*twisted-web-0.7.0 (11 Jan 2007)
+
+ 11 Jan 2007; Marien Zwart <marienz@gentoo.org> twisted-web-0.6.0.ebuild,
+ -twisted-web-0.6.0-r1.ebuild, +twisted-web-0.7.0.ebuild:
+ Version bump, make twisted dependency stricter, drop revision patched to
+ work with python 2.5 (use the new bump instead).
20 Oct 2006; Bryan Østergaard <kloeri@gentoo.org>
twisted-web-0.6.0.ebuild:
diff --git a/dev-python/twisted-web/files/digest-twisted-web-0.7.0 b/dev-python/twisted-web/files/digest-twisted-web-0.7.0
new file mode 100644
index 000000000000..4c80162dbc7b
--- /dev/null
+++ b/dev-python/twisted-web/files/digest-twisted-web-0.7.0
@@ -0,0 +1,3 @@
+MD5 de55ee18f843bcc6372d34eb88a27c21 TwistedWeb-0.7.0.tar.bz2 263183
+RMD160 7e1c2cf1a2984a298bd2af3d3d983f559ed43e00 TwistedWeb-0.7.0.tar.bz2 263183
+SHA256 7b934d11d3920c18e1f85fb78352b5b232fa68c10ec218085abdedd167a380f1 TwistedWeb-0.7.0.tar.bz2 263183
diff --git a/dev-python/twisted-web/twisted-web-0.6.0.ebuild b/dev-python/twisted-web/twisted-web-0.6.0.ebuild
index fa19602c0a8d..d6c131a49998 100644
--- a/dev-python/twisted-web/twisted-web-0.6.0.ebuild
+++ b/dev-python/twisted-web/twisted-web-0.6.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/twisted-web-0.6.0.ebuild,v 1.8 2006/10/20 20:39:20 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/twisted-web-0.6.0.ebuild,v 1.9 2007/01/11 22:13:21 marienz Exp $
MY_PACKAGE=Web
@@ -10,7 +10,7 @@ DESCRIPTION="Twisted web server, programmable in Python"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh ~sparc ~x86"
-DEPEND=">=dev-python/twisted-2.4"
+DEPEND="=dev-python/twisted-2.4*"
src_unpack() {
unpack ${A}
diff --git a/dev-python/twisted-web/twisted-web-0.7.0.ebuild b/dev-python/twisted-web/twisted-web-0.7.0.ebuild
new file mode 100644
index 000000000000..9f3326c86e07
--- /dev/null
+++ b/dev-python/twisted-web/twisted-web-0.7.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/twisted-web-0.7.0.ebuild,v 1.1 2007/01/11 22:13:21 marienz Exp $
+
+MY_PACKAGE=Web
+
+inherit twisted eutils
+
+DESCRIPTION="Twisted web server, programmable in Python"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DEPEND="=dev-python/twisted-2.5*"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.5.0-root-skip.patch"
+}