summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-06 14:58:24 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-06 14:58:24 +0000
commitdde707abe7a5ff83e19a9d681a2aeb6ca73f13a0 (patch)
tree6bb87ed8c82b8ee08d27d4d5b7680043eda09dd4 /dev-python/traits
parentDelete older ebuild. (diff)
downloadhistorical-dde707abe7a5ff83e19a9d681a2aeb6ca73f13a0.tar.gz
historical-dde707abe7a5ff83e19a9d681a2aeb6ca73f13a0.tar.bz2
historical-dde707abe7a5ff83e19a9d681a2aeb6ca73f13a0.zip
Use $(PYTHON -f) instead of ${python}.
Package-Manager: portage-15324-svn/cvs/Linux x86_64
Diffstat (limited to 'dev-python/traits')
-rw-r--r--dev-python/traits/traits-3.2.0.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/traits/traits-3.2.0.ebuild b/dev-python/traits/traits-3.2.0.ebuild
index c9177fb6ed37..3b3fc6acdb8f 100644
--- a/dev-python/traits/traits-3.2.0.ebuild
+++ b/dev-python/traits/traits-3.2.0.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/traits-3.2.0.ebuild,v 1.5 2009/11/08 19:57:11 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/traits-3.2.0.ebuild,v 1.6 2010/02/06 14:53:27 arfrever Exp $
EAPI="2"
+PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
inherit distutils
@@ -38,8 +39,7 @@ src_prepare() {
src_compile() {
distutils_src_compile
if use doc; then
- "${python}" setup.py build_docs --formats=html \
- || die "doc building failed"
+ "$(PYTHON -f)" setup.py build_docs --formats=html || die "Generation of documentation failed"
fi
}