summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-01-17 06:24:19 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-01-17 06:24:19 +0000
commit12a9d6a0f2cad6129f9423ecc4d08744f13e7023 (patch)
treebd0e203bc788e81799bae1d5adaab781a99a0251 /dev-python/traits
parentEAPI bump (diff)
downloadhistorical-12a9d6a0f2cad6129f9423ecc4d08744f13e7023.tar.gz
historical-12a9d6a0f2cad6129f9423ecc4d08744f13e7023.tar.bz2
historical-12a9d6a0f2cad6129f9423ecc4d08744f13e7023.zip
Version bump
Package-Manager: portage-2.1.10.41/cvs/Linux x86_64
Diffstat (limited to 'dev-python/traits')
-rw-r--r--dev-python/traits/ChangeLog9
-rw-r--r--dev-python/traits/traits-4.1.0.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/dev-python/traits/ChangeLog b/dev-python/traits/ChangeLog
index 558a9969f9a0..d0f20580f681 100644
--- a/dev-python/traits/ChangeLog
+++ b/dev-python/traits/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/traits
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/ChangeLog,v 1.26 2011/08/04 00:05:56 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/ChangeLog,v 1.27 2012/01/17 06:15:58 bicatali Exp $
+
+*traits-4.1.0 (17 Jan 2012)
+
+ 17 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org> +traits-4.1.0.ebuild:
+ Version bump
04 Aug 2011; Sébastien Fabbro <bicatali@gentoo.org> traits-4.0.0.ebuild:
Typo
diff --git a/dev-python/traits/traits-4.1.0.ebuild b/dev-python/traits/traits-4.1.0.ebuild
new file mode 100644
index 000000000000..8e6d1006e6ea
--- /dev/null
+++ b/dev-python/traits/traits-4.1.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/traits-4.1.0.ebuild,v 1.1 2012/01/17 06:15:58 bicatali Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils virtualx
+
+DESCRIPTION="Enthought Tool Suite: Explicitly typed attributes for Python"
+HOMEPAGE="http://code.enthought.com/projects/traits/ http://pypi.python.org/pypi/traits"
+SRC_URI="http://www.enthought.com/repo/ETS/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="dev-python/numpy"
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/numpy )"
+
+DOCS="docs/*.txt"
+
+src_prepare() {
+ sed -i -e "s/'-O3'//g" setup.py
+}
+
+src_compile() {
+ distutils_src_compile
+ use doc && virtualmake -C docs html
+}
+
+src_install() {
+ find -name "*LICENSE*.txt" -delete
+ distutils_src_install
+
+ use doc && dohtml -r docs/build/html/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}