summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-01-16 17:32:07 +0000
committerIan Delaney <idella4@gentoo.org>2013-01-16 17:32:07 +0000
commit8ff8ea70b5d1e4d18ec2593cd60fd3596cacbca0 (patch)
tree6ebf50e2f2cfcf36b37431f858ed8eb0ae98c27d /dev-python/tinycss/tinycss-0.2-r1.ebuild
parentFix bug #451180, adds system-jpeg useflag, add support for hardened (diff)
downloadhistorical-8ff8ea70b5d1e4d18ec2593cd60fd3596cacbca0.tar.gz
historical-8ff8ea70b5d1e4d18ec2593cd60fd3596cacbca0.tar.bz2
historical-8ff8ea70b5d1e4d18ec2593cd60fd3596cacbca0.zip
revbump; added pypy support, test suite uncovered and addressed yielding a single test fail, ref Bug 452580, deps render unsuitable for migration to -r1 eclass
Package-Manager: portage-2.1.11.40/cvs/Linux x86_64 Manifest-Sign-Key: 0xB8072B0D
Diffstat (limited to 'dev-python/tinycss/tinycss-0.2-r1.ebuild')
-rw-r--r--dev-python/tinycss/tinycss-0.2-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/tinycss/tinycss-0.2-r1.ebuild b/dev-python/tinycss/tinycss-0.2-r1.ebuild
new file mode 100644
index 000000000000..e66fea44dcc4
--- /dev/null
+++ b/dev-python/tinycss/tinycss-0.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tinycss/tinycss-0.2-r1.ebuild,v 1.1 2013/01/16 17:31:30 idella4 Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.7 3:3.2"
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="2.5 2.6 3.1 *-jython"
+DISTUTILS_SRC_TEST="py.test"
+inherit distutils
+
+DESCRIPTION="A complete yet simple CSS parser for Python"
+HOMEPAGE="http://github.com/SimonSapin/tinycss/ http://packages.python.org/tinycss/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/lxml"
+DEPEND="${RDEPEND}"
+
+DOCS="CHANGES README.rst"
+
+src_test() {
+ export TINYCSS_SKIP_SPEEDUPS_TESTS=1
+ testing() {
+ for test in ${PN}/tests/test_*.py; do
+ PYTHONPATH=. py.test $test
+ done
+ }
+ python_execute_function testing
+}