summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Hoffmann <hoffie@gentoo.org>2008-03-19 21:30:07 +0000
committerChristian Hoffmann <hoffie@gentoo.org>2008-03-19 21:30:07 +0000
commit9dc90f6bd30ec7323b742fc8e5efb72a862d476d (patch)
tree5b7316597803f27507e4968dcf6dfffcec4c8464 /dev-python/storm
parentNon-maintainer-commit: Version bump for security bug 212364 (CVE-2008-0047). (diff)
downloadhistorical-9dc90f6bd30ec7323b742fc8e5efb72a862d476d.tar.gz
historical-9dc90f6bd30ec7323b742fc8e5efb72a862d476d.tar.bz2
historical-9dc90f6bd30ec7323b742fc8e5efb72a862d476d.zip
version bump to 0.12, marking ~amd64
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'dev-python/storm')
-rw-r--r--dev-python/storm/ChangeLog10
-rw-r--r--dev-python/storm/Manifest14
-rw-r--r--dev-python/storm/storm-0.12.ebuild42
3 files changed, 63 insertions, 3 deletions
diff --git a/dev-python/storm/ChangeLog b/dev-python/storm/ChangeLog
index 13ca819898f7..e4ec9d3b2b97 100644
--- a/dev-python/storm/ChangeLog
+++ b/dev-python/storm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/storm
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/storm/ChangeLog,v 1.1 2007/07/10 14:41:39 dev-zero Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/storm/ChangeLog,v 1.2 2008/03/19 21:30:07 hoffie Exp $
+
+*storm-0.12 (19 Mar 2008)
+
+ 19 Mar 2008; Christian Hoffmann <hoffie@gentoo.org> +storm-0.12.ebuild:
+ version bump to 0.12, also marking ~amd64 as it works fine for me on that
+ arch
*storm-0.9 (10 Jul 2007)
diff --git a/dev-python/storm/Manifest b/dev-python/storm/Manifest
index c97afa62b5db..dd1f39ede748 100644
--- a/dev-python/storm/Manifest
+++ b/dev-python/storm/Manifest
@@ -1,4 +1,16 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST storm-0.12.tar.bz2 120008 RMD160 1ea6cb55b87cf3a2eed6f0509d05d7a3fbe40b92 SHA1 01cd20343d5a08fb8a9d78322c59344b54efcf89 SHA256 4bb914edb4e8fb14ef2955d46a9aae3e0b2ad742797bd6ac3f84520d06e52cbc
DIST storm-0.9.tar.bz2 86352 RMD160 5bf2039f3356645c1a823803406e85f90ca4d6a5 SHA1 fc079236b36566b945b94a835fd4d083c17cf5ee SHA256 8318c3229dfdb0e360cc6d3273aa472b4c6993812f848ece6d0818bb534f17d6
+EBUILD storm-0.12.ebuild 1504 RMD160 82d7b52ebd21dacbb825dfa2281b0f207b4512af SHA1 ffd8c96170a0fff96805c303350fefe2fc06a1f4 SHA256 5eb07267fbb1c7fd6a055cf4c625132f8ca9728a09cbc84aaf770816132c3c21
EBUILD storm-0.9.ebuild 1685 RMD160 ab68b489c221ceba739a0352e121513d9b8a5018 SHA1 594dba33fcbd8bbecf2b26abe6254f7bdc3b9500 SHA256 d7518fe752831b0b04014bd476dd41f00a1face5f9bad0b4fa26884d068620a3
-MISC ChangeLog 341 RMD160 dd34965cc0197b703f893415763ca33bce401916 SHA1 b25a5dfdbad157220d6a3e03cc3795e994fca8c0 SHA256 12a0a19aa503e76bbade63e8405b990fd7d2083fd0c1ec6e3caa033d03f19bab
+MISC ChangeLog 524 RMD160 8805824906254861b8745cedd5e82f69ced11795 SHA1 7ee33ff5e88fd456bf4777724f8d38ce8724536f SHA256 df927bf6fba35b1ad9ff50eb14aac400a425ee365023cca211380f3c2d7cb067
MISC metadata.xml 159 RMD160 900a8c55d7a7d2f6312594769aaf941bf9e99c7f SHA1 c8e604d56dae898258b5254d78cfeac0b981e288 SHA256 9f01104d3484792496faff4805eed0ecea2352a897151f3397d49a13800037b4
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.7 (GNU/Linux)
+
+iD8DBQFH4YXnJ9KLJlGHWYIRAt2DAKDfR+R7QR8zUuoec+E1PXJYIcQ1iwCeIvr/
+iCUHi2Ni6cDW4OV9z2KF8Z4=
+=TTxC
+-----END PGP SIGNATURE-----
diff --git a/dev-python/storm/storm-0.12.ebuild b/dev-python/storm/storm-0.12.ebuild
new file mode 100644
index 000000000000..1411962bf42d
--- /dev/null
+++ b/dev-python/storm/storm-0.12.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/storm/storm-0.12.ebuild,v 1.1 2008/03/19 21:30:07 hoffie Exp $
+
+NEED_PYTHON=2.4
+
+inherit distutils
+
+DESCRIPTION="An object-relational mapper for Python developed at Canonical."
+HOMEPAGE="https://storm.canonical.com/FrontPage"
+SRC_URI="https://launchpad.net/storm/trunk/${PV}/+download/${P}.tar.bz2"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="mysql postgres sqlite test"
+
+RDEPEND="mysql? ( dev-python/mysql-python )
+ postgres? ( =dev-python/psycopg-2* )
+ sqlite? ( || ( dev-python/pysqlite >=dev-lang/python-2.5 ) )"
+DEPEND="${DEPEND}
+ test? ( || ( dev-python/pysqlite >=dev-lang/python-2.5 ) )"
+
+DOCS="tests/tutorial.txt"
+
+src_test() {
+ if use postgres ; then
+ elog "To run the PostgreSQL-tests, you need:"
+ elog " - a running postgresql-server"
+ elog " - an already existing database 'db'"
+ elog " - a user 'user' with full permissions on that database"
+ elog " - and an environment variable STORM_POSTGRES_URI=\"postgres://user:password@host:1234/db\""
+ fi
+ if use mysql ; then
+ elog "To run the MySQL-tests, you need:"
+ elog " - a running mysql-server"
+ elog " - an already existing database 'db'"
+ elog " - a user 'user' with full permissions on that database"
+ elog " - and an environment variable STORM_MYSQL_URI=\"mysql://user:password@host:1234/db\""
+ fi
+
+ PYTHONPATH=. "${python}" test || die "tests failed"
+}