summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-03-21 04:59:04 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-03-21 04:59:04 +0000
commitcae2d07aa7571679303bd6c0aaea137a8fd3599b (patch)
tree9db79ea42b5bd7cd88e5f2f1b577d4eb9ac12960 /dev-python/skype4py/skype4py-1.0.31.0.ebuild
parentStable for HPPA (bug #261569). (diff)
downloadhistorical-cae2d07aa7571679303bd6c0aaea137a8fd3599b.tar.gz
historical-cae2d07aa7571679303bd6c0aaea137a8fd3599b.tar.bz2
historical-cae2d07aa7571679303bd6c0aaea137a8fd3599b.zip
New package. Initial ebuild by Michal Slonina, modified by me. bug 257481
Package-Manager: portage-2.1.6.7/cvs/Linux x86_64
Diffstat (limited to 'dev-python/skype4py/skype4py-1.0.31.0.ebuild')
-rw-r--r--dev-python/skype4py/skype4py-1.0.31.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/skype4py/skype4py-1.0.31.0.ebuild b/dev-python/skype4py/skype4py-1.0.31.0.ebuild
new file mode 100644
index 000000000000..7eb6fed11b58
--- /dev/null
+++ b/dev-python/skype4py/skype4py-1.0.31.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/skype4py/skype4py-1.0.31.0.ebuild,v 1.1 2009/03/21 04:59:04 darkside Exp $
+
+inherit distutils
+
+DESCRIPTION="Python wrapper for the Skype API."
+HOMEPAGE="https://developer.skype.com/wiki/Skype4Py"
+SRC_URI="mirror://sourceforge/${PN}/Skype4Py-${PV}.tar.gz
+ doc? ( mirror://sourceforge/${PN}/Skype4Py-${PV}-htmldoc.zip )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/Skype4Py-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ use doc && mv "${WORKDIR}/Skype4Py-${PV}-htmldoc" "${S}/html_doc"
+}
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ dohtml html_doc/* || die "dohtml failed"
+ fi
+}