summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-07-03 04:27:53 +0000
committerAli Polatel <hawking@gentoo.org>2007-07-03 04:27:53 +0000
commit2ee3b7ca1dc5b71d7e0ba4e8955a731637d752bf (patch)
tree0ff67e5b335f2c78548f8c854a570a29f52fdc01 /dev-python/pyxml/pyxml-0.8.4-r1.ebuild
parentfoldingathome-5.91_beta has expired. Removing KEYWORDS until the next release... (diff)
downloadhistorical-2ee3b7ca1dc5b71d7e0ba4e8955a731637d752bf.tar.gz
historical-2ee3b7ca1dc5b71d7e0ba4e8955a731637d752bf.tar.bz2
historical-2ee3b7ca1dc5b71d7e0ba4e8955a731637d752bf.zip
revbump, fixes bug 178920, drop ~ppc-macos keyword, add doc,examples USE flag and src_test
Package-Manager: portage-2.1.3_rc6
Diffstat (limited to 'dev-python/pyxml/pyxml-0.8.4-r1.ebuild')
-rw-r--r--dev-python/pyxml/pyxml-0.8.4-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pyxml/pyxml-0.8.4-r1.ebuild b/dev-python/pyxml/pyxml-0.8.4-r1.ebuild
new file mode 100644
index 000000000000..257d5513b7d4
--- /dev/null
+++ b/dev-python/pyxml/pyxml-0.8.4-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxml/pyxml-0.8.4-r1.ebuild,v 1.1 2007/07/03 04:27:53 hawking Exp $
+
+inherit python distutils
+
+MY_P=${P/pyxml/PyXML}
+
+DESCRIPTION="A collection of libraries to process XML with Python"
+HOMEPAGE="http://pyxml.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="PYTHON"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sh sparc x86 ~x86-fbsd"
+IUSE="doc examples"
+
+DEPEND=">=dev-libs/expat-1.95.6"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ local myconf
+
+ # if you want to use 4Suite, then their XSLT/XPATH is
+ # better according to the docs
+ if has_version "dev-python/4suite"; then
+ myconf="--without-xslt --without-xpath"
+ fi
+
+ # use the already-installed shared copy of libexpat
+ distutils_src_compile --with-libexpat=/usr ${myconf}
+}
+
+src_install() {
+ DOCS="ANNOUNCE CREDITS doc/*.txt"
+ distutils_src_install
+
+ doman doc/man/*
+ if use doc; then
+ dohtml -A api,web -r doc/*
+ insinto /usr/share/doc/${PF} && doins doc/*.tex
+ fi
+ use examples && cp -r demo ${D}/usr/share/doc/${PF}
+}
+
+src_test() {
+ cd test
+ PYTHONPATH="$(ls -d ../build/lib.*)" "${python}" regrtest.py \
+ || die "tests failed"
+}