summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-28 22:01:02 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-28 22:01:02 +0000
commitfa57bab9e672230a1a32fa9b94c57eed4886f1a6 (patch)
treef69cdf613c70d7540c74041431590f1d83040465 /dev-python/python-xlib/python-xlib-0.14.ebuild
parentDelete older ebuild. (diff)
downloadhistorical-fa57bab9e672230a1a32fa9b94c57eed4886f1a6.tar.gz
historical-fa57bab9e672230a1a32fa9b94c57eed4886f1a6.tar.bz2
historical-fa57bab9e672230a1a32fa9b94c57eed4886f1a6.zip
Set SUPPORT_PYTHON_ABIS.
Package-Manager: portage-HEAD/cvs/Linux x86_64
Diffstat (limited to 'dev-python/python-xlib/python-xlib-0.14.ebuild')
-rw-r--r--dev-python/python-xlib/python-xlib-0.14.ebuild44
1 files changed, 31 insertions, 13 deletions
diff --git a/dev-python/python-xlib/python-xlib-0.14.ebuild b/dev-python/python-xlib/python-xlib-0.14.ebuild
index cd8d2a2da6f3..97033a2f3556 100644
--- a/dev-python/python-xlib/python-xlib-0.14.ebuild
+++ b/dev-python/python-xlib/python-xlib-0.14.ebuild
@@ -1,41 +1,59 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-xlib/python-xlib-0.14.ebuild,v 1.7 2009/11/14 16:35:31 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-xlib/python-xlib-0.14.ebuild,v 1.8 2010/05/28 22:01:02 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
inherit distutils
DESCRIPTION="A fully functional X client library for Python, written in Python"
HOMEPAGE="http://python-xlib.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 ~arm ia64 ppc ~ppc64 x86"
IUSE="doc"
-DEPEND="${RDEPEND}
- doc? ( virtual/latex-base
- >=sys-apps/texinfo-4.8-r2 )"
+
+DEPEND="doc? (
+ virtual/latex-base
+ >=sys-apps/texinfo-4.8-r2
+ )"
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
PYTHON_MODNAME="Xlib"
src_compile() {
distutils_src_compile
+
if use doc; then
cd doc
- VARTEXFONTS="${T}"/fonts emake || die "make docs failed"
+ einfo "Generation of documentation"
+ VARTEXFONTS="${T}"/fonts emake || die "Generation of documentation failed"
fi
}
+src_test() {
+ cd test
+ testing() {
+ local return_status="0" test
+ for test in *.py; do
+ echo "Running ${test}..."
+ PYTHONPATH="../build-${PYTHON_ABI}/lib" "$(PYTHON)" "${test}" || return_status="1"
+ done
+ return "${return_status}"
+ }
+ python_execute_function testing
+}
+
src_install () {
distutils_src_install
+
if use doc; then
dohtml -r doc/html/
dodoc doc/ps/python-xlib.ps
fi
}
-
-src_test() {
- distutils_python_version
- for pytest in $(ls test/*py); do
- PYTHONPATH=. "${python}" ${pytest} || die "test failed"
- done
-}