summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2007-05-31 19:01:26 +0000
committerRob Cakebread <pythonhead@gentoo.org>2007-05-31 19:01:26 +0000
commitd8aa9b9f0cb11534728f069c9b1e94282f70afdb (patch)
tree69a4037a226aab53858456824cd0c7f2d9b1eeec /dev-python/python-openid/python-openid-1.2.0-r1.ebuild
parentInitial commit. (diff)
downloadhistorical-d8aa9b9f0cb11534728f069c9b1e94282f70afdb.tar.gz
historical-d8aa9b9f0cb11534728f069c9b1e94282f70afdb.tar.bz2
historical-d8aa9b9f0cb11534728f069c9b1e94282f70afdb.zip
Dropped amd64 keyword due to two missing deps bug#180397 - Thanks Paul Rauch <LightLan@lightlan.de>. Added src_test, missing deps for python-yadis, python-urljr and USE/dep for postgres/pyscopg, added PYTHON_MODNAME. Dropped old version.
Package-Manager: portage-2.1.2.8
Diffstat (limited to 'dev-python/python-openid/python-openid-1.2.0-r1.ebuild')
-rw-r--r--dev-python/python-openid/python-openid-1.2.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/python-openid/python-openid-1.2.0-r1.ebuild b/dev-python/python-openid/python-openid-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..29058697083b
--- /dev/null
+++ b/dev-python/python-openid/python-openid-1.2.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-openid/python-openid-1.2.0-r1.ebuild,v 1.1 2007/05/31 19:01:26 pythonhead Exp $
+
+NEED_PYTHON=2.3
+PYTHON_MODNAME="openid"
+
+inherit distutils
+
+KEYWORDS="~x86"
+
+DESCRIPTION="OpenID support for servers and consumers."
+HOMEPAGE="http://www.openidenabled.com/openid/libraries/python/"
+SRC_URI="http://www.openidenabled.com/resources/downloads/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc examples postgres"
+
+RDEPEND=">=dev-python/python-yadis-1.1.0
+ >=dev-python/python-urljr-1.0.1
+ postgres? ( dev-python/psycopg )"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ distutils_src_install
+ use doc && dohtml doc/*
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+src_test() {
+ PYTHONPATH=. "${python}" admin/runtests || die "tests failed"
+}