summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-24 23:21:08 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-24 23:21:08 +0000
commite7ff4c576bbcf97f5ab367d18fca058b7a6205ee (patch)
tree0251cf5763f0baabd3d1cdbe164184ff92b90e2e /dev-python/python-fchksum/python-fchksum-1.7.1.ebuild
parentFix dependencies. Set SUPPORT_PYTHON_ABIS. (diff)
downloadhistorical-e7ff4c576bbcf97f5ab367d18fca058b7a6205ee.tar.gz
historical-e7ff4c576bbcf97f5ab367d18fca058b7a6205ee.tar.bz2
historical-e7ff4c576bbcf97f5ab367d18fca058b7a6205ee.zip
Use distutils.eclass. Fix dependencies. Set SUPPORT_PYTHON_ABIS.
Package-Manager: portage-2.2.0_alpha10_p5/cvs/Linux x86_64
Diffstat (limited to 'dev-python/python-fchksum/python-fchksum-1.7.1.ebuild')
-rw-r--r--dev-python/python-fchksum/python-fchksum-1.7.1.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/dev-python/python-fchksum/python-fchksum-1.7.1.ebuild b/dev-python/python-fchksum/python-fchksum-1.7.1.ebuild
index 840142195bda..a4a1034a161d 100644
--- a/dev-python/python-fchksum/python-fchksum-1.7.1.ebuild
+++ b/dev-python/python-fchksum/python-fchksum-1.7.1.ebuild
@@ -1,9 +1,13 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-fchksum/python-fchksum-1.7.1.ebuild,v 1.29 2010/10/19 05:48:29 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-fchksum/python-fchksum-1.7.1.ebuild,v 1.30 2010/12/24 23:21:08 arfrever Exp $
-# DON'T inherit distutils because it will cause a circular dependency with python
-#inherit distutils
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils
DESCRIPTION="Python module to find the checksum of files"
HOMEPAGE="http://www.dakotacom.net/~donut/programs/fchksum.html"
@@ -14,13 +18,5 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
-DEPEND="dev-lang/python
- sys-libs/zlib"
-
-src_compile() {
- python setup.py build || die
-}
-
-src_install() {
- python setup.py install --root="${D}" || die
-}
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"