summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-05-05 15:17:41 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-05-05 15:17:41 +0000
commit9badd03b8c0af80029be8e13288506cc7278b6d4 (patch)
tree8b11b6aeb8105dddead62b797d2e05372fbdc639 /dev-python/pyfltk/pyfltk-1.1.5.ebuild
parentDrop useless dodoc line. (diff)
downloadhistorical-9badd03b8c0af80029be8e13288506cc7278b6d4.tar.gz
historical-9badd03b8c0af80029be8e13288506cc7278b6d4.tar.bz2
historical-9badd03b8c0af80029be8e13288506cc7278b6d4.zip
Fix building with SWIG 2 (bug #346605).
Package-Manager: portage-2.2.0_alpha30_p50/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pyfltk/pyfltk-1.1.5.ebuild')
-rw-r--r--dev-python/pyfltk/pyfltk-1.1.5.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/pyfltk/pyfltk-1.1.5.ebuild b/dev-python/pyfltk/pyfltk-1.1.5.ebuild
index 8e50c9f1bc36..f7c353303e47 100644
--- a/dev-python/pyfltk/pyfltk-1.1.5.ebuild
+++ b/dev-python/pyfltk/pyfltk-1.1.5.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyfltk/pyfltk-1.1.5.ebuild,v 1.9 2011/04/01 16:37:33 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyfltk/pyfltk-1.1.5.ebuild,v 1.10 2011/05/05 15:17:41 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
inherit distutils eutils
@@ -36,6 +36,8 @@ src_prepare() {
rm -f python/fltk*
# move docs because the swig stuff will remove them
use doc && cp -r fltk fltk.docs
+
+ epatch "${FILESDIR}/${P}-swig-2.patch"
}
src_compile() {