summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2004-06-21 00:42:20 +0000
committerBryan Østergaard <kloeri@gentoo.org>2004-06-21 00:42:20 +0000
commit1f4aada6966ae25c572be85f4b3e97f781532b0d (patch)
tree856690c6e1b0ddeffe103552d5b830afd8cf5443 /dev-python/pyclimate/pyclimate-1.2.1.ebuild
parentFix bug 54357: thunderbird's mozilla-xremote-client requires -a Thunderbird i... (diff)
downloadhistorical-1f4aada6966ae25c572be85f4b3e97f781532b0d.tar.gz
historical-1f4aada6966ae25c572be85f4b3e97f781532b0d.tar.bz2
historical-1f4aada6966ae25c572be85f4b3e97f781532b0d.zip
Moved from dev-python/PyClimate.
Diffstat (limited to 'dev-python/pyclimate/pyclimate-1.2.1.ebuild')
-rw-r--r--dev-python/pyclimate/pyclimate-1.2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pyclimate/pyclimate-1.2.1.ebuild b/dev-python/pyclimate/pyclimate-1.2.1.ebuild
new file mode 100644
index 000000000000..f6c3a9372af8
--- /dev/null
+++ b/dev-python/pyclimate/pyclimate-1.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyclimate/pyclimate-1.2.1.ebuild,v 1.1 2004/06/21 00:42:20 kloeri Exp $
+
+inherit eutils
+
+MY_P="${P/pyclimate/PyClimate}"
+IUSE=""
+DESCRIPTION="Climate Data Analysis Module for Python"
+SRC_URI="http://starship.python.net/crew/jsaenz/pyclimate/downloads/${MY_P}.tar.gz"
+HOMEPAGE="http://starship.python.net/crew/jsaenz/pyclimate/index.html"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~alpha ~ppc"
+
+DEPEND="virtual/python
+ >=dev-python/numeric-19.0
+ dev-python/ScientificPython
+ >=app-sci/netcdf-3.0"
+
+src_install() {
+ python setup.py install --prefix=${D}/usr || die "Python Install Failed"
+
+ dodoc README PKG-INFO
+
+ dodir /usr/share/doc/${PF}/doc
+ insinto /usr/share/doc/${PF}/doc
+ doins doc/*
+
+ dodir /usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+}