summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-21 02:21:39 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-21 02:21:39 +0000
commitbdb003dddaa5dbf8e3db0e9a5112ccd57c50e48e (patch)
tree4447fd665aae085a10f6b51462e8ce19d2a3bec9 /dev-python/logilab-common
parentInitial import, bug #192728. (diff)
downloadhistorical-bdb003dddaa5dbf8e3db0e9a5112ccd57c50e48e.tar.gz
historical-bdb003dddaa5dbf8e3db0e9a5112ccd57c50e48e.tar.bz2
historical-bdb003dddaa5dbf8e3db0e9a5112ccd57c50e48e.zip
Simplify src_test().
Package-Manager: portage-14854-svn/cvs/Linux x86_64
Diffstat (limited to 'dev-python/logilab-common')
-rw-r--r--dev-python/logilab-common/Manifest12
-rw-r--r--dev-python/logilab-common/logilab-common-0.45.1.ebuild30
2 files changed, 7 insertions, 35 deletions
diff --git a/dev-python/logilab-common/Manifest b/dev-python/logilab-common/Manifest
index f6302dba7e82..10164feaeb6f 100644
--- a/dev-python/logilab-common/Manifest
+++ b/dev-python/logilab-common/Manifest
@@ -1,17 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
AUX logilab-common-0.41.0-remove-broken-tests.patch 697 RMD160 bf3fa9c83abb0a47155486efe6d87714b4af2e68 SHA1 d226f60e0568a8476b8aa23a662b7f1cb74f6bb7 SHA256 71e5cdcdd983ec4da56a893b4191e50739aba2267a4105d4b1709ee4f4418dfd
DIST logilab-common-0.45.0.tar.gz 173484 RMD160 a6f439a81348750312c3f7dbbb89290690915796 SHA1 18f1f6dc3575d190aa1d91a7e027d89ce89c90bb SHA256 1ed092ff5ef2cd82ad98a6a3f810f7aa34f4a438cf2449e26983d486de0472c1
DIST logilab-common-0.45.1.tar.gz 176339 RMD160 4057ff9afae6c3e9d60e48e1c8bfc02fbafc3ca9 SHA1 495c314e6c9a19a5bd8143dd22e5052d133c66e5 SHA256 602c17a5934c54d2973e1d7df15ce7ff66c42c65e374434cfb1dd59208b1efd7
EBUILD logilab-common-0.45.0.ebuild 2699 RMD160 9a4c0ea12a798b5a8aa8cb3108460d8d82c1a808 SHA1 f246064db969314bec7c12e9dd67bf4f3c0c40a5 SHA256 246afbfcaeea04e61b07274f6b09fdeebceac40078979f71fff5ea1bcd523ee2
-EBUILD logilab-common-0.45.1.ebuild 2705 RMD160 bce7aff65b1bc56681f3fa7dad614b630426c714 SHA1 7738272ca0c281ab249db04a010a8e5d6c32064f SHA256 41bda616e8a9424df6be19fd1c9d1302c97c30ed38c1faaecdf575d84e3a9cb0
+EBUILD logilab-common-0.45.1.ebuild 2168 RMD160 3cc0ae962321ac00ce8000d9725b413f5262b0d1 SHA1 4a974f143b8ce22b09bbb5713d9ccfbbecc6e650 SHA256 3f725b5ed36c13fb6464c3998116d92394c4bf4367ff29bfec382355f691174d
MISC ChangeLog 9114 RMD160 9c2e0b149bac8c5f611ae7fb214795bbf18140af SHA1 290b49bac763657631b54cba358771ac45bd091e SHA256 ae676526902c8bc740169ed1d283ef47d287fc92ef035e7b1f3990c831dcfb6a
MISC metadata.xml 159 RMD160 900a8c55d7a7d2f6312594769aaf941bf9e99c7f SHA1 c8e604d56dae898258b5254d78cfeac0b981e288 SHA256 9f01104d3484792496faff4805eed0ecea2352a897151f3397d49a13800037b4
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v2.0.11 (GNU/Linux)
-
-iEYEARECAAYFAksFcLYACgkQkKaRLQcq0GLUFQCeLUh84Txm9roMuIJCZ8OrBuzD
-jPoAn1GH5Y41+wRbACp1VZ4s9KpNb2gy
-=0iC+
------END PGP SIGNATURE-----
diff --git a/dev-python/logilab-common/logilab-common-0.45.1.ebuild b/dev-python/logilab-common/logilab-common-0.45.1.ebuild
index 3a5032330633..d19ec1377748 100644
--- a/dev-python/logilab-common/logilab-common-0.45.1.ebuild
+++ b/dev-python/logilab-common/logilab-common-0.45.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/logilab-common-0.45.1.ebuild,v 1.3 2009/11/19 16:21:58 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/logilab-common-0.45.1.ebuild,v 1.4 2009/11/21 02:21:39 arfrever Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
@@ -40,38 +40,20 @@ src_test() {
testing() {
# Install temporarily.
local tpath="${T}/test-${PYTHON_ABI}"
- local lpath="${tpath}/lib/python"
+ local spath="${tpath}$(python_get_sitedir)"
- # setuptools would fail if the directory doesn't exist.
- mkdir -p "${lpath}" || die
-
- # We also have to add ${lpath} to PYTHONPATH else the installation would
- # fail.
- PYTHONPATH="${lpath}" "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --home="${tpath}" || die "test copy failed"
-
- # Get a rid of precompiled files to ensure we run our _modified_ tests
- find ${lpath} -type f -name '*.pyc' -exec rm {} ';'
-
- # Remove a botched tests.
- # To support test w/o setuptools.
- if [[ -d "${lpath}/${PN/-//}" ]]; then
- pushd "${lpath}/${PN/-//}" >/dev/null || die
- else
- pushd "${lpath}/${P/-/_}-py${PYTHON_ABI}.egg/${PN/-//}" >/dev/null || die
- fi
+ "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --root="${tpath}" || die "Installation for tests failed with Python ${PYTHON_ABI}"
# Bug 223079.
if [[ "${EUID}" -eq 0 ]]; then
rm test/unittest_fileutils.py || die
fi
- popd >/dev/null || die
-
- # It picks up the tests relative to the current dir, so cd in. Do
+ # pytest picks up the tests relative to the current directory, so cd in. Do
# not cd in too far though (to logilab/common for example) or some
# relative/absolute module location tests fail.
- pushd "${lpath}" >/dev/null || die
- PYTHONPATH="${lpath}" "$(PYTHON)" "${tpath}/bin/pytest" -v || die "tests failed"
+ pushd "${spath}" >/dev/null || die
+ PYTHONPATH="${spath}" "$(PYTHON)" "${tpath}/usr/bin/pytest" -v || return 1
popd >/dev/null || die
}
python_execute_function testing