summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-24 10:57:25 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-24 10:57:25 +0000
commit57c0d7ae6f07f8dce10d0589d794e0ea65ae8124 (patch)
tree17587ff21603ef0dcc2c1ec4f2ae8aa799ca284c /dev-python/jsonpointer/jsonpointer-1.7.ebuild
parentRemove old. (diff)
downloadhistorical-57c0d7ae6f07f8dce10d0589d794e0ea65ae8124.tar.gz
historical-57c0d7ae6f07f8dce10d0589d794e0ea65ae8124.tar.bz2
historical-57c0d7ae6f07f8dce10d0589d794e0ea65ae8124.zip
bump, rm old
Package-Manager: portage-2.2.14/cvs/Linux x86_64 Manifest-Sign-Key: 0xB8072B0D
Diffstat (limited to 'dev-python/jsonpointer/jsonpointer-1.7.ebuild')
-rw-r--r--dev-python/jsonpointer/jsonpointer-1.7.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/jsonpointer/jsonpointer-1.7.ebuild b/dev-python/jsonpointer/jsonpointer-1.7.ebuild
new file mode 100644
index 000000000000..c0c46ce48c8a
--- /dev/null
+++ b/dev-python/jsonpointer/jsonpointer-1.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpointer/jsonpointer-1.7.ebuild,v 1.1 2014/12/24 10:56:55 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Identify specific nodes in a JSON document (according to draft 08)"
+HOMEPAGE="https://github.com/stefankoegl/python-json-pointer https://pypi.python.org/pypi/jsonpointer/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ "${PYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}