summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-02-21 11:35:36 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-02-21 11:35:36 +0000
commit16602c3bfd2a7561428e709c6f23e3ebe8b1f87e (patch)
treeef2c6860be060abac919284842a3b94570389dd6 /dev-python/jinja2
parentBump (diff)
downloadhistorical-16602c3bfd2a7561428e709c6f23e3ebe8b1f87e.tar.gz
historical-16602c3bfd2a7561428e709c6f23e3ebe8b1f87e.tar.bz2
historical-16602c3bfd2a7561428e709c6f23e3ebe8b1f87e.zip
Bump for #306065, thanks to Priit Laes for the test fixes
Package-Manager: portage-2.2_rc63/cvs/Linux x86_64
Diffstat (limited to 'dev-python/jinja2')
-rw-r--r--dev-python/jinja2/ChangeLog7
-rw-r--r--dev-python/jinja2/jinja2-2.3.1.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-python/jinja2/ChangeLog b/dev-python/jinja2/ChangeLog
index 478fe6d717ae..c6c11baeae8f 100644
--- a/dev-python/jinja2/ChangeLog
+++ b/dev-python/jinja2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/jinja2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jinja2/ChangeLog,v 1.32 2010/02/10 08:51:42 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jinja2/ChangeLog,v 1.33 2010/02/21 11:35:36 patrick Exp $
+
+*jinja2-2.3.1 (21 Feb 2010)
+
+ 21 Feb 2010; Patrick Lauer <patrick@gentoo.org> +jinja2-2.3.1.ebuild:
+ Bump for #306065, thanks to Priit Laes for the test fixes
*jinja2-2.3 (10 Feb 2010)
diff --git a/dev-python/jinja2/jinja2-2.3.1.ebuild b/dev-python/jinja2/jinja2-2.3.1.ebuild
new file mode 100644
index 000000000000..00a1c4447c96
--- /dev/null
+++ b/dev-python/jinja2/jinja2-2.3.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jinja2/jinja2-2.3.1.ebuild,v 1.1 2010/02/21 11:35:36 patrick Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="Jinja2"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A small but fast and easy to use stand-alone template engine written in pure python."
+HOMEPAGE="http://jinja.pocoo.org/ http://pypi.python.org/pypi/Jinja2"
+SRC_URI="http://pypi.python.org/packages/source/J/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+SLOT="0"
+IUSE="doc examples i18n test"
+
+CDEPEND="dev-python/setuptools"
+DEPEND="${CDEPEND}
+ doc? ( >=dev-python/sphinx-0.6 )"
+RDEPEND="${CDEPEND}
+ i18n? ( >=dev-python/Babel-0.9.3 )"
+RESTRICT_PYTHON_ABIS="3.*" # test suite doesn't work on 3.x
+
+S="${WORKDIR}/${MY_P}"
+
+DISTUTILS_GLOBAL_OPTIONS=("--with-speedups")
+DOCS="CHANGES"
+
+src_compile(){
+ distutils_src_compile
+
+ if use doc; then
+ cd "${S}/docs"
+ PYTHONPATH=.. emake html || die "Building of documentation failed"
+ fi
+}
+
+src_test(){
+ testing() {
+ PYTHONPATH="$(dir -d build-${PYTHON_ABI}/lib.*)" ${python} setup.py test || die "tests failed"
+ }
+ python_execute_function testing
+}
+
+src_install(){
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/_build/html/* || die "Installation of documentation failed"
+ fi
+
+ if use examples; then
+ # Eliminate .pyc files going into /usr/share
+ find examples -name "*.pyc" -print0 | xargs -0 rm -fr
+
+ insinto "/usr/share/doc/${PF}"
+ doins -r examples || die "Failed to install examples"
+ fi
+}