summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2011-07-07 23:26:15 +0000
committerJesus Rivero <neurogeek@gentoo.org>2011-07-07 23:26:15 +0000
commit9a107688fa52ade1add58fb45edc5c24a91eef3e (patch)
tree9184a4e68df3f805ccb85dd685cfd44a4b19ac82 /dev-python/imaging/imaging-1.1.7.ebuild
parentkeyword ~x86-fbsd, bug #351526 (diff)
downloadhistorical-9a107688fa52ade1add58fb45edc5c24a91eef3e.tar.gz
historical-9a107688fa52ade1add58fb45edc5c24a91eef3e.tar.bz2
historical-9a107688fa52ade1add58fb45edc5c24a91eef3e.zip
Fixed shebang in Scripts/pilfont.py wrt bug #371117
Package-Manager: portage-2.2.0_alpha29/cvs/Linux i686
Diffstat (limited to 'dev-python/imaging/imaging-1.1.7.ebuild')
-rw-r--r--dev-python/imaging/imaging-1.1.7.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/imaging/imaging-1.1.7.ebuild b/dev-python/imaging/imaging-1.1.7.ebuild
index 05e5c58e27e4..55aee9aeec63 100644
--- a/dev-python/imaging/imaging-1.1.7.ebuild
+++ b/dev-python/imaging/imaging-1.1.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/imaging/imaging-1.1.7.ebuild,v 1.12 2011/02/25 17:50:42 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/imaging/imaging-1.1.7.ebuild,v 1.13 2011/07/07 23:26:15 neurogeek Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -45,6 +45,10 @@ src_prepare() {
epatch "${FILESDIR}/${P}-giftrans.patch"
epatch "${FILESDIR}/${P}-missing-math.patch"
+ # Add shebang.
+ sed -e "1i#!/usr/bin/python" -i Scripts/pilfont.py \
+ || die "sed failed adding shebang"
+
sed -i \
-e "s:/usr/lib\":/usr/$(get_libdir)\":" \
-e "s:\"lib\":\"$(get_libdir)\":g" \