summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-28 22:04:06 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-28 22:04:06 +0000
commit3ee5dec9857049d6c0484ab9b4f15c6963c90e71 (patch)
tree158e1d7df44e26e7ea97c0f356d4816ef3db54ba /dev-python/happydoc
parentinitial commit. (diff)
downloadhistorical-3ee5dec9857049d6c0484ab9b4f15c6963c90e71.tar.gz
historical-3ee5dec9857049d6c0484ab9b4f15c6963c90e71.tar.bz2
historical-3ee5dec9857049d6c0484ab9b4f15c6963c90e71.zip
Delete older ebuilds.
Diffstat (limited to 'dev-python/happydoc')
-rw-r--r--dev-python/happydoc/files/happydoc-2.1-python-2.4-compat.patch73
-rw-r--r--dev-python/happydoc/happydoc-2.1-r1.ebuild41
-rw-r--r--dev-python/happydoc/happydoc-2.1.ebuild41
3 files changed, 0 insertions, 155 deletions
diff --git a/dev-python/happydoc/files/happydoc-2.1-python-2.4-compat.patch b/dev-python/happydoc/files/happydoc-2.1-python-2.4-compat.patch
deleted file mode 100644
index e58f721224bf..000000000000
--- a/dev-python/happydoc/files/happydoc-2.1-python-2.4-compat.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-=== modified file 'happydoclib/docstring/StructuredText/STDOM.py'
---- happydoclib/docstring/StructuredText/STDOM.py
-+++ happydoclib/docstring/StructuredText/STDOM.py
-@@ -171,7 +171,7 @@
- type=type,
- st=type(''),
- getattr=getattr,
-- None=None):
-+ none=None):
-
- """
- The node immediately preceding this node. If
-@@ -180,17 +180,17 @@
-
- children = self.aq_parent.getChildren()
- if not children:
-- return None
--
-- index=getattr(self, '_DOMIndex', None)
-- if index is None:
-+ return none
-+
-+ index=getattr(self, '_DOMIndex', none)
-+ if index is none:
- index=self._getDOMIndex(children)
-- if index is None: return None
-+ if index is none: return none
-
- index=index-1
-- if index < 0: return None
-+ if index < 0: return none
- try: n=children[index]
-- except IndexError: return None
-+ except IndexError: return none
- else:
- if type(n) is st:
- n=TextNode(n)
-@@ -243,9 +243,9 @@
- type=type,
- st=type(''),
- getattr=getattr,
-- None=None):
--
-- return self.getPreviousSibling(type,st,getattr,None)
-+ none=None):
-+
-+ return self.getPreviousSibling(type,st,getattr,none)
-
- def _get_NextSibling(self, type=type, st=type('')):
- return self.getNextSibling(type,st)
-@@ -292,7 +292,7 @@
- type=type,
- st=type(''),
- getattr=getattr,
-- None=None):
-+ none=None):
- """
- The node immediately preceding this node. If
- there is no such node, this returns None.
-@@ -346,9 +346,9 @@
- type=type,
- st=type(''),
- getattr=getattr,
-- None=None):
--
-- return self.getPreviousSibling(type,st,getattr,None)
-+ none=None):
-+
-+ return self.getPreviousSibling(type,st,getattr,none)
-
- def _get_NextSibling(self, type=type, st=type('')):
- return self.getNextSibling()
-
diff --git a/dev-python/happydoc/happydoc-2.1-r1.ebuild b/dev-python/happydoc/happydoc-2.1-r1.ebuild
deleted file mode 100644
index a1297749c65e..000000000000
--- a/dev-python/happydoc/happydoc-2.1-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/happydoc/happydoc-2.1-r1.ebuild,v 1.2 2007/07/04 19:50:49 hawking Exp $
-
-inherit distutils eutils
-
-MY_PN="HappyDoc"
-MY_PV=${PV//./_}
-S=${WORKDIR}/${MY_PN}-r${MY_PV}
-DESCRIPTION="tool for extracting documentation from Python sourcecode"
-SRC_URI="mirror://sourceforge/${PN}/${MY_PN}_r${MY_PV}.tar.gz"
-HOMEPAGE="http://happydoc.sourceforge.net/"
-
-SLOT="0"
-LICENSE="as-is"
-KEYWORDS="alpha ~amd64 ia64 ppc sparc x86"
-IUSE=""
-
-DEPEND="virtual/python"
-
-# the tests need extra data not present in the release tarball
-RESTRICT=test
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-python-2.4-compat.patch"
-}
-
-src_install() {
- DOCS="CHANGES.txt"
- distutils_src_install
-
- insinto /usr/share/doc/${PF}
- doins test_happydoc.py
-
- # manually install its weird documentation tree
- dohtml -r srcdocs/${MY_PN}-r${MY_PV}/*
- dohtml srcdocs/index.html
- dohtml -r srcdocs/home/dhellmann/Personal/Devel/HappyDoc/dist/HappyDoc-r2_1/
-}
diff --git a/dev-python/happydoc/happydoc-2.1.ebuild b/dev-python/happydoc/happydoc-2.1.ebuild
deleted file mode 100644
index 3c76ece3bf3c..000000000000
--- a/dev-python/happydoc/happydoc-2.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/happydoc/happydoc-2.1.ebuild,v 1.17 2007/07/04 19:50:49 hawking Exp $
-
-inherit distutils eutils
-
-MY_PN="HappyDoc"
-MY_PV=${PV//./_}
-S=${WORKDIR}/${MY_PN}-r${MY_PV}
-DESCRIPTION="tool for extracting documentation from Python sourcecode"
-SRC_URI="mirror://sourceforge/${PN}/${MY_PN}_r${MY_PV}.tar.gz"
-HOMEPAGE="http://happydoc.sourceforge.net/"
-
-SLOT="0"
-LICENSE="as-is"
-KEYWORDS="alpha ~amd64 ia64 ppc sparc x86"
-IUSE=""
-
-DEPEND="virtual/python"
-
-# the tests need extra data not present in the release tarball
-RESTRICT=test
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-python-2.4-compat.patch"
-}
-
-src_install() {
- DOCS="CHANGES.txt"
- distutils_src_install
-
- insinto /usr/share/doc/${PF}
- doins test_happydoc.py
-
- # manually install its weird documentation tree
- dohtml -r srcdocs/${MY_PN}-r${MY_PV}/*
- dohtml srcdocs/index.html
- dohtml -r srcdocs/home/dhellmann/Personal/Devel/HappyDoc/dist/HappyDoc-r2_1/
-}