summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-06-14 14:56:31 +0000
committerPacho Ramos <pacho@gentoo.org>2010-06-14 14:56:31 +0000
commit802870ca23d91cd32634518d9fd5ce5575d37715 (patch)
tree3e61807bd1520388eed3502d07a52aef83564aed /dev-python/gnome-python-desktop-base
parentx86 stable wrt bug #320261 (diff)
downloadhistorical-802870ca23d91cd32634518d9fd5ce5575d37715.tar.gz
historical-802870ca23d91cd32634518d9fd5ce5575d37715.tar.bz2
historical-802870ca23d91cd32634518d9fd5ce5575d37715.zip
Add new version for Gnome 2.30
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'dev-python/gnome-python-desktop-base')
-rw-r--r--dev-python/gnome-python-desktop-base/ChangeLog8
-rw-r--r--dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.30.2.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/gnome-python-desktop-base/ChangeLog b/dev-python/gnome-python-desktop-base/ChangeLog
index 21a7a518f6b0..763689ee7e34 100644
--- a/dev-python/gnome-python-desktop-base/ChangeLog
+++ b/dev-python/gnome-python-desktop-base/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/gnome-python-desktop-base
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-desktop-base/ChangeLog,v 1.30 2010/06/11 08:53:26 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-desktop-base/ChangeLog,v 1.31 2010/06/14 14:29:49 pacho Exp $
+
+*gnome-python-desktop-base-2.30.2 (14 Jun 2010)
+
+ 14 Jun 2010; Pacho Ramos <pacho@gentoo.org>
+ +gnome-python-desktop-base-2.30.2.ebuild:
+ Add new version for Gnome 2.30.
11 Jun 2010; Pacho Ramos <pacho@gentoo.org>
gnome-python-desktop-base-2.28.0.ebuild:
diff --git a/dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.30.2.ebuild b/dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.30.2.ebuild
new file mode 100644
index 000000000000..48f360e4413e
--- /dev/null
+++ b/dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.30.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.30.2.ebuild,v 1.1 2010/06/14 14:29:49 pacho Exp $
+
+GCONF_DEBUG="no"
+
+inherit eutils gnome2 versionator
+
+# This ebuild does nothing -- we just want to get the pkgconfig file installed
+MY_PN="gnome-python-desktop"
+PVP="$(get_version_component_range 1-2)"
+
+DESCRIPTION="Provides python the base files for the Gnome Python Desktop bindings"
+HOMEPAGE="http://pygtk.org/"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP}/${MY_PN}-${PV}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+
+IUSE=""
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+# From the gnome-python-desktop eclass
+RDEPEND="virtual/python
+ >=dev-python/pygtk-2.10.3
+ >=dev-libs/glib-2.6.0
+ >=x11-libs/gtk+-2.4.0
+ !<dev-python/gnome-python-extras-2.13
+ !<dev-python/gnome-python-desktop-2.22.0-r10"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.7"
+
+RESTRICT="test"
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-allbindings"
+}