summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-10-29 23:29:59 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-10-29 23:29:59 +0000
commit81a2297ef681eb3a1dbd6fb5336befba80303a6b (patch)
tree6c7a3a60f9da426d703dce18c6d1a04f4cd78cc1 /dev-python/gnome-python-base
parentAutomated update of use.local.desc (diff)
downloadhistorical-81a2297ef681eb3a1dbd6fb5336befba80303a6b.tar.gz
historical-81a2297ef681eb3a1dbd6fb5336befba80303a6b.tar.bz2
historical-81a2297ef681eb3a1dbd6fb5336befba80303a6b.zip
New version for GNOME 2.28.
Package-Manager: portage-2.2_rc46/cvs/Linux x86_64
Diffstat (limited to 'dev-python/gnome-python-base')
-rw-r--r--dev-python/gnome-python-base/ChangeLog8
-rw-r--r--dev-python/gnome-python-base/gnome-python-base-2.28.0.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-python/gnome-python-base/ChangeLog b/dev-python/gnome-python-base/ChangeLog
index b24b98c6c98f..84426b9a3326 100644
--- a/dev-python/gnome-python-base/ChangeLog
+++ b/dev-python/gnome-python-base/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/gnome-python-base
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-base/ChangeLog,v 1.16 2009/10/24 16:18:21 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-base/ChangeLog,v 1.17 2009/10/29 23:20:03 eva Exp $
+
+*gnome-python-base-2.28.0 (29 Oct 2009)
+
+ 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +gnome-python-base-2.28.0.ebuild:
+ New version for GNOME 2.28.
24 Oct 2009; nixnut <nixnut@gentoo.org> gnome-python-base-2.26.1.ebuild:
ppc stable #281427
diff --git a/dev-python/gnome-python-base/gnome-python-base-2.28.0.ebuild b/dev-python/gnome-python-base/gnome-python-base-2.28.0.ebuild
new file mode 100644
index 000000000000..851a5ce0db5d
--- /dev/null
+++ b/dev-python/gnome-python-base/gnome-python-base-2.28.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-base/gnome-python-base-2.28.0.ebuild,v 1.1 2009/10/29 23:20:03 eva Exp $
+
+GCONF_DEBUG="no"
+
+inherit versionator eutils gnome2
+
+# This ebuild does nothing -- we just want to get the pkgconfig file installed
+
+MY_PN="gnome-python"
+DESCRIPTION="Provides the base files for the gnome-python bindings"
+HOMEPAGE="http://pygtk.org/"
+PVP="$(get_version_component_range 1-2)"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP}/${MY_PN}-${PV}.tar.bz2"
+
+IUSE=""
+LICENSE="LGPL-2.1"
+SLOT="2"
+RESTRICT="${RESTRICT} test"
+
+# From the gnome-python eclass
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=dev-libs/glib-2.6
+ >=dev-python/pygtk-2.14.0
+ >=dev-python/pygobject-2.17
+ !<dev-python/gnome-python-2.22.1"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-allbindings"
+}