summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-22 19:48:23 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-22 19:48:23 +0000
commite5deb358b4304919c1659e4e5c70304ba195f4b6 (patch)
tree63a4bfc93aa6a3f576ddc8131bdf42704960908e /dev-python/django/django-1.1.2.ebuild
parentStable on amd64 wrt bug #334735 (diff)
downloadhistorical-e5deb358b4304919c1659e4e5c70304ba195f4b6.tar.gz
historical-e5deb358b4304919c1659e4e5c70304ba195f4b6.tar.bz2
historical-e5deb358b4304919c1659e4e5c70304ba195f4b6.zip
Improve pysqlite dependencies (bug #334801).
Package-Manager: portage-2.2_rc86_p1/cvs/Linux x86_64
Diffstat (limited to 'dev-python/django/django-1.1.2.ebuild')
-rw-r--r--dev-python/django/django-1.1.2.ebuild18
1 files changed, 6 insertions, 12 deletions
diff --git a/dev-python/django/django-1.1.2.ebuild b/dev-python/django/django-1.1.2.ebuild
index 0da86bd2430c..0b6f140c2ecd 100644
--- a/dev-python/django/django-1.1.2.ebuild
+++ b/dev-python/django/django-1.1.2.ebuild
@@ -1,16 +1,17 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.1.2.ebuild,v 1.4 2010/07/11 12:38:44 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.1.2.ebuild,v 1.5 2010/09/22 19:48:23 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit bash-completion distutils versionator webapp
MY_P="Django-${PV}"
-DESCRIPTION="High-level python web framework"
+DESCRIPTION="High-level Python web framework"
HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
SRC_URI="http://media.djangoproject.com/releases/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
@@ -20,19 +21,12 @@ KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~
IUSE="doc examples mysql postgres sqlite test"
RDEPEND="dev-python/imaging
- sqlite? ( || (
- >=dev-lang/python-2.5[sqlite]
- ( dev-python/pysqlite:2 <dev-lang/python-2.5 )
- ) )
+ sqlite? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )
postgres? ( dev-python/psycopg )
mysql? ( >=dev-python/mysql-python-1.2.1_p2 )"
DEPEND="${RDEPEND}
doc? ( >=dev-python/sphinx-0.3 )
- test? ( || (
- >=dev-lang/python-2.5[sqlite]
- ( dev-python/pysqlite:2 <dev-lang/python-2.5 )
- ) )"
-RESTRICT_PYTHON_ABIS="3.*"
+ test? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )"
S="${WORKDIR}/${MY_P}"
@@ -48,8 +42,8 @@ src_compile() {
distutils_src_compile
if use doc; then
- pushd docs > /dev/null
einfo "Generation of documentation"
+ pushd docs > /dev/null
emake html || die "Generation of documentation failed"
popd > /dev/null
fi