summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-04-26 08:21:23 +0000
committerPacho Ramos <pacho@gentoo.org>2014-04-26 08:21:23 +0000
commit20b57d03e2bd67e963c6f7bf28833f2bb236efc1 (patch)
treed33132a8965b27980ede1f4768bc779ae909b636 /dev-python/dbus-python/dbus-python-1.2.0.ebuild
parentAdapt to latest pygobject don't providing python2.6 support (diff)
downloadhistorical-20b57d03e2bd67e963c6f7bf28833f2bb236efc1.tar.gz
historical-20b57d03e2bd67e963c6f7bf28833f2bb236efc1.tar.bz2
historical-20b57d03e2bd67e963c6f7bf28833f2bb236efc1.zip
Adapt to latest pygobject don't providing python2.6 support
Package-Manager: portage-2.2.10/cvs/Linux x86_64 Manifest-Sign-Key: 0xA188FBD4
Diffstat (limited to 'dev-python/dbus-python/dbus-python-1.2.0.ebuild')
-rw-r--r--dev-python/dbus-python/dbus-python-1.2.0.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-python/dbus-python/dbus-python-1.2.0.ebuild b/dev-python/dbus-python/dbus-python-1.2.0.ebuild
index 96d293f1a54b..1f390d155f22 100644
--- a/dev-python/dbus-python/dbus-python-1.2.0.ebuild
+++ b/dev-python/dbus-python/dbus-python-1.2.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-1.2.0.ebuild,v 1.13 2014/01/05 19:47:54 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-1.2.0.ebuild,v 1.14 2014/04/26 08:17:52 pacho Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
inherit eutils python-r1
@@ -17,7 +17,7 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~m68k-mint"
IUSE="doc examples test"
# API docs generated with epydoc, which is python2-only
-REQUIRED_USE="doc? ( || ( python_targets_python2_6 python_targets_python2_7 ) )"
+REQUIRED_USE="doc? ( python_targets_python2_7 )"
RDEPEND=">=dev-libs/dbus-glib-0.100:=
>=sys-apps/dbus-1.6:=
@@ -25,8 +25,8 @@ RDEPEND=">=dev-libs/dbus-glib-0.100:=
DEPEND="${RDEPEND}
virtual/pkgconfig
doc? (
- dev-python/docutils[python_targets_python2_6?,python_targets_python2_7?]
- =dev-python/epydoc-3*[python_targets_python2_6?,python_targets_python2_7?] )
+ dev-python/docutils[python_targets_python2_7?]
+ =dev-python/epydoc-3*[python_targets_python2_7?] )
test? ( dev-python/pygobject:3[${PYTHON_USEDEP}] )"
src_prepare() {