summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-24 15:04:10 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-24 15:04:10 +0000
commit3d7f159f8d73f43b8be77a6c907e05d2ad604434 (patch)
tree0c5890b6d994fdafba80ce7f2e05f6dd679fb8b0 /dev-python/bsddb3/bsddb3-4.7.0.ebuild
parentBump to 1.7a (diff)
downloadhistorical-3d7f159f8d73f43b8be77a6c907e05d2ad604434.tar.gz
historical-3d7f159f8d73f43b8be77a6c907e05d2ad604434.tar.bz2
historical-3d7f159f8d73f43b8be77a6c907e05d2ad604434.zip
Remove old
Package-Manager: portage-2.2_rc31/cvs/Linux x86_64
Diffstat (limited to 'dev-python/bsddb3/bsddb3-4.7.0.ebuild')
-rw-r--r--dev-python/bsddb3/bsddb3-4.7.0.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/bsddb3/bsddb3-4.7.0.ebuild b/dev-python/bsddb3/bsddb3-4.7.0.ebuild
deleted file mode 100644
index aaa58afbfd0f..000000000000
--- a/dev-python/bsddb3/bsddb3-4.7.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-4.7.0.ebuild,v 1.3 2008/06/29 09:44:17 armin76 Exp $
-
-EAPI="1"
-
-NEED_PYTHON=2.5
-
-inherit distutils db-use multilib
-
-DESCRIPTION="Python bindings for BerkeleyDB"
-HOMEPAGE="http://www.jcea.es/programacion/pybsddb.htm"
-SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
-IUSE="doc"
-
-RDEPEND="sys-libs/db:4.6"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( dev-python/sphinx )"
-
-src_compile() {
- DB_VER="4.6"
-
- sed -i \
- -e "s/dblib = 'db'/dblib = '$(db_libname ${DB_VER})'/" \
- setup.py
-
- distutils_src_compile \
- "--berkeley-db=/usr" \
- "--berkeley-db-incdir=$(db_includedir ${DB_VER})" \
- "--berkeley-db-libdir=/usr/$(get_libdir)"
-
- if use doc ; then
- mkdir html
- sphinx-build docs html || die "building docs failed"
- fi
-}
-
-src_install() {
- DOCS="TODO.txt"
- distutils_src_install
-
- distutils_python_version
- rm -rf "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}/tests"
-
- use doc && dohtml -r html/*
-}
-
-src_test() {
- distutils_python_version
- "${python}" test.py || die "tests failed"
-}