summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2003-08-27 16:00:42 +0000
committerCaleb Tennis <caleb@gentoo.org>2003-08-27 16:00:42 +0000
commitfbfffd0bbc0e9da391ccd7e6de45679ff4b2d2bc (patch)
treee0a54f1153affe0f662cf6123d20c36e7c20182e /dev-python/PyQt
parentVersion bump (diff)
downloadhistorical-fbfffd0bbc0e9da391ccd7e6de45679ff4b2d2bc.tar.gz
historical-fbfffd0bbc0e9da391ccd7e6de45679ff4b2d2bc.tar.bz2
historical-fbfffd0bbc0e9da391ccd7e6de45679ff4b2d2bc.zip
Version bump
Diffstat (limited to 'dev-python/PyQt')
-rw-r--r--dev-python/PyQt/Manifest6
-rw-r--r--dev-python/PyQt/PyQt-3.8.ebuild51
-rw-r--r--dev-python/PyQt/files/digest-PyQt-3.81
-rw-r--r--dev-python/PyQt/files/license-3.8.diff34
4 files changed, 89 insertions, 3 deletions
diff --git a/dev-python/PyQt/Manifest b/dev-python/PyQt/Manifest
index ec8ed2398f00..3d3c8f4803ba 100644
--- a/dev-python/PyQt/Manifest
+++ b/dev-python/PyQt/Manifest
@@ -3,8 +3,8 @@ MD5 79e4de0b6ffa7d820296689198694a2f PyQt-3.7.ebuild 1435
MD5 bcb87c9191c593b9c41356efaea867c2 PyQt-3.6-r1.ebuild 1455
MD5 bcf831b36821e50a7a8d67f8f01e7574 PyQt-3.6.ebuild 1453
MD5 a9e4ca44877ccf840572f5a07df3a1c5 PyQt-3.5-r1.ebuild 1378
-MD5 59ec1f29b84f4535339000a6da939277 ChangeLog 2635
-MD5 79e4de0b6ffa7d820296689198694a2f PyQt-3.8.ebuild 1435
+MD5 b5bd377b8c6f64af35365465da535eca ChangeLog 2739
+MD5 2b6708e7e50441d2f0e127bb5ae3ec2d PyQt-3.8.ebuild 1436
MD5 811c07ba7510a315382249fc3adb44fc metadata.xml 175
MD5 94164eef52f16b805d3c252c02100d11 files/qt3.1.2-compilation-fix-3.5.diff 2151
MD5 ac2fc9d166ddfb0637781545e6d168c0 files/license-3.5.diff 972
@@ -12,7 +12,7 @@ MD5 37aecdea8b6915ebc7f7e558aa0efbf9 files/license-3.6.diff 984
MD5 a411bac15db49327e2ac6e94f34f7577 files/license-3.7.diff 984
MD5 cfa5b5c9a44fc587bc3937b2d1335bb9 files/digest-PyQt-3.5-r1 68
MD5 02f19a3e9665543de676bb8eed138769 files/digest-PyQt-3.6-r1 68
-MD5 a411bac15db49327e2ac6e94f34f7577 files/license-3.8.diff 984
+MD5 31778b2adf33bdd65407d3e3ef69aed8 files/license-3.8.diff 984
MD5 cfa5b5c9a44fc587bc3937b2d1335bb9 files/digest-PyQt-3.5 68
MD5 02f19a3e9665543de676bb8eed138769 files/digest-PyQt-3.6 68
MD5 8ccb1c3fb13a5b2eb0a9a628393b6001 files/digest-PyQt-3.7 68
diff --git a/dev-python/PyQt/PyQt-3.8.ebuild b/dev-python/PyQt/PyQt-3.8.ebuild
new file mode 100644
index 000000000000..efd562d08407
--- /dev/null
+++ b/dev-python/PyQt/PyQt-3.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.8.ebuild,v 1.1 2003/08/27 16:00:01 caleb Exp $
+
+inherit eutils distutils
+
+IUSE=""
+S="${WORKDIR}/PyQt-x11-gpl-${PV}"
+DESCRIPTION="set of Python bindings for the QT 3.x Toolkit"
+SRC_URI="http://www.river-bank.demon.co.uk/download/PyQt/PyQt-x11-gpl-${PV}.tar.gz"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+DEPEND="virtual/glibc
+ sys-devel/libtool
+ x11-libs/qt
+ dev-lang/python
+ =dev-python/sip-${PV}
+ >=dev-python/qscintilla-1.53"
+
+src_unpack() {
+ unpack PyQt-x11-gpl-${PV}.tar.gz
+ cd ${S}
+ epatch $FILESDIR/license-${PV}.diff
+}
+
+src_compile() {
+
+ distutils_python_version
+ # standard qt sandbox problem workaround
+ [ -d "$QTDIR/etc/settings" ] && addwrite "$QTDIR/etc/settings"
+ dodir /usr/lib/python${PYVER}/site-packages
+ dodir /usr/include/python${PYVER}
+ python build.py \
+ -d ${D}/usr/lib/python${PYVER}/site-packages \
+ -e /usr/include/python${PYVER} \
+ -b ${D}/usr/bin \
+ -l qt-mt -c
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README.Linux NEWS LICENSE README ChangeLog THANKS
+ dodir /usr/share/doc/${P}/
+ mv ${D}/usr/share/doc/* ${D}/usr/share/doc/${P}/
+ # I found out this location from the redhat rpm
+ insinto /usr/share/sip/qt
+ doins ${S}/sip/*
+}
diff --git a/dev-python/PyQt/files/digest-PyQt-3.8 b/dev-python/PyQt/files/digest-PyQt-3.8
new file mode 100644
index 000000000000..bc246db61c63
--- /dev/null
+++ b/dev-python/PyQt/files/digest-PyQt-3.8
@@ -0,0 +1 @@
+MD5 3a6da6ce9ae84183d59281980366990f PyQt-x11-gpl-3.8.tar.gz 743487
diff --git a/dev-python/PyQt/files/license-3.8.diff b/dev-python/PyQt/files/license-3.8.diff
new file mode 100644
index 000000000000..073689d3e358
--- /dev/null
+++ b/dev-python/PyQt/files/license-3.8.diff
@@ -0,0 +1,34 @@
+--- build.py.orig 2003-08-27 10:57:39.000000000 -0500
++++ build.py 2003-08-27 10:58:15.000000000 -0500
+@@ -710,31 +710,6 @@
+ licType = "GPL"
+ licname = "GNU General Public License"
+
+- inform("This is the %s version of PyQt and is licensed under the %s." % (licType,licname),0)
+-
+- print
+- print "Type 'L' to view the license."
+- print "Type 'yes' to accept the terms of the license."
+- print "Type 'no' to decline the terms of the license."
+- print
+-
+- while 1:
+- try:
+- resp = raw_input("Do you accept the terms of the license? ")
+- except:
+- resp = ""
+-
+- resp = string.lower(string.strip(resp))
+-
+- if resp == "yes":
+- break
+-
+- if resp == "no":
+- sys.exit(0)
+-
+- if resp == "l":
+- os.system("more LICENSE")
+-
+ inform("Building the %s version of PyQt 3.8 for Python %s on %s." % (licType,pyFullVers,sys.platform))
+
+ if licType != "GPL":