summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-07-16 03:56:18 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-07-16 03:56:18 +0000
commitf10346dc1c1470382811d494c4939e0db87c3e21 (patch)
tree21d0824c0d4012301e441305bbca9e47b51d0153 /dev-php
parentAdded KEYWORDS and removed the empty jadetex-2.20 ebuild and digest (diff)
downloadhistorical-f10346dc1c1470382811d494c4939e0db87c3e21.tar.gz
historical-f10346dc1c1470382811d494c4939e0db87c3e21.tar.bz2
historical-f10346dc1c1470382811d494c4939e0db87c3e21.zip
Fixes compile error. #4912. Thanks to Roman Weber
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/php/ChangeLog13
-rw-r--r--dev-php/php/files/digest-php-4.2.1-r31
-rw-r--r--dev-php/php/php-4.2.1-r1.ebuild19
-rw-r--r--dev-php/php/php-4.2.1-r3.ebuild169
4 files changed, 193 insertions, 9 deletions
diff --git a/dev-php/php/ChangeLog b/dev-php/php/ChangeLog
index 37021b8834a5..839605806d22 100644
--- a/dev-php/php/ChangeLog
+++ b/dev-php/php/ChangeLog
@@ -1,6 +1,13 @@
-# ChangeLog for dev-lang/phpcgi
+# ChangeLog for dev-lang/php
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.2 2002/07/09 19:20:50 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.3 2002/07/16 03:56:18 rphillips Exp $
+
+*php-4.2.1-r3 (12 Jul 2002)
+
+ 12 Jul 2002; Roman Weber <gentoo@gonzo.ch> php-4.2.1-r3.ebuild :
+
+ Fixed compile error with sablotron 0.95
+ Fixed weird uname bug. (Bug #4913)
*php-4.2.1-r2 (09 Jul 2002) php-4.2.1-r2.ebuild :
@@ -21,7 +28,7 @@
Update to actual 4.2.1 release.
-*phpcgi-4.2.0 (23 Apr 2002)
+*php-4.2.0 (23 Apr 2002)
23 Apr 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
diff --git a/dev-php/php/files/digest-php-4.2.1-r3 b/dev-php/php/files/digest-php-4.2.1-r3
new file mode 100644
index 000000000000..ceaa1d27083e
--- /dev/null
+++ b/dev-php/php/files/digest-php-4.2.1-r3
@@ -0,0 +1 @@
+MD5 654983196a94ca91c272a00e877b2b40 php-4.2.1.tar.gz 3376494
diff --git a/dev-php/php/php-4.2.1-r1.ebuild b/dev-php/php/php-4.2.1-r1.ebuild
index 6d545f2abfa5..8a233106be1a 100644
--- a/dev-php/php/php-4.2.1-r1.ebuild
+++ b/dev-php/php/php-4.2.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Update: Roman Weber <gentoo@gonzo.ch>
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.2.1-r1.ebuild,v 1.2 2002/07/11 06:30:24 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.2.1-r1.ebuild,v 1.3 2002/07/16 03:56:18 rphillips Exp $
A=php-${PV}.tar.gz
S=${WORKDIR}/php-${PV}
@@ -12,11 +12,11 @@ LICENSE="PHP"
SLOT="0"
DEPEND=">=dev-libs/gmp-3.1.1
- freetype ( ~media-libs/freetype-1.3.1 >=media-libs/t1lib-1.3.1 )
- jpeg ( >=media-libs/jpeg-6b )
- tiff ( >=media-libs/tiff-3.5.5 )
- png ( >=media-libs/libpng-1.2.1 )
- gd ( >=media-libs/libgd-1.8.3 )
+ freetype? ( ~media-libs/freetype-1.3.1 >=media-libs/t1lib-1.3.1 )
+ jpeg? ( >=media-libs/jpeg-6b )
+ tiff? ( >=media-libs/tiff-3.5.5 )
+ png? ( >=media-libs/libpng-1.2.1 )
+ gd? ( >=media-libs/libgd-1.8.3 )
X? ( virtual/x11 )
qt? ( =x11-libs/qt-2.3* )
nls? ( sys-devel/gettext )
@@ -75,6 +75,13 @@ src_compile() {
use jpeg && myconf="${myconf} --with-jpeg-dir=/usr/lib"
use png && myconf="${myconf} --with-png-dir=/usr"
use tiff && myconf="${myconf} --with-tiff-dir=/usr"
+
+ # optional support for oracle oci8
+ if [ "`use oci8`" ] ; then
+ if [ "$ORACLE_HOME" ] ; then
+ myconf="${myconf} --with-oci8=${ORACLE_HOME}"
+ fi
+ fi
use qt && ( \
export QTDIR=/usr/qt/2 #hope this helps - danarmak
diff --git a/dev-php/php/php-4.2.1-r3.ebuild b/dev-php/php/php-4.2.1-r3.ebuild
new file mode 100644
index 000000000000..66b10eb16f5d
--- /dev/null
+++ b/dev-php/php/php-4.2.1-r3.ebuild
@@ -0,0 +1,169 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Update: Roman Weber <gentoo@gonzo.ch>
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.2.1-r3.ebuild,v 1.1 2002/07/16 03:56:18 rphillips Exp $
+
+A=php-${PV}.tar.gz
+S=${WORKDIR}/php-${PV}
+DESCRIPTION="HTML embedded scripting language"
+SRC_URI="http://www.php.net/distributions/${A}"
+HOMEPAGE="http://www.php.net/"
+LICENSE="PHP"
+SLOT="0"
+
+DEPEND=">=dev-libs/gmp-3.1.1
+ freetype? ( ~media-libs/freetype-1.3.1 >=media-libs/t1lib-1.3.1 )
+ jpeg? ( >=media-libs/jpeg-6b )
+ tiff? ( >=media-libs/tiff-3.5.5 )
+ png? ( >=media-libs/libpng-1.2.1 )
+ gd? ( >=media-libs/libgd-1.8.3 )
+ X? ( virtual/x11 )
+ qt? ( =x11-libs/qt-2.3* )
+ nls? ( sys-devel/gettext )
+ pam? ( >=sys-libs/pam-0.75 )
+ xml? ( >=app-text/sablotron-0.95-r1 )
+ ssl? ( >=dev-libs/openssl-0.9.5 )
+ curl? ( >=net-ftp/curl-7.8.1 )
+ snmp? ( >=net-analyzer/ucd-snmp-4.2.3 )
+ imap? ( >=net-mail/uw-imap-2001a-r1 )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ ldap? ( >=net-nds/openldap-1.2.11 )
+ odbc? ( >=dev-db/unixODBC-1.8.13 )
+ xml2? ( dev-libs/libxml2 )
+ crypt? ( >=dev-libs/libmcrypt-2.4
+ >=app-crypt/mhash-0.8 )
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ flash? ( media-libs/libswf >=media-libs/ming-0.2a )
+ berkdb? ( >=sys-libs/db-3 )
+ libwww? ( >=net-libs/libwww-5.3.2 )
+ firebird? ( >=dev-db/firebird-1.0 )
+ pdflib? ( >=media-libs/pdflib-4.0.1-r2 )
+ postgres? ( >=dev-db/postgresql-7.1 )
+ readline? ( >=sys-libs/ncurses-5.1
+ >=sys-libs/readline-4.1 )"
+
+RDEPEND="${DEPEND}
+ qt? ( >=x11-libs/qt-2.3.0 )
+ xml? ( >=app-text/sablotron-0.95-r1 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Configure Patch for wired uname -a
+ mv configure configure.old
+ cat configure.old | sed "s/PHP_UNAME=\`uname -a\`/PHP_UNAME=\`uname -s -n -r -v\`/g" > configure
+ chmod 755 configure
+}
+
+src_compile() {
+
+ local myconf
+
+ use readline && myconf="${myconf} --with-readline"
+ use pam && myconf="${myconf} --with-pam"
+ use nls && myconf="${myconf} --with-gettext" || myconf="${myconf} --without-gettext"
+ use ssl && myconf="${myconf} --with-openssl"
+ use curl && myconf="${myconf} --with-curl"
+ use snmp && myconf="${myconf} --with-snmp --enable-ucd-snmp-hack"
+ use gdbm && myconf="${myconf} --with-gdbm=/usr"
+ use berkdb && myconf="${myconf} --with-db3=/usr"
+ use mysql && myconf="${myconf} --with-mysql=/usr" || myconf="${myconf} --without-mysql"
+ use postgres && myconf="${myconf} --with-pgsql=/usr"
+ use odbc && myconf="${myconf} --with-unixODBC=/usr"
+ use ldap && myconf="${myconf} --with-ldap"
+ use pdflib && myconf="${myconf} --with-pdflib=/usr"
+ use firebird && myconf="${myconf} --with-interbase=/opt/interbase"
+ use gd && myconf="${myconf} --with-gd"
+ use freetype && myconf="${myconf} --with-ttf --with-t1lib"
+ use jpeg && myconf="${myconf} --with-jpeg-dir=/usr/lib"
+ use png && myconf="${myconf} --with-png-dir=/usr"
+ use tiff && myconf="${myconf} --with-tiff-dir=/usr"
+
+ # optional support for oracle oci8
+ if [ "`use oci8`" ] ; then
+ if [ "$ORACLE_HOME" ] ; then
+ myconf="${myconf} --with-oci8=${ORACLE_HOME}"
+ fi
+ fi
+
+ use qt && ( \
+ export QTDIR=/usr/qt/2 #hope this helps - danarmak
+ myconf="${myconf} --with-qtdom"
+ )
+
+ if [ "`use imap`" ] ; then
+ if [ "`use ssl`" ] && [ "`strings ${ROOT}/usr/lib/c-client.a \
+ | grep ssl_onceonlyinit`" ] ; then
+ echo "Compiling imap with SSL support"
+ myconf="${myconf} --with-imap --with-imap-ssl"
+ else
+ echo "Compiling imap without SSL support"
+ myconf="${myconf} --with-imap"
+ fi
+ fi
+ use libwww && myconf="${myconf} --with-xml" || myconf="${myconf} --disable-xml"
+ use flash && myconf="${myconf} --with-swf=/usr --with-ming=/usr"
+
+ if [ "`use xml`" ] ; then
+ export LIBS="-lxmlparse -lxmltok"
+ myconf="${myconf} --with-sablot=/usr"
+ myconf="${myconf} --enable-xslt"
+ myconf="${myconf} --with-xslt-sablot"
+ fi
+
+ use xml2 && myconf="${myconf} --with-dom"
+ use crypt && myconf="${myconf} --with-mcrypt --with-mhash"
+
+ LDFLAGS="$LDFLAGS -ltiff -ljpeg"
+
+ if [ "`use X`" ] ; then
+ myconf="${myconf} --with-xpm-dir=/usr/X11R6"
+ LDFLAGS="$LDFLAGS -L/usr/X11R6/lib"
+ fi
+
+ ./configure \
+ --prefix=/usr \
+ --with-gmp \
+ --with-bz2 \
+ --enable-ftp \
+ --enable-dbase \
+ --with-zlib=yes \
+ --enable-bcmath \
+ --enable-sysvsem \
+ --enable-sysvshm \
+ --enable-calendar \
+ --enable-trans-sid \
+ --enable-versioning \
+ --enable-track-vars \
+ --enable-inline-optimization \
+ --with-config-file-path=/etc/php4 \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ make || die "compile problem"
+}
+
+
+src_install() {
+ make INSTALL_ROOT=${D} install-pear || die
+
+ dodoc CODING_STANDARDS LICENSE EXTENSIONS
+ dodoc RELEASE_PROCESS README.* TODO NEWS
+ dodoc ChangeLog* *.txt
+
+ exeinto /usr/bin
+ doexe php
+
+ insinto /etc/php4
+ cat php.ini-dist | sed "s/register_globals = Off/register_globals = On/g" > php.ini
+ doins php.ini
+ dosym /usr/lib/php/extensions/no-debug-non-zts-20020429 /etc/php4/lib
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Please don't use this package on a webserver."
+ einfo "There is no security compiled in."
+ einfo
+}
+