summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2010-09-26 18:22:35 +0000
committerOle Markus With <olemarkus@gentoo.org>2010-09-26 18:22:35 +0000
commitade3a1a99ba2171ff5adf351b87cb024cab9bd71 (patch)
tree6803c50f298e84eaa4dc0068a37be12e5fed9a91 /dev-php5
parentDrop ruby19 to make this a stable candidate. (diff)
downloadhistorical-ade3a1a99ba2171ff5adf351b87cb024cab9bd71.tar.gz
historical-ade3a1a99ba2171ff5adf351b87cb024cab9bd71.tar.bz2
historical-ade3a1a99ba2171ff5adf351b87cb024cab9bd71.zip
Added dev-php5/pecl-haru (bug #249443)
Package-Manager: portage-2.1.8.3/cvs/Linux i686
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/pecl-haru/ChangeLog10
-rw-r--r--dev-php5/pecl-haru/Manifest4
-rw-r--r--dev-php5/pecl-haru/metadata.xml9
-rw-r--r--dev-php5/pecl-haru/pecl-haru-1.0.0.ebuild34
4 files changed, 57 insertions, 0 deletions
diff --git a/dev-php5/pecl-haru/ChangeLog b/dev-php5/pecl-haru/ChangeLog
new file mode 100644
index 000000000000..1db8eb1cd094
--- /dev/null
+++ b/dev-php5/pecl-haru/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-php5/pecl-haru
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-haru/ChangeLog,v 1.1 2010/09/26 18:22:35 olemarkus Exp $
+
+*pecl-haru-1.0.0 (26 Sep 2010)
+
+ 26 Sep 2010; <olemarkus@gentoo.org> +pecl-haru-1.0.0.ebuild,
+ +metadata.xml:
+ Added pecl-haru (bug #249443)
+
diff --git a/dev-php5/pecl-haru/Manifest b/dev-php5/pecl-haru/Manifest
new file mode 100644
index 000000000000..2032b98cf45d
--- /dev/null
+++ b/dev-php5/pecl-haru/Manifest
@@ -0,0 +1,4 @@
+DIST haru-1.0.0.tgz 23336 RMD160 75d48cbf357be5a440c2cf8618b294bffd88cf9c SHA1 a7ee087d4e0081cb933d2328ab76ea8bef84c118 SHA256 90180684438ce6ad4ac8f1c2ac496d6c132d2345590f11ce230ed7cc1e26b5a5
+EBUILD pecl-haru-1.0.0.ebuild 793 RMD160 319ddaf676c2934abc05f1aa2f40aba55f5a8e37 SHA1 eee0eddff11f744e2bdfa25cfa9af122d801cd4a SHA256 c2ed1ade99a4cbe4604c5db1218f14485889ee433892b889af7acdebe4a7bf1f
+MISC ChangeLog 357 RMD160 23bf23bc0d7f05773dd9f0c42dc5a827ecbaea27 SHA1 380c50b49d68023d00396b577c954f90888d87ea SHA256 1637415f56fb7857d6ff062c8cb89249004f5db3fa13e4ceda48256c6ef7e784
+MISC metadata.xml 291 RMD160 4a9d95eed8a7ae045b4ee8680b966b466354c7c3 SHA1 b5d33382587939e751c24a765d718a420448ba03 SHA256 928f03bc41d212cb804a7a3d4df9b2ebc61149835f133bacca230ed6e46c7cb7
diff --git a/dev-php5/pecl-haru/metadata.xml b/dev-php5/pecl-haru/metadata.xml
new file mode 100644
index 000000000000..0c93320ef0b0
--- /dev/null
+++ b/dev-php5/pecl-haru/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+ <longdescription lang="en">These functions allow you to create PDF documents
+ using the Haru Free PDF Library.
+ </longdescription>
+</pkgmetadata>
+
diff --git a/dev-php5/pecl-haru/pecl-haru-1.0.0.ebuild b/dev-php5/pecl-haru/pecl-haru-1.0.0.ebuild
new file mode 100644
index 000000000000..b3b0850c97a4
--- /dev/null
+++ b/dev-php5/pecl-haru/pecl-haru-1.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-haru/pecl-haru-1.0.0.ebuild,v 1.1 2010/09/26 18:22:35 olemarkus Exp $
+
+EAPI=3
+
+PHP_EXT_NAME="haru"
+
+inherit php-ext-pecl-r1
+
+DESCRIPTION="An interface to libharu, a PDF generator"
+
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="png zlib"
+
+DEPEND="media-libs/libharu[png?,zlib?]"
+RDEPEND="${DEPEND}"
+
+need_php_by_category
+
+src_configure() {
+ true # php-ext-*-r1 doesn't really support EAPI=3
+}
+
+src_compile() {
+ # config.m4 is broken checking paths, so we need to override it
+ my_conf="--with-haru=/usr"
+ use png && my_conf+=" --with-png-dir=/usr"
+ use zlib && my_conf+=" --with-zlib-dir=/usr"
+
+ php-ext-source-r1_src_compile
+}