summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2008-03-30 19:51:01 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2008-03-30 19:51:01 +0000
commit071d168323229c5f37fe7d86544b2b6884b7b7a3 (patch)
tree30561e24a4060f8269e83580c4959d93d8dcaccd /dev-php5
parentCleanup. (diff)
downloadhistorical-071d168323229c5f37fe7d86544b2b6884b7b7a3.tar.gz
historical-071d168323229c5f37fe7d86544b2b6884b7b7a3.tar.bz2
historical-071d168323229c5f37fe7d86544b2b6884b7b7a3.zip
* bump
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/onphp-module/ChangeLog8
-rw-r--r--dev-php5/onphp-module/onphp-module-1.0.4.ebuild34
-rw-r--r--dev-php5/onphp/ChangeLog8
-rw-r--r--dev-php5/onphp/onphp-1.0.4.ebuild33
4 files changed, 81 insertions, 2 deletions
diff --git a/dev-php5/onphp-module/ChangeLog b/dev-php5/onphp-module/ChangeLog
index c7c79a377749..ebbaa1b4dab6 100644
--- a/dev-php5/onphp-module/ChangeLog
+++ b/dev-php5/onphp-module/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php5/onphp-module
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp-module/ChangeLog,v 1.31 2008/03/24 17:45:04 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp-module/ChangeLog,v 1.32 2008/03/30 19:51:01 voxus Exp $
+
+*onphp-module-1.0.4 (30 Mar 2008)
+
+ 30 Mar 2008; Konstantin V. Arkhipov <voxus@gentoo.org>
+ +onphp-module-1.0.4.ebuild:
+ Version bump.
*onphp-module-1.0.3 (24 Mar 2008)
diff --git a/dev-php5/onphp-module/onphp-module-1.0.4.ebuild b/dev-php5/onphp-module/onphp-module-1.0.4.ebuild
new file mode 100644
index 000000000000..58499dcc61b7
--- /dev/null
+++ b/dev-php5/onphp-module/onphp-module-1.0.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp-module/onphp-module-1.0.4.ebuild,v 1.1 2008/03/30 19:51:01 voxus Exp $
+
+PHP_EXT_NAME="onphp"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-pecl-r1
+
+SRC_URI="http://onphp.org/download/onphp-${PV}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+DESCRIPTION="onPHP's module."
+HOMEPAGE="http://onphp.org/"
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE=""
+
+# since need_php51 is missing
+DEPEND=">=dev-lang/php-5.2"
+RDEPEND="${DEPEND}
+ ~dev-php5/onphp-${PV}"
+
+PHP_VERSION="5"
+PHP_SHARED_CAT="php5"
+
+S="${WORKDIR}/onphp-${PV}/ext"
+
+pkg_setup() {
+ has_php
+
+ require_php_with_use spl
+}
diff --git a/dev-php5/onphp/ChangeLog b/dev-php5/onphp/ChangeLog
index 2f69473466f4..c0ec1f606773 100644
--- a/dev-php5/onphp/ChangeLog
+++ b/dev-php5/onphp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php5/onphp
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/ChangeLog,v 1.57 2008/03/24 17:44:44 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/ChangeLog,v 1.58 2008/03/30 19:50:57 voxus Exp $
+
+*onphp-1.0.4 (30 Mar 2008)
+
+ 30 Mar 2008; Konstantin V. Arkhipov <voxus@gentoo.org>
+ +onphp-1.0.4.ebuild:
+ Version bump.
*onphp-1.0.3 (24 Mar 2008)
diff --git a/dev-php5/onphp/onphp-1.0.4.ebuild b/dev-php5/onphp/onphp-1.0.4.ebuild
new file mode 100644
index 000000000000..a844fc32e634
--- /dev/null
+++ b/dev-php5/onphp/onphp-1.0.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/onphp-1.0.4.ebuild,v 1.1 2008/03/30 19:50:57 voxus Exp $
+
+inherit php-lib-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="onPHP is the LGPL'ed multi-purpose object-oriented PHP framework."
+HOMEPAGE="http://onphp.org/"
+SRC_URI="http://onphp.org/download/${P}.tar.bz2
+ doc? ( http://onphp.org/download/${PN}-api-${PV}.tar.bz2 )"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND=""
+
+need_php_by_category
+
+src_install() {
+ has_php
+
+ dodoc `find doc -maxdepth 1 -type f -print`
+
+ if use doc ; then
+ dohtml -r "${WORKDIR}/${PN}-api-${PV}/"*
+ fi
+
+ php-lib-r1_src_install ./ global.inc.php.tpl
+ php-lib-r1_src_install ./ `find core main meta -type f -print`
+}