summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2006-10-27 19:54:16 +0000
committerSven Wegener <swegener@gentoo.org>2006-10-27 19:54:16 +0000
commit43eea8774f78ec6a4799f7c7952ed8335f8891b4 (patch)
tree6ebabc748dfe5df842dee639164fb6cc6f2743b4 /dev-php/xdebug-client/xdebug-client-2.0.0_rc1.ebuild
parentMoved to vdr-testing overlay. (diff)
downloadhistorical-43eea8774f78ec6a4799f7c7952ed8335f8891b4.tar.gz
historical-43eea8774f78ec6a4799f7c7952ed8335f8891b4.tar.bz2
historical-43eea8774f78ec6a4799f7c7952ed8335f8891b4.zip
Set S correctly to avoid cd'ing around.
Package-Manager: portage-2.1.2_pre3-r9
Diffstat (limited to 'dev-php/xdebug-client/xdebug-client-2.0.0_rc1.ebuild')
-rw-r--r--dev-php/xdebug-client/xdebug-client-2.0.0_rc1.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/dev-php/xdebug-client/xdebug-client-2.0.0_rc1.ebuild b/dev-php/xdebug-client/xdebug-client-2.0.0_rc1.ebuild
index 6b6579a665f2..511fdcc00b01 100644
--- a/dev-php/xdebug-client/xdebug-client-2.0.0_rc1.ebuild
+++ b/dev-php/xdebug-client/xdebug-client-2.0.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/xdebug-client-2.0.0_rc1.ebuild,v 1.1 2006/10/27 18:58:01 sebastian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/xdebug-client-2.0.0_rc1.ebuild,v 1.2 2006/10/27 19:54:16 swegener Exp $
IUSE="libedit"
DESCRIPTION="Xdebug client for the Common Debugger Protocol (DBGP)."
@@ -8,16 +8,18 @@ HOMEPAGE="http://www.xdebug.org/"
SLOT="0"
MY_PV="${PV/_/}"
SRC_URI="http://pecl.php.net/get/xdebug-${MY_PV}.tgz"
-S="${WORKDIR}/xdebug-2.0.0RC1"
+S="${WORKDIR}/xdebug-2.0.0RC1/debugclient"
LICENSE="Xdebug"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-DEPEND="${DEPEND} libedit? ( || ( dev-libs/libedit sys-freebsd/freebsd-lib ) )"
+DEPEND="libedit? ( || ( dev-libs/libedit sys-freebsd/freebsd-lib ) )"
-src_compile() {
- cd "${S}/debugclient"
- chmod +x configure
+src_unpack() {
+ unpack ${A}
+ chmod +x "${S}"/configure
+}
+src_compile() {
econf \
$(use_with libedit ) \
|| die "Configure of debug client failed!"
@@ -26,6 +28,5 @@ src_compile() {
}
src_install() {
- cd "${S}/debugclient"
newbin debugclient xdebug
}