summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-10-23 02:08:18 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-10-23 02:08:18 +0000
commit18a068aabb45ef650d1c5ef2996a30fd2bb8bd2d (patch)
treefa2e983b2e591806f8c200916b45def255a57fb6 /dev-php/php
parentcleanup ebuild and version bump for eclass changes (diff)
downloadhistorical-18a068aabb45ef650d1c5ef2996a30fd2bb8bd2d.tar.gz
historical-18a068aabb45ef650d1c5ef2996a30fd2bb8bd2d.tar.bz2
historical-18a068aabb45ef650d1c5ef2996a30fd2bb8bd2d.zip
cleanup ebuild and version bump for eclass changes
Diffstat (limited to 'dev-php/php')
-rw-r--r--dev-php/php/Manifest4
-rw-r--r--dev-php/php/files/digest-php-4.3.3-r32
-rw-r--r--dev-php/php/php-4.3.3-r3.ebuild51
3 files changed, 55 insertions, 2 deletions
diff --git a/dev-php/php/Manifest b/dev-php/php/Manifest
index 50739b35ae71..a55d7e20bd56 100644
--- a/dev-php/php/Manifest
+++ b/dev-php/php/Manifest
@@ -5,9 +5,9 @@ MD5 25f97fc9df6d134f3da1b4e5c1414830 php-4.3.2.ebuild 2418
MD5 3eeafc4e390ffd783e014a5ec877e820 php-4.3.2-r2.ebuild 1182
MD5 f1385520cac897796eeae1ad974ac15c php-4.3.3-r1.ebuild 1208
MD5 ff00712ef064fedea5c310204c367b1a php-5.0_beta1.ebuild 1176
-MD5 b2f257d721a7241e811cbaedfffb64c6 ChangeLog 9561
+MD5 50ce68feb8934b968076e44bb1e6c0e5 ChangeLog 9561
MD5 38fe937e954ab7109395cefa86fcd2d4 metadata.xml 384
-MD5 f9bf99a40026d535c8201c72cd853704 php-4.3.3-r3.ebuild 1218
+MD5 db16022e0ec00d919b30ab222f073577 php-4.3.3-r3.ebuild 1218
MD5 ce0950f7facac1bcd6c3f99321f4648a php-4.3.2-r1.ebuild 990
MD5 bc498859e45cdd2924f64ae5ef806239 php-4.3.3.ebuild 1210
MD5 63f7765d77e10eeef4b306480cd5d200 files/digest-php-4.3.2-r1 137
diff --git a/dev-php/php/files/digest-php-4.3.3-r3 b/dev-php/php/files/digest-php-4.3.3-r3
new file mode 100644
index 000000000000..1fecdf01d76d
--- /dev/null
+++ b/dev-php/php/files/digest-php-4.3.3-r3
@@ -0,0 +1,2 @@
+MD5 1171d96104e2ff2cff9e19789a4a1536 php-4.3.3.tar.bz2 3711877
+MD5 912ff94309b762563d0542db5187315f php-4.3.2-fopen-url-secure.patch 416
diff --git a/dev-php/php/php-4.3.3-r3.ebuild b/dev-php/php/php-4.3.3-r3.ebuild
new file mode 100644
index 000000000000..ed7b9254e405
--- /dev/null
+++ b/dev-php/php/php-4.3.3-r3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.3.3-r3.ebuild,v 1.1 2003/10/23 02:06:25 robbat2 Exp $
+
+PHPSAPI="cli"
+inherit php eutils
+
+IUSE="${IUSE} readline"
+
+DESCRIPTION="PHP Shell Interpreter"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm ~hppa ~mips"
+
+DEPEND_EXTRA="readline? ( >=sys-libs/ncurses-5.1 >=sys-libs/readline-4.1 )
+ ncurses? ( >=sys-libs/ncurses-5.1 )"
+DEPEND="${DEPEND} ${DEPEND_EXTRA}"
+RDEPEND="${RDEPEND} ${DEPEND_EXTRA}"
+
+src_compile() {
+ myconf="${myconf} `use_with readline readline /usr`"
+ # Readline and Ncurses are CLI PHP only
+ # readline needs ncurses
+ use ncurses || use readline \
+ && myconf="${myconf} --with-ncurses=/usr" \
+ || myconf="${myconf} --without-ncurses"
+
+ myconf="${myconf} \
+ --disable-cgi \
+ --enable-cli"
+
+ php_src_compile
+}
+
+
+src_install() {
+ installtargets="${installtargets} install-cli"
+ php_src_install
+
+ # php executable is located in ./sapi/cli/
+ exeinto /usr/bin
+ doexe sapi/cli/php
+}
+
+pkg_postinst() {
+ php_pkg_postinst
+ einfo "This is a CLI only build."
+ einfo "You can not use it on a webserver."
+}
+pkg_preinst() {
+ php_pkg_preinst
+}