summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-08-12 11:08:09 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-08-12 11:08:09 +0000
commitf45f3af6f58d4278472437b0a4284c24b165f9a7 (patch)
tree8cb61662010ae5a21f16ee5b18c0c8ed6d54c218 /dev-php/php-cgi
parentRoll out 5.0.0-r1 to ~x86 ONLY. Other interested arches need to keyword the r... (diff)
downloadhistorical-f45f3af6f58d4278472437b0a4284c24b165f9a7.tar.gz
historical-f45f3af6f58d4278472437b0a4284c24b165f9a7.tar.bz2
historical-f45f3af6f58d4278472437b0a4284c24b165f9a7.zip
Roll out 5.0.0-r1 to ~x86 ONLY. Other interested arches need to keyword the required dependancies first. Create virtual/httpd-php.
Diffstat (limited to 'dev-php/php-cgi')
-rw-r--r--dev-php/php-cgi/ChangeLog6
-rw-r--r--dev-php/php-cgi/php-cgi-5.0.0-r1.ebuild12
2 files changed, 13 insertions, 5 deletions
diff --git a/dev-php/php-cgi/ChangeLog b/dev-php/php-cgi/ChangeLog
index 5b669593e359..d0e545256ca4 100644
--- a/dev-php/php-cgi/ChangeLog
+++ b/dev-php/php-cgi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php/php-cgi
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cgi/ChangeLog,v 1.33 2004/08/12 10:51:07 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cgi/ChangeLog,v 1.34 2004/08/12 11:08:09 robbat2 Exp $
+
+ 12 Aug 2004; Robin H. Johnson <robbat2@gentoo.org> php-cgi-5.0.0-r1.ebuild:
+ Roll out 5.0.0-r1 to ~x86 ONLY. Other interested arches need to keyword the
+ required dependancies first. Create virtual/httpd-php.
*php-cgi-4.3.9_rc1 (12 Aug 2004)
diff --git a/dev-php/php-cgi/php-cgi-5.0.0-r1.ebuild b/dev-php/php-cgi/php-cgi-5.0.0-r1.ebuild
index 72bcfbc8533f..a1a8959404e1 100644
--- a/dev-php/php-cgi/php-cgi-5.0.0-r1.ebuild
+++ b/dev-php/php-cgi/php-cgi-5.0.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cgi/php-cgi-5.0.0-r1.ebuild,v 1.2 2004/08/09 09:49:51 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cgi/php-cgi-5.0.0-r1.ebuild,v 1.3 2004/08/12 11:08:09 robbat2 Exp $
PHPSAPI="cgi"
MY_P="php-${PV}"
@@ -9,10 +9,14 @@ inherit php5-sapi eutils
DESCRIPTION="PHP CGI"
SLOT="0"
-KEYWORDS="-x86 -sparc -alpha -hppa -ppc"
+KEYWORDS="~x86"
-# for this revision only
-PDEPEND=">=${PHP_PROVIDER_PKG}-5.0.0"
+# provides all base PHP extras (eg PEAR, extension building stuff)
+DEPEND_PHP=">=${PHP_PROVIDER_PKG}-5.0.0-r1"
+DEPEND="${DEPEND} ${DEPEND_PHP}"
+RDEPEND="${RDEPEND} ${DEPEND_PHP}"
+
+PROVIDE="virtual/php-${PV} virtual/httpd-php-${PV}"
src_compile() {
# CLI needed to build stuff