summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2011-04-09 19:17:03 +0000
committerOle Markus With <olemarkus@gentoo.org>2011-04-09 19:17:03 +0000
commit3bacfe40a7f327df6871bded41021f5759f8ef6c (patch)
tree876d6c7d8aecbb14a1edde018651ce3d586221d1 /dev-php/libchart/libchart-1.2.2.ebuild
parentMoving dev-php5/libchart to dev-php/libchart (diff)
downloadhistorical-3bacfe40a7f327df6871bded41021f5759f8ef6c.tar.gz
historical-3bacfe40a7f327df6871bded41021f5759f8ef6c.tar.bz2
historical-3bacfe40a7f327df6871bded41021f5759f8ef6c.zip
Version bump
Package-Manager: portage-2.1.9.42/cvs/Linux i686
Diffstat (limited to 'dev-php/libchart/libchart-1.2.2.ebuild')
-rw-r--r--dev-php/libchart/libchart-1.2.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-php/libchart/libchart-1.2.2.ebuild b/dev-php/libchart/libchart-1.2.2.ebuild
new file mode 100644
index 000000000000..b0bd3971c333
--- /dev/null
+++ b/dev-php/libchart/libchart-1.2.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/libchart/libchart-1.2.2.ebuild,v 1.1 2011/04/09 19:17:03 olemarkus Exp $
+
+EAPI="2"
+
+inherit php-lib-r1 depend.php
+
+DESCRIPTION="Libchart is a chart creation PHP library that is easy to use."
+HOMEPAGE="http://naku.dohcrew.com/libchart"
+SRC_URI="http://libchart.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3 BitstreamVera"
+KEYWORDS="~x86 ~amd64"
+SLOT=0
+IUSE="examples"
+
+need_php5
+
+DEPEND=""
+RDEPEND="dev-lang/php[truetype]
+ || ( dev-lang/php[gd] dev-lang/php[gd-external] )"
+
+src_install() {
+ php-lib-r1_src_install ${PN} `cd ${PN}; find . -type f -print`
+ for i in ${PN}/{ChangeLog,README} ; do
+ dodoc-php ${i}
+ rm -f ${i}
+ done
+ if use examples ; then
+ insinto /usr/share/doc/${CATEGORY}/${PF}
+ doins -r demo/
+ fi
+}