summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Hoffmann <hoffie@gentoo.org>2007-09-27 21:29:58 +0000
committerChristian Hoffmann <hoffie@gentoo.org>2007-09-27 21:29:58 +0000
commit04f294d6db9f4dd08607fa261e1e5640375f4004 (patch)
treef4a1a6d7faa102b0739a3a99cd6d09d975e6758b /dev-php/PEAR-Benchmark/PEAR-Benchmark-1.2.7-r1.ebuild
parentTwo gtkmm-2.10's ought to be enough for everybody (diff)
downloadhistorical-04f294d6db9f4dd08607fa261e1e5640375f4004.tar.gz
historical-04f294d6db9f4dd08607fa261e1e5640375f4004.tar.bz2
historical-04f294d6db9f4dd08607fa261e1e5640375f4004.zip
Install to correct location this time by using package2.xml instead of package.xml; fixes bug 194033
Package-Manager: portage-2.1.3.9
Diffstat (limited to 'dev-php/PEAR-Benchmark/PEAR-Benchmark-1.2.7-r1.ebuild')
-rw-r--r--dev-php/PEAR-Benchmark/PEAR-Benchmark-1.2.7-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-php/PEAR-Benchmark/PEAR-Benchmark-1.2.7-r1.ebuild b/dev-php/PEAR-Benchmark/PEAR-Benchmark-1.2.7-r1.ebuild
new file mode 100644
index 000000000000..482285fb8368
--- /dev/null
+++ b/dev-php/PEAR-Benchmark/PEAR-Benchmark-1.2.7-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Benchmark/PEAR-Benchmark-1.2.7-r1.ebuild,v 1.1 2007/09/27 21:29:57 hoffie Exp $
+
+inherit php-pear-r1 depend.php eutils
+
+DESCRIPTION="Framework to benchmark PHP scripts or function calls."
+LICENSE="PHP"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}"
+ rm -f package.xml
+ cp package2.xml package.xml
+}
+
+pkg_postinst() {
+ has_php
+ if ! built_with_use --missing true =${PHP_PKG} bcmath ; then
+ elog "${PN} can optionally use ${PHP_PKG} bcmath features."
+ elog "If you want those, recompile ${PHP_PKG} with these flags in USE."
+ fi
+}