summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2007-01-02 14:02:42 +0000
committerMichael Cummings <mcummings@gentoo.org>2007-01-02 14:02:42 +0000
commit67fddba06dc6b577413e6a572c1dc41e0c5138eb (patch)
treec7aae8fc6e9725142d5b07fabd62420080a54719 /dev-perl/glib-perl/glib-perl-1.142.ebuild
parentKeyworded ~sparc wrt #145970 and cleanup (diff)
downloadhistorical-67fddba06dc6b577413e6a572c1dc41e0c5138eb.tar.gz
historical-67fddba06dc6b577413e6a572c1dc41e0c5138eb.tar.bz2
historical-67fddba06dc6b577413e6a572c1dc41e0c5138eb.zip
Version bump
Package-Manager: portage-2.1.2_rc4-r3
Diffstat (limited to 'dev-perl/glib-perl/glib-perl-1.142.ebuild')
-rw-r--r--dev-perl/glib-perl/glib-perl-1.142.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/glib-perl/glib-perl-1.142.ebuild b/dev-perl/glib-perl/glib-perl-1.142.ebuild
new file mode 100644
index 000000000000..50c22e607ce2
--- /dev/null
+++ b/dev-perl/glib-perl/glib-perl-1.142.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/glib-perl/glib-perl-1.142.ebuild,v 1.1 2007/01/02 13:52:26 mcummings Exp $
+
+inherit perl-module eutils
+
+MY_P=Glib-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Glib - Perl wrappers for the GLib utility and Object libraries"
+HOMEPAGE="http://gtk2-perl.sf.net/"
+SRC_URI="mirror://cpan/authors/id/T/TS/TSCH/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="xml"
+SRC_TEST="do"
+
+RDEPEND=">=x11-libs/gtk+-2
+ >=dev-libs/glib-2
+ dev-lang/perl
+ dev-perl/extutils-pkgconfig
+ dev-perl/extutils-depends
+ xml? ( dev-perl/XML-Writer
+ dev-perl/XML-Parser )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-perl/extutils-depends-0.205
+ >=dev-perl/extutils-pkgconfig-1.07"
+