summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-08-23 22:10:13 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-08-23 22:10:13 +0000
commit387d47230a17108133304d33e522d6f46968b506 (patch)
treec41bd18ff2900af7220894974e21e07689b5d8aa /dev-perl/Test-Class/Test-Class-0.390.0-r1.ebuild
parentbumped current stable ebuild(s) EAPI to 5; committed directly to stable as no... (diff)
downloadhistorical-387d47230a17108133304d33e522d6f46968b506.tar.gz
historical-387d47230a17108133304d33e522d6f46968b506.tar.bz2
historical-387d47230a17108133304d33e522d6f46968b506.zip
bumped current stable ebuild(s) EAPI to 5; committed directly to stable as no other changes present and revbump helps stable systems to keep from dieing on perl-5.18 upgrade
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 RepoMan-Options: --force Manifest-Sign-Key: 0x2B6559ED
Diffstat (limited to 'dev-perl/Test-Class/Test-Class-0.390.0-r1.ebuild')
-rw-r--r--dev-perl/Test-Class/Test-Class-0.390.0-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-perl/Test-Class/Test-Class-0.390.0-r1.ebuild b/dev-perl/Test-Class/Test-Class-0.390.0-r1.ebuild
new file mode 100644
index 000000000000..a783f4e7dbb0
--- /dev/null
+++ b/dev-perl/Test-Class/Test-Class-0.390.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Test-Class/Test-Class-0.390.0-r1.ebuild,v 1.1 2014/08/23 22:06:10 axs Exp $
+
+EAPI=5
+
+MODULE_AUTHOR=ADIE
+MODULE_VERSION=0.39
+inherit perl-module
+
+DESCRIPTION="Easily create test classes in an xUnit style"
+
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND=">=virtual/perl-Storable-2
+ >=virtual/perl-Test-Simple-0.78
+ dev-perl/MRO-Compat"
+DEPEND="${RDEPEND}
+ >=virtual/perl-Module-Build-0.380.0
+ test? ( >=dev-perl/Test-Exception-0.25 )"
+
+SRC_TEST="do"