summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-02-18 06:35:37 +0000
committerTorsten Veller <tove@gentoo.org>2011-02-18 06:35:37 +0000
commitfba80452e7d2ab1914990f7bd2e1d8ffd8cb3ce9 (patch)
tree077e3b1ed8ed904d07e0a427f4a15b26741dba78 /dev-perl/Math-Random-ISAAC-XS/Math-Random-ISAAC-XS-1.4.ebuild
parent[bump] dev-perl/File-Remove-1.460 (diff)
downloadhistorical-fba80452e7d2ab1914990f7bd2e1d8ffd8cb3ce9.tar.gz
historical-fba80452e7d2ab1914990f7bd2e1d8ffd8cb3ce9.tar.bz2
historical-fba80452e7d2ab1914990f7bd2e1d8ffd8cb3ce9.zip
[bump] dev-perl/Math-Random-ISAAC-XS-1.4
Package-Manager: portage-2.2.0_alpha24/cvs/Linux x86_64
Diffstat (limited to 'dev-perl/Math-Random-ISAAC-XS/Math-Random-ISAAC-XS-1.4.ebuild')
-rw-r--r--dev-perl/Math-Random-ISAAC-XS/Math-Random-ISAAC-XS-1.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/Math-Random-ISAAC-XS/Math-Random-ISAAC-XS-1.4.ebuild b/dev-perl/Math-Random-ISAAC-XS/Math-Random-ISAAC-XS-1.4.ebuild
new file mode 100644
index 000000000000..7698d2dd803c
--- /dev/null
+++ b/dev-perl/Math-Random-ISAAC-XS/Math-Random-ISAAC-XS-1.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Math-Random-ISAAC-XS/Math-Random-ISAAC-XS-1.4.ebuild,v 1.1 2011/02/18 06:35:37 tove Exp $
+
+EAPI=3
+
+MODULE_AUTHOR=JAWNSY
+MODULE_VERSION=1.004
+inherit perl-module
+
+DESCRIPTION="C implementation of the ISAAC PRNG algorithm"
+
+LICENSE="|| ( public-domain Artistic Artistic-2 GPL-1 GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-perl/Math-Random-ISAAC"
+DEPEND="${RDEPEND}
+ virtual/perl-Module-Build
+ test? (
+ dev-perl/Test-NoWarnings
+ )"
+
+SRC_TEST="do"