summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Coie <rac@gentoo.org>2004-05-30 06:14:50 +0000
committerRobert Coie <rac@gentoo.org>2004-05-30 06:14:50 +0000
commit85ba9566499957c18562f70afcc23986e5fa58f1 (patch)
tree86a56ea2da7547316fb5794007894019fc43bf92 /dev-perl/AppConfig/AppConfig-1.56-r2.ebuild
parentAdded support for new kbuild module building #50914 by J van der Wulp. (diff)
downloadhistorical-85ba9566499957c18562f70afcc23986e5fa58f1.tar.gz
historical-85ba9566499957c18562f70afcc23986e5fa58f1.tar.bz2
historical-85ba9566499957c18562f70afcc23986e5fa58f1.zip
add blocksep patch, clean out deadwood
Diffstat (limited to 'dev-perl/AppConfig/AppConfig-1.56-r2.ebuild')
-rw-r--r--dev-perl/AppConfig/AppConfig-1.56-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/AppConfig/AppConfig-1.56-r2.ebuild b/dev-perl/AppConfig/AppConfig-1.56-r2.ebuild
new file mode 100644
index 000000000000..be3c126b04f8
--- /dev/null
+++ b/dev-perl/AppConfig/AppConfig-1.56-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/AppConfig/AppConfig-1.56-r2.ebuild,v 1.1 2004/05/30 06:14:50 rac Exp $
+
+inherit perl-module eutils
+
+DESCRIPTION="Application config (from ARGV, file, ...)"
+HOMEPAGE="http://search.cpan.org/author/ABW/AppConfig-1.55/"
+SRC_URI="http://www.cpan.org/authors/id/ABW/${P}.tar.gz"
+
+LICENSE="Artistic | GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~sparc ~alpha ~ppc"
+
+DEPEND="dev-perl/Test-Simple"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # 2004.05.27 rac
+ # this patch, which will be sent upstream, allows [ block ] to
+ # work without variables becoming ' block _var'
+
+ epatch ${FILESDIR}/blockwhitespace.patch
+
+ # 2004.05.28 rac
+ # this patch, which will be sent upstream, allows customizing the
+ # separator between [block] and variable name, instead of having _
+ # be hardwired. this is important when processing constructions
+ # where _ is a legal part of either blocks or variable names.
+
+ epatch ${FILESDIR}/blocksep.patch
+}