summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-10-28 08:13:31 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-10-28 08:13:31 +0000
commit2eaee3bf9648b49926ab921c271fea7f0cd786e3 (patch)
tree6c25e4fb03490761298d472e017422a1b421aa8f /dev-ml/ocamlgraph/ocamlgraph-1.8.5.ebuild
parentkeyword ~arm (diff)
downloadhistorical-2eaee3bf9648b49926ab921c271fea7f0cd786e3.tar.gz
historical-2eaee3bf9648b49926ab921c271fea7f0cd786e3.tar.bz2
historical-2eaee3bf9648b49926ab921c271fea7f0cd786e3.zip
version bump
Signed-off-by: aballier@gentoo.org Package-Manager: portage-2.2.14/cvs/Linux x86_64 Manifest-Sign-Key: 0x160F534A
Diffstat (limited to 'dev-ml/ocamlgraph/ocamlgraph-1.8.5.ebuild')
-rw-r--r--dev-ml/ocamlgraph/ocamlgraph-1.8.5.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-ml/ocamlgraph/ocamlgraph-1.8.5.ebuild b/dev-ml/ocamlgraph/ocamlgraph-1.8.5.ebuild
new file mode 100644
index 000000000000..f6def1163626
--- /dev/null
+++ b/dev-ml/ocamlgraph/ocamlgraph-1.8.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlgraph/ocamlgraph-1.8.5.ebuild,v 1.1 2014/10/28 08:13:27 aballier Exp $
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="O'Caml Graph library"
+HOMEPAGE="http://ocamlgraph.lri.fr/index.en.html"
+SRC_URI="http://ocamlgraph.lri.fr/download/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86"
+RDEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ gtk? ( dev-ml/lablgtk:=[gnomecanvas,ocamlopt?] )"
+DEPEND="${RDEPEND}
+ doc? ( dev-tex/hevea dev-ml/ocamlweb )"
+IUSE="doc examples gtk +ocamlopt"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-installfindlib.patch"
+}
+
+src_compile() {
+ emake byte
+ use ocamlopt && emake opt
+
+ if use doc; then
+ emake doc
+ fi
+
+ if use gtk; then
+ emake OCAMLBEST=$(usex ocamlopt opt byte) viewer dgraph editor
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ use ocamlopt || export WANT_OCAMLOPT=no
+ use gtk && export WANT_GTK=yes
+ emake install-findlib
+
+ if use gtk ; then
+ local ext=byte
+ use ocamlopt && ext=opt
+ newbin dgraph/dgraph.${ext} ${PN}-dgraph
+ newbin editor/editor.${ext} ${PN}-editor
+ newbin view_graph/viewgraph.${ext} ${PN}-viewgraph
+ fi
+
+ dodoc README CREDITS FAQ CHANGES
+ if use doc; then
+ dohtml doc/*
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}