summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-25 21:01:56 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-25 21:01:56 +0000
commitce1b59767ec11fee6577bc2d441009900ab0f95e (patch)
tree28a782c43e72d1d99f5cba10239e573337771049 /dev-lisp
parentVersion bump. (diff)
downloadhistorical-ce1b59767ec11fee6577bc2d441009900ab0f95e.tar.gz
historical-ce1b59767ec11fee6577bc2d441009900ab0f95e.tar.bz2
historical-ce1b59767ec11fee6577bc2d441009900ab0f95e.zip
add inherit eutils
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/clisp/clisp-2.32-r1.ebuild65
-rw-r--r--dev-lisp/clisp/clisp-2.32.ebuild65
-rw-r--r--dev-lisp/clisp/clisp-2.33.ebuild63
-rw-r--r--dev-lisp/cmucl/cmucl-18e-r1.ebuild24
-rw-r--r--dev-lisp/cmucl/cmucl-18e-r2.ebuild22
-rw-r--r--dev-lisp/cmucl/cmucl-18e-r3.ebuild22
-rw-r--r--dev-lisp/cmucl/cmucl-18e-r4.ebuild22
-rw-r--r--dev-lisp/cmucl/cmucl-18e.ebuild24
-rw-r--r--dev-lisp/common-lisp-controller/common-lisp-controller-3.76.ebuild5
-rw-r--r--dev-lisp/common-lisp-controller/common-lisp-controller-3.82.ebuild3
-rw-r--r--dev-lisp/ecls/ecls-0.9b.ebuild13
-rw-r--r--dev-lisp/plt/plt-202.ebuild5
-rw-r--r--dev-lisp/sbcl/sbcl-0.8.7-r1.ebuild16
-rw-r--r--dev-lisp/sbcl/sbcl-0.8.7.ebuild16
-rw-r--r--dev-lisp/sbcl/sbcl-0.8.8.ebuild16
-rw-r--r--dev-lisp/sbcl/sbcl-0.8.9.ebuild16
16 files changed, 196 insertions, 201 deletions
diff --git a/dev-lisp/clisp/clisp-2.32-r1.ebuild b/dev-lisp/clisp/clisp-2.32-r1.ebuild
index 2b8322506cd7..8feee179a91e 100644
--- a/dev-lisp/clisp/clisp-2.32-r1.ebuild
+++ b/dev-lisp/clisp/clisp-2.32-r1.ebuild
@@ -1,41 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.32-r1.ebuild,v 1.4 2004/03/30 20:58:13 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.32-r1.ebuild,v 1.5 2004/04/25 20:53:13 vapier Exp $
-inherit flag-o-matic common-lisp-common
-
-IUSE="X threads fastcgi postgres ldap nls berkdb"
-
-# Handle the case where the user has some other -falign-functions
-# option set. Bug 34630.
-
-if ! is-flag '-falign-functions=4' \
- && expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)' >/dev/null; then
- CFLAGS=${CFLAGS/\
-$(expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)')/\
--falign-functions=4}
-fi
-
-# Fails to compile without -falign-functions=4 when -march=pentium4
-# (or -march=pentium3, sometimes??) is defined. Bugs 33425 and 34630.
-
-if (is-flag '-march=pentium4' || is-flag '-march=pentium3') \
- && ! is-flag '-falign-functions=4'; then
- append-flags '-falign-functions=4'
-fi
-
-# Athlon XP users report problems with -O3 optimization. In this
-# block, we remove any optimization flag. Depending on bug 34497. we
-# may be able to reduce optimization to -O2.
-
-if is-flag '-march=athlon-xp'; then
- filter-flags '-O*'
-fi
+inherit flag-o-matic common-lisp-common eutils
DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
HOMEPAGE="http://clisp.sourceforge.net/"
SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
-S=${WORKDIR}/${P}
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="x86"
+IUSE="X threads fastcgi postgres ldap nls berkdb"
+
DEPEND="dev-libs/libsigsegv
dev-lisp/common-lisp-controller
fastcgi? ( dev-libs/fcgi )
@@ -45,9 +22,6 @@ DEPEND="dev-libs/libsigsegv
readline? ( sys-libs/readline )
nls? ( sys-devel/gettext )
berkdb? ( =sys-libs/db-4* )"
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="x86"
src_unpack() {
unpack ${A}
@@ -56,6 +30,29 @@ src_unpack() {
}
src_compile() {
+ # Handle the case where the user has some other -falign-functions
+ # option set. Bug 34630.
+ if ! is-flag '-falign-functions=4' \
+ && expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)' >/dev/null; then
+ CFLAGS=${CFLAGS/\
+ $(expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)')/\
+ -falign-functions=4}
+ fi
+
+ # Fails to compile without -falign-functions=4 when -march=pentium4
+ # (or -march=pentium3, sometimes??) is defined. Bugs 33425 and 34630.
+ if (is-flag '-march=pentium4' || is-flag '-march=pentium3') \
+ && ! is-flag '-falign-functions=4'; then
+ append-flags '-falign-functions=4'
+ fi
+
+ # Athlon XP users report problems with -O3 optimization. In this
+ # block, we remove any optimization flag. Depending on bug 34497. we
+ # may be able to reduce optimization to -O2.
+ if is-flag '-march=athlon-xp'; then
+ filter-flags '-O*'
+ fi
+
einfo "Using CFLAGS: ${CFLAGS}"
export CC="${CC} ${CFLAGS}"
unset CFLAGS CXXFLAGS
diff --git a/dev-lisp/clisp/clisp-2.32.ebuild b/dev-lisp/clisp/clisp-2.32.ebuild
index b14df0bd3eec..7b303a1fbb48 100644
--- a/dev-lisp/clisp/clisp-2.32.ebuild
+++ b/dev-lisp/clisp/clisp-2.32.ebuild
@@ -1,41 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.32.ebuild,v 1.2 2004/03/30 20:58:13 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.32.ebuild,v 1.3 2004/04/25 20:54:05 vapier Exp $
-inherit flag-o-matic
-
-IUSE="X threads fastcgi postgres ldap nls berkdb"
-
-# Handle the case where the user has some other -falign-functions
-# option set. Bug 34630.
-
-if ! is-flag '-falign-functions=4' \
- && expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)' >/dev/null; then
- CFLAGS=${CFLAGS/\
-$(expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)')/\
--falign-functions=4}
-fi
-
-# Fails to compile without -falign-functions=4 when -march=pentium4
-# (or -march=pentium3, sometimes??) is defined. Bugs 33425 and 34630.
-
-if (is-flag '-march=pentium4' || is-flag '-march=pentium3') \
- && ! is-flag '-falign-functions=4'; then
- append-flags '-falign-functions=4'
-fi
-
-# Athlon XP users report problems with -O3 optimization. In this
-# block, we remove any optimization flag. Depending on bug 34497. we
-# may be able to reduce optimization to -O2.
-
-if is-flag '-march=athlon-xp'; then
- filter-flags '-O*'
-fi
+inherit flag-o-matic eutils
DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
HOMEPAGE="http://clisp.sourceforge.net/"
SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
-S=${WORKDIR}/${P}
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~x86"
+IUSE="X threads fastcgi postgres ldap nls berkdb"
+
DEPEND="dev-libs/libsigsegv
dev-lisp/common-lisp-controller
fastcgi? ( dev-libs/fcgi )
@@ -45,9 +22,6 @@ DEPEND="dev-libs/libsigsegv
readline? ( sys-libs/readline )
nls? ( sys-devel/gettext )
berkdb? ( =sys-libs/db-4* )"
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="~x86"
src_unpack() {
unpack ${A}
@@ -56,6 +30,29 @@ src_unpack() {
}
src_compile() {
+ # Handle the case where the user has some other -falign-functions
+ # option set. Bug 34630.
+ if ! is-flag '-falign-functions=4' \
+ && expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)' >/dev/null; then
+ CFLAGS=${CFLAGS/\
+ $(expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)')/\
+ -falign-functions=4}
+ fi
+
+ # Fails to compile without -falign-functions=4 when -march=pentium4
+ # (or -march=pentium3, sometimes??) is defined. Bugs 33425 and 34630.
+ if (is-flag '-march=pentium4' || is-flag '-march=pentium3') \
+ && ! is-flag '-falign-functions=4'; then
+ append-flags '-falign-functions=4'
+ fi
+
+ # Athlon XP users report problems with -O3 optimization. In this
+ # block, we remove any optimization flag. Depending on bug 34497. we
+ # may be able to reduce optimization to -O2.
+ if is-flag '-march=athlon-xp'; then
+ filter-flags '-O*'
+ fi
+
einfo "Using CFLAGS: ${CFLAGS}"
export CC="${CC} ${CFLAGS}"
unset CFLAGS CXXFLAGS
diff --git a/dev-lisp/clisp/clisp-2.33.ebuild b/dev-lisp/clisp/clisp-2.33.ebuild
index 0c1f01fe9e65..df037726d915 100644
--- a/dev-lisp/clisp/clisp-2.33.ebuild
+++ b/dev-lisp/clisp/clisp-2.33.ebuild
@@ -1,41 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.33.ebuild,v 1.3 2004/03/30 20:58:13 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.33.ebuild,v 1.4 2004/04/25 20:54:43 vapier Exp $
inherit flag-o-matic common-lisp-common
-IUSE="X fastcgi postgres nls berkdb pcre"
-
-# Handle the case where the user has some other -falign-functions
-# option set. Bug 34630.
-
-if ! is-flag '-falign-functions=4' \
- && expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)' >/dev/null; then
- CFLAGS=${CFLAGS/\
-$(expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)')/\
--falign-functions=4}
-fi
-
-# Fails to compile without -falign-functions=4 when -march=pentium4
-# (or -march=pentium3, sometimes??) is defined. Bugs 33425 and 34630.
-
-if (is-flag '-march=pentium4' || is-flag '-march=pentium3') \
- && ! is-flag '-falign-functions=4'; then
- append-flags '-falign-functions=4'
-fi
-
-# Athlon XP users report problems with -O3 optimization. In this
-# block, we remove any optimization flag. Depending on bug 34497. we
-# may be able to reduce optimization to -O2.
-
-if is-flag '-march=athlon-xp'; then
- filter-flags '-O*'
-fi
-
DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
HOMEPAGE="http://clisp.sourceforge.net/"
SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
-S=${WORKDIR}/${P}
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="x86"
+IUSE="X fastcgi postgres nls berkdb pcre"
+
DEPEND="dev-libs/libsigsegv
dev-lisp/common-lisp-controller
fastcgi? ( dev-libs/fcgi )
@@ -45,9 +22,6 @@ DEPEND="dev-libs/libsigsegv
nls? ( sys-devel/gettext )
berkdb? ( =sys-libs/db-4* )
pcre? ( dev-libs/libpcre )"
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="x86"
src_unpack() {
unpack ${A}
@@ -56,6 +30,29 @@ src_unpack() {
}
src_compile() {
+ # Handle the case where the user has some other -falign-functions
+ # option set. Bug 34630.
+ if ! is-flag '-falign-functions=4' \
+ && expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)' >/dev/null; then
+ CFLAGS=${CFLAGS/\
+ $(expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)')/\
+ -falign-functions=4}
+ fi
+
+ # Fails to compile without -falign-functions=4 when -march=pentium4
+ # (or -march=pentium3, sometimes??) is defined. Bugs 33425 and 34630.
+ if (is-flag '-march=pentium4' || is-flag '-march=pentium3') \
+ && ! is-flag '-falign-functions=4'; then
+ append-flags '-falign-functions=4'
+ fi
+
+ # Athlon XP users report problems with -O3 optimization. In this
+ # block, we remove any optimization flag. Depending on bug 34497. we
+ # may be able to reduce optimization to -O2.
+ if is-flag '-march=athlon-xp'; then
+ filter-flags '-O*'
+ fi
+
einfo "Using CFLAGS: ${CFLAGS}"
export CC="${CC} ${CFLAGS}"
unset CFLAGS CXXFLAGS
diff --git a/dev-lisp/cmucl/cmucl-18e-r1.ebuild b/dev-lisp/cmucl/cmucl-18e-r1.ebuild
index 2e2f819f315f..c1a73bfedbf2 100644
--- a/dev-lisp/cmucl/cmucl-18e-r1.ebuild
+++ b/dev-lisp/cmucl/cmucl-18e-r1.ebuild
@@ -1,25 +1,27 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl/cmucl-18e-r1.ebuild,v 1.2 2003/11/25 17:40:20 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl/cmucl-18e-r1.ebuild,v 1.3 2004/04/25 20:55:17 vapier Exp $
+
+inherit eutils
# This package is a port of the Debian package of the same name.
DEB_PV=7
DESCRIPTION="CMUCL Lisp. This conforms to the ANSI Common Lisp Standard"
-HOMEPAGE="http://www.cons.org/cmucl/
- http://packages.debian.org/unstable/devel/cmucl.html"
+HOMEPAGE="http://www.cons.org/cmucl/ http://packages.debian.org/unstable/devel/cmucl.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cmucl/cmucl_${PV}.orig.tar.gz
+ http://ftp.debian.org/debian/pool/main/c/cmucl/cmucl_${PV}-${DEB_PV}.diff.gz
+ http://cmucl.cons.org/ftp-area/cmucl/release/18e/cmucl-${PV}-x86-linux.tar.bz2"
+
LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="doc X"
+
DEPEND="dev-lisp/common-lisp-controller
x11-libs/lesstif
doc? ( app-text/tetex )"
# X? ( x11-libs/lesstif )"
-IUSE="doc X"
-SLOT="0"
-KEYWORDS="x86"
-SRC_URI="http://ftp.debian.org/debian/pool/main/c/cmucl/cmucl_${PV}.orig.tar.gz
- http://ftp.debian.org/debian/pool/main/c/cmucl/cmucl_${PV}-${DEB_PV}.diff.gz
- http://cmucl.cons.org/ftp-area/cmucl/release/18e/cmucl-${PV}-x86-linux.tar.bz2"
-
PROVIDE="virtual/commonlisp"
S=${WORKDIR}/${P}.orig
diff --git a/dev-lisp/cmucl/cmucl-18e-r2.ebuild b/dev-lisp/cmucl/cmucl-18e-r2.ebuild
index d6a374562040..0f840faa7f74 100644
--- a/dev-lisp/cmucl/cmucl-18e-r2.ebuild
+++ b/dev-lisp/cmucl/cmucl-18e-r2.ebuild
@@ -1,29 +1,27 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl/cmucl-18e-r2.ebuild,v 1.1 2004/01/28 22:12:37 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl/cmucl-18e-r2.ebuild,v 1.2 2004/04/25 20:56:04 vapier Exp $
-inherit common-lisp-common
+inherit common-lisp-common eutils
DEB_PV=8
DESCRIPTION="CMUCL Lisp. This conforms to the ANSI Common Lisp Standard"
-HOMEPAGE="http://www.cons.org/cmucl/
- http://packages.debian.org/unstable/devel/cmucl.html"
+HOMEPAGE="http://www.cons.org/cmucl/ http://packages.debian.org/unstable/devel/cmucl.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cmucl/cmucl_${PV}-${DEB_PV}.tar.gz
+ http://cmucl.cons.org/ftp-area/cmucl/release/18e/cmucl-${PV}-x86-linux.tar.bz2"
+
LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="doc X"
+
DEPEND="dev-lisp/common-lisp-controller
x11-libs/lesstif
doc? ( app-text/tetex )"
# X? ( x11-libs/lesstif )"
-IUSE="doc X"
-SLOT="0"
-KEYWORDS="x86"
-SRC_URI="http://ftp.debian.org/debian/pool/main/c/cmucl/cmucl_${PV}-${DEB_PV}.tar.gz
- http://cmucl.cons.org/ftp-area/cmucl/release/18e/cmucl-${PV}-x86-linux.tar.bz2"
-
PROVIDE="virtual/commonlisp"
-S=${WORKDIR}/${P}
-
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${PV}/herald-save.lisp-gentoo.patch
diff --git a/dev-lisp/cmucl/cmucl-18e-r3.ebuild b/dev-lisp/cmucl/cmucl-18e-r3.ebuild
index 0ca9d8405f01..44fd978c444c 100644
--- a/dev-lisp/cmucl/cmucl-18e-r3.ebuild
+++ b/dev-lisp/cmucl/cmucl-18e-r3.ebuild
@@ -1,28 +1,26 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl/cmucl-18e-r3.ebuild,v 1.1 2004/02/14 00:07:00 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl/cmucl-18e-r3.ebuild,v 1.2 2004/04/25 20:55:55 vapier Exp $
-inherit common-lisp-common
+inherit common-lisp-common eutils
DEB_PV=8
DESCRIPTION="CMUCL Lisp. This conforms to the ANSI Common Lisp Standard"
-HOMEPAGE="http://www.cons.org/cmucl/
- http://packages.debian.org/unstable/devel/cmucl.html"
+HOMEPAGE="http://www.cons.org/cmucl/ http://packages.debian.org/unstable/devel/cmucl.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cmucl/cmucl_${PV}-${DEB_PV}.tar.gz
+ http://cmucl.cons.org/ftp-area/cmucl/release/18e/cmucl-${PV}-x86-linux.tar.bz2"
+
LICENSE="public-domain"
-DEPEND="dev-lisp/common-lisp-controller
- doc? ( app-text/tetex )
- X? ( lesstif? ( x11-libs/lesstif ) !lesstif? ( x11-libs/openmotif ) )"
-IUSE="doc"
SLOT="0"
KEYWORDS="~x86"
-SRC_URI="http://ftp.debian.org/debian/pool/main/c/cmucl/cmucl_${PV}-${DEB_PV}.tar.gz
- http://cmucl.cons.org/ftp-area/cmucl/release/18e/cmucl-${PV}-x86-linux.tar.bz2"
+IUSE="doc"
+DEPEND="dev-lisp/common-lisp-controller
+ doc? ( app-text/tetex )
+ X? ( lesstif? ( x11-libs/lesstif ) !lesstif? ( x11-libs/openmotif ) )"
PROVIDE="virtual/commonlisp"
-S=${WORKDIR}/${P}
-
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${PV}/herald-save.lisp-gentoo.patch
diff --git a/dev-lisp/cmucl/cmucl-18e-r4.ebuild b/dev-lisp/cmucl/cmucl-18e-r4.ebuild
index acf3605348e1..4dd7d8e7a811 100644
--- a/dev-lisp/cmucl/cmucl-18e-r4.ebuild
+++ b/dev-lisp/cmucl/cmucl-18e-r4.ebuild
@@ -1,29 +1,27 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl/cmucl-18e-r4.ebuild,v 1.3 2004/03/14 23:02:32 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl/cmucl-18e-r4.ebuild,v 1.4 2004/04/25 20:56:13 vapier Exp $
-inherit common-lisp-common
+inherit common-lisp-common eutils
DEB_PV=8
DESCRIPTION="CMU Common Lisp is an implementation of ANSI Common Lisp"
-HOMEPAGE="http://www.cons.org/cmucl/
- http://packages.debian.org/unstable/devel/cmucl.html"
+HOMEPAGE="http://www.cons.org/cmucl/ http://packages.debian.org/unstable/devel/cmucl.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cmucl/cmucl_${PV}-${DEB_PV}.tar.gz
+ http://cmucl.cons.org/ftp-area/cmucl/release/18e/cmucl-${PV}-x86-linux.tar.bz2"
+
LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="doc lesstif"
+
DEPEND="dev-lisp/common-lisp-controller
doc? ( app-text/tetex )
lesstif? ( x11-libs/lesstif )
!lesstif? ( x11-libs/openmotif )"
-IUSE="doc lesstif"
-SLOT="0"
-KEYWORDS="x86"
-SRC_URI="http://ftp.debian.org/debian/pool/main/c/cmucl/cmucl_${PV}-${DEB_PV}.tar.gz
- http://cmucl.cons.org/ftp-area/cmucl/release/18e/cmucl-${PV}-x86-linux.tar.bz2"
-
PROVIDE="virtual/commonlisp"
-S=${WORKDIR}/${P}
-
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${PV}/herald-save.lisp-gentoo.patch
diff --git a/dev-lisp/cmucl/cmucl-18e.ebuild b/dev-lisp/cmucl/cmucl-18e.ebuild
index 7fff091b43b8..8e7d8ac878b6 100644
--- a/dev-lisp/cmucl/cmucl-18e.ebuild
+++ b/dev-lisp/cmucl/cmucl-18e.ebuild
@@ -1,25 +1,27 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl/cmucl-18e.ebuild,v 1.1 2003/09/24 00:27:43 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl/cmucl-18e.ebuild,v 1.2 2004/04/25 20:56:45 vapier Exp $
+
+inherit eutils
# This package is a port of the Debian package of the same name.
DEB_PV=7
DESCRIPTION="CMUCL Lisp. This conforms to the ANSI Common Lisp Standard"
-HOMEPAGE="http://www.cons.org/cmucl/
- http://packages.debian.org/unstable/devel/cmucl.html"
+HOMEPAGE="http://www.cons.org/cmucl/ http://packages.debian.org/unstable/devel/cmucl.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cmucl/cmucl_${PV}.orig.tar.gz
+ http://ftp.debian.org/debian/pool/main/c/cmucl/cmucl_${PV}-${DEB_PV}.diff.gz
+ http://cmucl.cons.org/ftp-area/cmucl/release/18e/cmucl-${PV}-x86-linux.tar.bz2"
+
LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc X"
+
DEPEND="dev-lisp/common-lisp-controller
x11-libs/lesstif
doc? ( app-text/tetex )"
# X? ( x11-libs/lesstif )"
-IUSE="doc X"
-SLOT="0"
-KEYWORDS="~x86"
-SRC_URI="http://ftp.debian.org/debian/pool/main/c/cmucl/cmucl_${PV}.orig.tar.gz
- http://ftp.debian.org/debian/pool/main/c/cmucl/cmucl_${PV}-${DEB_PV}.diff.gz
- http://cmucl.cons.org/ftp-area/cmucl/release/18e/cmucl-${PV}-x86-linux.tar.bz2"
-
PROVIDE="virtual/commonlisp"
S=${WORKDIR}/${P}.orig
diff --git a/dev-lisp/common-lisp-controller/common-lisp-controller-3.76.ebuild b/dev-lisp/common-lisp-controller/common-lisp-controller-3.76.ebuild
index cd64b1cf724e..8893205cd16c 100644
--- a/dev-lisp/common-lisp-controller/common-lisp-controller-3.76.ebuild
+++ b/dev-lisp/common-lisp-controller/common-lisp-controller-3.76.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/common-lisp-controller/common-lisp-controller-3.76.ebuild,v 1.3 2003/12/14 22:38:07 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/common-lisp-controller/common-lisp-controller-3.76.ebuild,v 1.4 2004/04/25 20:57:14 vapier Exp $
DESCRIPTION="Common Lisp Controller"
HOMEPAGE="http://packages.debian.org/unstable/devel/common-lisp-controller.html"
@@ -9,6 +9,7 @@ SRC_URI="http://ftp.debian.org/debian/pool/main/c/common-lisp-controller/${PN}_$
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~sparc"
+IUSE=""
DEPEND="dev-lisp/cl-defsystem3
dev-lisp/cl-asdf
diff --git a/dev-lisp/common-lisp-controller/common-lisp-controller-3.82.ebuild b/dev-lisp/common-lisp-controller/common-lisp-controller-3.82.ebuild
index 6da486a436aa..3f7a434ca35c 100644
--- a/dev-lisp/common-lisp-controller/common-lisp-controller-3.82.ebuild
+++ b/dev-lisp/common-lisp-controller/common-lisp-controller-3.82.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/common-lisp-controller/common-lisp-controller-3.82.ebuild,v 1.1 2004/01/28 09:52:32 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/common-lisp-controller/common-lisp-controller-3.82.ebuild,v 1.2 2004/04/25 20:57:25 vapier Exp $
DESCRIPTION="Common Lisp Controller"
HOMEPAGE="http://packages.debian.org/unstable/devel/common-lisp-controller.html"
@@ -9,6 +9,7 @@ SRC_URI="http://ftp.debian.org/debian/pool/main/c/common-lisp-controller/${PN}_$
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~sparc ~ppc ~mips"
+IUSE=""
DEPEND="dev-lisp/cl-defsystem3
dev-lisp/cl-asdf
diff --git a/dev-lisp/ecls/ecls-0.9b.ebuild b/dev-lisp/ecls/ecls-0.9b.ebuild
index e8eef1a472ce..5b239b9f04fd 100644
--- a/dev-lisp/ecls/ecls-0.9b.ebuild
+++ b/dev-lisp/ecls/ecls-0.9b.ebuild
@@ -1,15 +1,16 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-0.9b.ebuild,v 1.2 2003/09/11 01:10:52 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-0.9b.ebuild,v 1.3 2004/04/25 20:57:51 vapier Exp $
+
+inherit eutils
DESCRIPTION="ECL (Embeddable Common-Lisp) is an interpreter of the Common-Lisp language as described in the X3J13 ANSI specification, featuring CLOS (Common-Lisp Object System), conditions, loops, etc, plus a translator to C, which can produce standalone executables. (Also known as ECLS or ECL 'Spain')"
-SRC_URI="mirror://sourceforge/ecls/ecl-${PV}.tgz"
HOMEPAGE="http://ecls.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ecls/ecl-${PV}.tgz"
-SLOT="0"
LICENSE="BSD LGPL-2"
+SLOT="0"
KEYWORDS="~x86"
-
IUSE="X"
DEPEND="X? ( virtual/x11 )
@@ -41,5 +42,5 @@ src_install() {
mandir=${D}/usr/share/man \
libdir=${D}/usr/lib/ecl install || die
dohtml doc/*.html
- dodoc ANNOUNCEMENT Copyright LGPL
+ dodoc ANNOUNCEMENT
}
diff --git a/dev-lisp/plt/plt-202.ebuild b/dev-lisp/plt/plt-202.ebuild
index 83f7b7d0e37c..2aa9e2c2acd5 100644
--- a/dev-lisp/plt/plt-202.ebuild
+++ b/dev-lisp/plt/plt-202.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/plt/plt-202.ebuild,v 1.9 2004/03/14 01:31:12 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/plt/plt-202.ebuild,v 1.10 2004/04/25 20:59:31 vapier Exp $
+
+inherit eutils
DESCRIPTION="PLT Scheme, including DrScheme, mzscheme, mred, and mzc"
HOMEPAGE="http://www.plt-scheme.org/software/drscheme/"
@@ -9,6 +11,7 @@ SRC_URI="http://www.cs.utah.edu/plt/download/${PV}/plt/plt.src.x.tar.gz"
KEYWORDS="x86"
SLOT="0"
LICENSE="LGPL-2.1"
+IUSE=""
DEPEND="virtual/glibc
virtual/x11
diff --git a/dev-lisp/sbcl/sbcl-0.8.7-r1.ebuild b/dev-lisp/sbcl/sbcl-0.8.7-r1.ebuild
index 8eba9d331151..2e9cbfec0aff 100644
--- a/dev-lisp/sbcl/sbcl-0.8.7-r1.ebuild
+++ b/dev-lisp/sbcl/sbcl-0.8.7-r1.ebuild
@@ -1,17 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.8.7-r1.ebuild,v 1.1 2004/01/29 03:54:31 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.8.7-r1.ebuild,v 1.2 2004/04/25 21:00:02 vapier Exp $
-inherit common-lisp-common
+inherit common-lisp-common eutils
-DESCRIPTION="Steel Bank Common Lisp (SBCL) is an implementation of ANSI Common Lisp."
-HOMEPAGE="http://sbcl.sourceforge.net/"
-IUSE="threads"
BV_X86=0.8.1
BV_PPC=0.7.13
BV_SPARC=0.7.13
BV_MIPS=0.7.10
DEB_PV=1
+DESCRIPTION="Steel Bank Common Lisp (SBCL) is an implementation of ANSI Common Lisp."
+HOMEPAGE="http://sbcl.sourceforge.net/"
SRC_URI="http://ftp.debian.org/debian/pool/main/s/sbcl/sbcl_${PV}.orig.tar.gz
mirror://sourceforge/sbcl/${P}-html.tar.bz2
http://ftp.debian.org/debian/pool/main/s/sbcl/sbcl_${PV}-${DEB_PV}.diff.gz
@@ -19,13 +18,14 @@ SRC_URI="http://ftp.debian.org/debian/pool/main/s/sbcl/sbcl_${PV}.orig.tar.gz
ppc? ( mirror://sourceforge/sbcl/${PN}-${BV_PPC}-binary-linux-ppc.tar.bz2 )
sparc? ( mirror://sourceforge/sbcl/${PN}-${BV_SPARC}-sparc-linux-binary.tar.bz2 )
mips? ( mirror://sourceforge/sbcl/${PN}-${BV_MIPS}-mips-linux-binary.tar.gz )"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="x86 ~ppc ~sparc ~mips"
-PROVIDE="virtual/commonlisp"
-DEPEND="dev-lisp/common-lisp-controller"
+IUSE="threads"
-S=${WORKDIR}/${P}
+DEPEND="dev-lisp/common-lisp-controller"
+PROVIDE="virtual/commonlisp"
src_unpack() {
if use x86; then
diff --git a/dev-lisp/sbcl/sbcl-0.8.7.ebuild b/dev-lisp/sbcl/sbcl-0.8.7.ebuild
index 05f13ebdb784..c0bb98c4e746 100644
--- a/dev-lisp/sbcl/sbcl-0.8.7.ebuild
+++ b/dev-lisp/sbcl/sbcl-0.8.7.ebuild
@@ -1,17 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.8.7.ebuild,v 1.1 2004/01/12 09:41:24 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.8.7.ebuild,v 1.2 2004/04/25 21:00:23 vapier Exp $
-inherit common-lisp-common
+inherit common-lisp-common eutils
-DESCRIPTION="Steel Bank Common Lisp (SBCL) is a Open Source development system for ANSI Common Lisp. It provides an interactive environment including an integrated native compiler, interpreter, and debugger."
-HOMEPAGE="http://sbcl.sourceforge.net/"
-IUSE="threads"
BV_X86=0.8.1
BV_PPC=0.7.13
BV_SPARC=0.7.13
BV_MIPS=0.7.10
DEB_PV=1
+DESCRIPTION="Steel Bank Common Lisp (SBCL) is a Open Source development system for ANSI Common Lisp. It provides an interactive environment including an integrated native compiler, interpreter, and debugger."
+HOMEPAGE="http://sbcl.sourceforge.net/"
SRC_URI="http://ftp.debian.org/debian/pool/main/s/sbcl/sbcl_${PV}.orig.tar.gz
mirror://sourceforge/sbcl/${P}-html.tar.bz2
http://ftp.debian.org/debian/pool/main/s/sbcl/sbcl_${PV}-${DEB_PV}.diff.gz
@@ -19,13 +18,14 @@ SRC_URI="http://ftp.debian.org/debian/pool/main/s/sbcl/sbcl_${PV}.orig.tar.gz
ppc? ( mirror://sourceforge/sbcl/${PN}-${BV_PPC}-binary-linux-ppc.tar.bz2 )
sparc? ( mirror://sourceforge/sbcl/${PN}-${BV_SPARC}-sparc-linux-binary.tar.bz2 )
mips? ( mirror://sourceforge/sbcl/${PN}-${BV_MIPS}-mips-linux-binary.tar.gz )"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~mips"
-PROVIDE="virtual/commonlisp"
-DEPEND="dev-lisp/common-lisp-controller"
+IUSE="threads"
-S=${WORKDIR}/${P}
+DEPEND="dev-lisp/common-lisp-controller"
+PROVIDE="virtual/commonlisp"
src_unpack() {
if use x86; then
diff --git a/dev-lisp/sbcl/sbcl-0.8.8.ebuild b/dev-lisp/sbcl/sbcl-0.8.8.ebuild
index e4ff5e3a5ecf..1d7fd6ee0e44 100644
--- a/dev-lisp/sbcl/sbcl-0.8.8.ebuild
+++ b/dev-lisp/sbcl/sbcl-0.8.8.ebuild
@@ -1,29 +1,29 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.8.8.ebuild,v 1.4 2004/03/24 21:52:12 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.8.8.ebuild,v 1.5 2004/04/25 21:01:38 vapier Exp $
-inherit common-lisp-common
+inherit common-lisp-common eutils
-DESCRIPTION="Steel Bank Common Lisp (SBCL) is an implementation of ANSI Common Lisp."
-HOMEPAGE="http://sbcl.sourceforge.net/"
-IUSE="threads"
BV_X86=0.8.1
BV_PPC=0.7.13
BV_SPARC=0.7.13
BV_MIPS=0.7.10
+DESCRIPTION="Steel Bank Common Lisp (SBCL) is an implementation of ANSI Common Lisp."
+HOMEPAGE="http://sbcl.sourceforge.net/"
SRC_URI="mirror://sourceforge/sbcl/${P}-source.tar.bz2
mirror://sourceforge/sbcl/${P}-html.tar.bz2
x86? ( mirror://sourceforge/sbcl/${PN}-${BV_X86}-x86-linux-binary.tar.bz2 )
ppc? ( mirror://sourceforge/sbcl/${PN}-${BV_PPC}-binary-linux-ppc.tar.bz2 )
sparc? ( mirror://sourceforge/sbcl/${PN}-${BV_SPARC}-sparc-linux-binary.tar.bz2 )
mips? ( mirror://sourceforge/sbcl/${PN}-${BV_MIPS}-mips-linux-binary.tar.gz )"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="x86 ~ppc ~sparc ~mips"
-PROVIDE="virtual/commonlisp"
-DEPEND="dev-lisp/common-lisp-controller"
+IUSE="threads"
-S=${WORKDIR}/${P}
+DEPEND="dev-lisp/common-lisp-controller"
+PROVIDE="virtual/commonlisp"
src_unpack() {
if use x86; then
diff --git a/dev-lisp/sbcl/sbcl-0.8.9.ebuild b/dev-lisp/sbcl/sbcl-0.8.9.ebuild
index 2f9c38217b08..b9265f24f472 100644
--- a/dev-lisp/sbcl/sbcl-0.8.9.ebuild
+++ b/dev-lisp/sbcl/sbcl-0.8.9.ebuild
@@ -1,29 +1,29 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.8.9.ebuild,v 1.1 2004/03/25 21:09:35 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.8.9.ebuild,v 1.2 2004/04/25 21:01:56 vapier Exp $
-inherit common-lisp-common
+inherit common-lisp-common eutils
-DESCRIPTION="Steel Bank Common Lisp (SBCL) is an implementation of ANSI Common Lisp."
-HOMEPAGE="http://sbcl.sourceforge.net/"
-IUSE="threads"
BV_X86=0.8.1
BV_PPC=0.7.13
BV_SPARC=0.7.13
BV_MIPS=0.7.10
+DESCRIPTION="Steel Bank Common Lisp (SBCL) is an implementation of ANSI Common Lisp."
+HOMEPAGE="http://sbcl.sourceforge.net/"
SRC_URI="mirror://sourceforge/sbcl/${P}-source.tar.bz2
mirror://sourceforge/sbcl/${P}-html.tar.bz2
x86? ( mirror://sourceforge/sbcl/${PN}-${BV_X86}-x86-linux-binary.tar.bz2 )
ppc? ( mirror://sourceforge/sbcl/${PN}-${BV_PPC}-binary-linux-ppc.tar.bz2 )
sparc? ( mirror://sourceforge/sbcl/${PN}-${BV_SPARC}-sparc-linux-binary.tar.bz2 )
mips? ( mirror://sourceforge/sbcl/${PN}-${BV_MIPS}-mips-linux-binary.tar.gz )"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~mips"
-PROVIDE="virtual/commonlisp"
-DEPEND="dev-lisp/common-lisp-controller"
+IUSE="threads"
-S=${WORKDIR}/${P}
+DEPEND="dev-lisp/common-lisp-controller"
+PROVIDE="virtual/commonlisp"
src_unpack() {
if use x86; then