summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2004-05-25 16:13:01 +0000
committerAkinori Hattori <hattya@gentoo.org>2004-05-25 16:13:01 +0000
commitb5d79c67ebe528c0a39d29ed89110902785b4d8e (patch)
tree194036aee9010872941d38bd48383b11e6312e65 /dev-lisp
parentversion bump. (diff)
downloadhistorical-b5d79c67ebe528c0a39d29ed89110902785b4d8e.tar.gz
historical-b5d79c67ebe528c0a39d29ed89110902785b4d8e.tar.bz2
historical-b5d79c67ebe528c0a39d29ed89110902785b4d8e.zip
version bump.
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/gauche/ChangeLog7
-rw-r--r--dev-lisp/gauche/Manifest4
-rw-r--r--dev-lisp/gauche/files/digest-gauche-0.81
-rw-r--r--dev-lisp/gauche/gauche-0.8.ebuild66
4 files changed, 76 insertions, 2 deletions
diff --git a/dev-lisp/gauche/ChangeLog b/dev-lisp/gauche/ChangeLog
index 14efc35ada40..1d6635a1fdf6 100644
--- a/dev-lisp/gauche/ChangeLog
+++ b/dev-lisp/gauche/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/gauche
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gauche/ChangeLog,v 1.22 2004/04/07 11:53:54 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gauche/ChangeLog,v 1.23 2004/05/25 16:13:01 hattya Exp $
+
+*gauche-0.8 (26 May 2004)
+
+ 26 May 2004; Akinori Hattori <hattya@gentoo.org> gauche-0.8.ebuild:
+ version bump.
07 Apr 2004; Akinori Hattori <hattya@gentoo.org> gauche-0.7.4.2.ebuild:
marked stable on x86.
diff --git a/dev-lisp/gauche/Manifest b/dev-lisp/gauche/Manifest
index 1304e89a6f2b..48d02f30861e 100644
--- a/dev-lisp/gauche/Manifest
+++ b/dev-lisp/gauche/Manifest
@@ -1,10 +1,12 @@
-MD5 61ac7d9969fcffd451edcec18c63cb13 ChangeLog 3478
+MD5 1ea1876e559002fa3c9bd26f68ffaed9 ChangeLog 3592
MD5 4f5b260070b79dd17577ee6027ce0105 gauche-0.7.3.ebuild 1389
MD5 297f23b1d0dd692dc71335c3c439dd23 gauche-0.7.4.1.ebuild 1205
MD5 e0ce463f407c17b0467f0ba5b34d2203 gauche-0.7.4.2.ebuild 1274
+MD5 525e688b297147604b955237e52a380c gauche-0.8.ebuild 1271
MD5 e9fa98743d1cf3b213a4b04f52baf5f8 metadata.xml 619
MD5 c72a63369fdb0fee8a8f45533b69fe5f files/digest-gauche-0.7.3 62
MD5 89966637512684b9b73c898b067cf740 files/digest-gauche-0.7.4.1 64
MD5 506a28faf2e5a3d88f080e411dff706c files/digest-gauche-0.7.4.2 64
+MD5 0f8ed13a6cb96a582a2cb357dd817608 files/digest-gauche-0.8 60
MD5 905b4119bbcfc50f5004668d9d806dcc files/gauche-extract-1.13.diff 524
MD5 177cc4fa4c84d465bab80e5b3adb5cc1 files/gauche-gdbm-gentoo.diff 729
diff --git a/dev-lisp/gauche/files/digest-gauche-0.8 b/dev-lisp/gauche/files/digest-gauche-0.8
new file mode 100644
index 000000000000..8a7a4cfb5a5b
--- /dev/null
+++ b/dev-lisp/gauche/files/digest-gauche-0.8
@@ -0,0 +1 @@
+MD5 95a72756ebc0bf7c95534869db45e542 Gauche-0.8.tgz 2467615
diff --git a/dev-lisp/gauche/gauche-0.8.ebuild b/dev-lisp/gauche/gauche-0.8.ebuild
new file mode 100644
index 000000000000..1579c88a7863
--- /dev/null
+++ b/dev-lisp/gauche/gauche-0.8.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gauche/gauche-0.8.ebuild,v 1.1 2004/05/25 16:13:01 hattya Exp $
+
+inherit eutils flag-o-matic
+
+IUSE="ipv6 nls"
+
+MY_P="${P/g/G}"
+
+DESCRIPTION="A Unix system friendly Scheme Interpreter"
+HOMEPAGE="http://gauche.sf.net/"
+SRC_URI="mirror://sourceforge/gauche/${MY_P}.tgz"
+
+RESTRICT="nomirror"
+LICENSE="BSD"
+KEYWORDS="~x86 ~ppc"
+SLOT="0"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND=">=sys-libs/gdbm-1.8.0"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-gdbm-gentoo.diff
+ epatch ${FILESDIR}/${PN}-extract-1.13.diff
+ autoconf
+
+}
+
+src_compile() {
+
+ local myconf mycflags
+
+ use ipv6 && myconf="--enable-ipv6"
+
+ if use nls; then
+ myconf="${myconf} --enable-multibyte=utf-8"
+ else
+ myconf="${myconf} --enable-multibyte=euc-jp"
+ fi
+
+ sed -i -e "67s/\$(LIB_INSTALL_DIR)/\$(DISTDIR)\$(LIB_INSTALL_DIR)/" src/Makefile.in
+
+ strip-flags
+
+ mycflags=${CFLAGS}
+ unset CFLAGS CXXFLAGS
+
+ econf ${myconf} --enable-threads=pthreads || die
+ emake OPTFLAGS="${mycflags}" || die
+
+ make -s check || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog HACKING INSTALL INSTALL.eucjp README
+
+}