summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-10 17:39:35 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-10 17:39:35 +0000
commit6ee348b8417871f03f4f2c0abb8e4990edf88ec4 (patch)
tree380cd67b4c0832fa8bd93e42f40984333c97d6c0 /dev-lisp/clisp/clisp-2.33-r1.ebuild
parentdont access $CC (diff)
downloadhistorical-6ee348b8417871f03f4f2c0abb8e4990edf88ec4.tar.gz
historical-6ee348b8417871f03f4f2c0abb8e4990edf88ec4.tar.bz2
historical-6ee348b8417871f03f4f2c0abb8e4990edf88ec4.zip
if anyone reads these diffs, these were good examples of things you should never do in your ebuild
Diffstat (limited to 'dev-lisp/clisp/clisp-2.33-r1.ebuild')
-rw-r--r--dev-lisp/clisp/clisp-2.33-r1.ebuild74
1 files changed, 35 insertions, 39 deletions
diff --git a/dev-lisp/clisp/clisp-2.33-r1.ebuild b/dev-lisp/clisp/clisp-2.33-r1.ebuild
index f3d659f888b2..b2dbd7ae23b1 100644
--- a/dev-lisp/clisp/clisp-2.33-r1.ebuild
+++ b/dev-lisp/clisp/clisp-2.33-r1.ebuild
@@ -1,47 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.33-r1.ebuild,v 1.3 2004/05/10 17:34:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.33-r1.ebuild,v 1.4 2004/05/10 17:39:35 vapier Exp $
inherit flag-o-matic common-lisp-common eutils gcc
-IUSE="X fastcgi postgres nls berkdb pcre"
-
-# Handle the case where the user has some other -falign-functions
-# option set. Bug 34630.
-
-if ! is-flag '-falign-functions=4' \
- && expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)' >/dev/null; then
- CFLAGS=${CFLAGS/\
-$(expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)')/\
--falign-functions=4}
-fi
-
-# Fails to compile without -falign-functions=4 when -march=pentium4
-# (or -march=pentium3, sometimes??) is defined. Bugs 33425 and 34630.
-
-if (is-flag '-march=pentium4' || is-flag '-march=pentium3') \
- && ! is-flag '-falign-functions=4'; then
- append-flags '-falign-functions=4'
-fi
-
-# Athlon XP users report problems with -O3 optimization. In this
-# block, we remove any optimization flag. Depending on bug 34497. we
-# may be able to reduce optimization to -O2.
-
-if is-flag '-march=athlon-xp'; then
- filter-flags '-O*'
-fi
-
-# The previous stanza might not be necessary. Bug 39830.
-
-if is-flag '-march=athlon-xp'; then
- replace-flags '-march=athlon-xp' '-mcpu=athlon-xp'
-fi
-
DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
HOMEPAGE="http://clisp.sourceforge.net/"
SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
-S=${WORKDIR}/${P}
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~x86"
+IUSE="X fastcgi postgres nls berkdb pcre"
+
DEPEND="dev-libs/libsigsegv
dev-lisp/common-lisp-controller
fastcgi? ( dev-libs/fcgi )
@@ -51,9 +22,6 @@ DEPEND="dev-libs/libsigsegv
nls? ( sys-devel/gettext )
berkdb? ( =sys-libs/db-4* )
pcre? ( dev-libs/libpcre )"
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="~x86"
src_unpack() {
unpack ${A}
@@ -62,6 +30,34 @@ src_unpack() {
}
src_compile() {
+ # Handle the case where the user has some other -falign-functions
+ # option set. Bug 34630.
+ if ! is-flag '-falign-functions=4' \
+ && expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)' >/dev/null; then
+ CFLAGS=${CFLAGS/\
+ $(expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)')/\
+ -falign-functions=4}
+ fi
+
+ # Fails to compile without -falign-functions=4 when -march=pentium4
+ # (or -march=pentium3, sometimes??) is defined. Bugs 33425 and 34630.
+ if (is-flag '-march=pentium4' || is-flag '-march=pentium3') \
+ && ! is-flag '-falign-functions=4'; then
+ append-flags '-falign-functions=4'
+ fi
+
+ # Athlon XP users report problems with -O3 optimization. In this
+ # block, we remove any optimization flag. Depending on bug 34497. we
+ # may be able to reduce optimization to -O2.
+ if is-flag '-march=athlon-xp'; then
+ filter-flags '-O*'
+ fi
+
+ # The previous stanza might not be necessary. Bug 39830.
+ if is-flag '-march=athlon-xp'; then
+ replace-flags '-march=athlon-xp' '-mcpu=athlon-xp'
+ fi
+
einfo "Using CFLAGS: ${CFLAGS}"
export CC="$(gcc-getCC) ${CFLAGS}"
unset CFLAGS CXXFLAGS