summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-10-17 18:22:47 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-10-17 18:22:47 +0000
commit9b0a5c9ed79b6f08fcac7331036a1014dcf9ce6b (patch)
tree2cca97a58695db33e603444a8e18bcf5e8a71250 /dev-lisp/cl-sdl
parentMoving to SLOT=1. Closes #19409. (diff)
downloadhistorical-9b0a5c9ed79b6f08fcac7331036a1014dcf9ce6b.tar.gz
historical-9b0a5c9ed79b6f08fcac7331036a1014dcf9ce6b.tar.bz2
historical-9b0a5c9ed79b6f08fcac7331036a1014dcf9ce6b.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp/cl-sdl')
-rw-r--r--dev-lisp/cl-sdl/ChangeLog6
-rw-r--r--dev-lisp/cl-sdl/Manifest6
-rw-r--r--dev-lisp/cl-sdl/cl-sdl-0.2.1-r1.ebuild23
-rw-r--r--dev-lisp/cl-sdl/files/cl-sdl-0.2.1-gentoo.patch109
4 files changed, 137 insertions, 7 deletions
diff --git a/dev-lisp/cl-sdl/ChangeLog b/dev-lisp/cl-sdl/ChangeLog
index b52929e0defc..1de9d9513804 100644
--- a/dev-lisp/cl-sdl/ChangeLog
+++ b/dev-lisp/cl-sdl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lisp/cl-sdl
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-sdl/ChangeLog,v 1.2 2003/09/24 01:50:02 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-sdl/ChangeLog,v 1.3 2003/10/17 18:21:29 mkennedy Exp $
+
+ 17 Oct 2003; Matthew Kennedy <mkennedy@gentoo.org> cl-sdl-0.2.1-r1.ebuild,
+ files/cl-sdl-0.2.1-gentoo.patch:
+ postrm, preinst, reorder modules, clisp disable patch
*cl-sdl-0.2.1-r1 (23 Sep 2003)
diff --git a/dev-lisp/cl-sdl/Manifest b/dev-lisp/cl-sdl/Manifest
index e8fa5049fe1d..0656d3b3217e 100644
--- a/dev-lisp/cl-sdl/Manifest
+++ b/dev-lisp/cl-sdl/Manifest
@@ -1,5 +1,7 @@
-MD5 c9ebc583609994eb390011f2d845a0bd ChangeLog 473
+MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
+MD5 7020b83ed4f258198550cd2c8cd28890 cl-sdl-0.2.1-r1.ebuild 2581
MD5 19dc21becba9cb720683794637bd4b04 cl-sdl-0.2.1.ebuild 2256
-MD5 21bba62f2fcb18d2ce2c943734ee4bf9 cl-sdl-0.2.1-r1.ebuild 2295
+MD5 2289dbfcc01293b4970435e5af09bf86 ChangeLog 642
MD5 3fb703d7848492c86eb70264442ebed4 files/digest-cl-sdl-0.2.1 64
MD5 3fb703d7848492c86eb70264442ebed4 files/digest-cl-sdl-0.2.1-r1 64
+MD5 eb99992a3fab31005b911962e7e6f116 files/cl-sdl-0.2.1-gentoo.patch 4044
diff --git a/dev-lisp/cl-sdl/cl-sdl-0.2.1-r1.ebuild b/dev-lisp/cl-sdl/cl-sdl-0.2.1-r1.ebuild
index 8775a8b95181..a3b19386fb8e 100644
--- a/dev-lisp/cl-sdl/cl-sdl-0.2.1-r1.ebuild
+++ b/dev-lisp/cl-sdl/cl-sdl-0.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-sdl/cl-sdl-0.2.1-r1.ebuild,v 1.1 2003/09/24 01:50:02 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-sdl/cl-sdl-0.2.1-r1.ebuild,v 1.2 2003/10/17 18:21:29 mkennedy Exp $
inherit common-lisp
@@ -21,7 +21,12 @@ DEPEND="dev-lisp/cl-uffi
S=${WORKDIR}/${PN}
-SUB_PACKAGES="sdl sdl-ttf sdl-img sdl-mix opengl"
+SUB_PACKAGES="opengl sdl sdl-ttf sdl-img sdl-mix"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-gentoo.patch
+}
src_compile() {
make clean
@@ -69,16 +74,26 @@ src_install() {
pkg_postinst() {
/usr/sbin/register-common-lisp-source sdl-ffi
- /usr/sbin/register-common-lisp-source sdl-demos
for i in ${SUB_PACKAGES} ; do
/usr/sbin/register-common-lisp-source $i
done
+ /usr/sbin/register-common-lisp-source sdl-demos
}
pkg_prerm() {
/usr/sbin/unregister-common-lisp-source sdl-ffi
- /usr/sbin/unregister-common-lisp-source sdl-demos
for i in ${SUB_PACKAGES} ; do
/usr/sbin/unregister-common-lisp-source $i
done
+ /usr/sbin/unregister-common-lisp-source sdl-demos
+}
+
+pkg_preinst() {
+ rm -rf /usr/lib/common-lisp/*/sdl* || true
+ rm -rf /usr/lib/common-lisp/*/opengl || true
+}
+
+pkg_postrm() {
+ rm -rf /usr/lib/common-lisp/*/sdl* || true
+ rm -rf /usr/lib/common-lisp/*/opengl || true
}
diff --git a/dev-lisp/cl-sdl/files/cl-sdl-0.2.1-gentoo.patch b/dev-lisp/cl-sdl/files/cl-sdl-0.2.1-gentoo.patch
new file mode 100644
index 000000000000..74255fedc4eb
--- /dev/null
+++ b/dev-lisp/cl-sdl/files/cl-sdl-0.2.1-gentoo.patch
@@ -0,0 +1,109 @@
+Common subdirectories: cl-sdl.orig/CVS and cl-sdl/CVS
+Common subdirectories: cl-sdl.orig/build and cl-sdl/build
+Common subdirectories: cl-sdl.orig/c and cl-sdl/c
+Common subdirectories: cl-sdl.orig/debian and cl-sdl/debian
+Common subdirectories: cl-sdl.orig/doc and cl-sdl/doc
+Common subdirectories: cl-sdl.orig/examples and cl-sdl/examples
+Common subdirectories: cl-sdl.orig/ffi and cl-sdl/ffi
+Common subdirectories: cl-sdl.orig/nehe and cl-sdl/nehe
+Common subdirectories: cl-sdl.orig/opengl and cl-sdl/opengl
+diff -u cl-sdl.orig/opengl.asd cl-sdl/opengl.asd
+--- cl-sdl.orig/opengl.asd 2002-12-08 09:55:16.000000000 -0600
++++ cl-sdl/opengl.asd 2003-10-17 13:06:13.490855184 -0500
+@@ -4,7 +4,7 @@
+
+ (in-package #:asdf)
+
+-(defsystem opengl
++#-clisp (defsystem opengl
+ :components ((:module :opengl
+ :components
+ ((:file "gl")
+Common subdirectories: cl-sdl.orig/sdl and cl-sdl/sdl
+diff -u cl-sdl.orig/sdl-demos.asd cl-sdl/sdl-demos.asd
+--- cl-sdl.orig/sdl-demos.asd 2002-12-08 13:40:44.000000000 -0600
++++ cl-sdl/sdl-demos.asd 2003-10-17 13:06:23.859278944 -0500
+@@ -2,7 +2,7 @@
+
+ (in-package #:asdf)
+
+-(defsystem sdl-demos
++#-clisp (defsystem sdl-demos
+ :components ((:module :examples
+ :components
+ ((:file "sdl-test")
+diff -u cl-sdl.orig/sdl-examples.asd cl-sdl/sdl-examples.asd
+--- cl-sdl.orig/sdl-examples.asd 2002-12-08 10:56:51.000000000 -0600
++++ cl-sdl/sdl-examples.asd 2003-10-17 13:06:31.087180136 -0500
+@@ -3,7 +3,7 @@
+ ;;;; ASDF System Definition
+ (in-package #:asdf)
+
+-(defsystem sdl-examples
++#-clisp (defsystem sdl-examples
+ :components ((:module :examples
+ :components
+ ((:file "2d-test"
+diff -u cl-sdl.orig/sdl-ffi.asd cl-sdl/sdl-ffi.asd
+--- cl-sdl.orig/sdl-ffi.asd 2002-12-08 08:48:10.000000000 -0600
++++ cl-sdl/sdl-ffi.asd 2003-10-17 13:06:37.926140456 -0500
+@@ -4,7 +4,7 @@
+
+ (in-package #:asdf)
+
+-(defsystem sdl-ffi
++#-clisp (defsystem sdl-ffi
+ :components ((:module :ffi
+ :components ((:file "uffi"))))
+ :depends-on (uffi))
+Common subdirectories: cl-sdl.orig/sdl-img and cl-sdl/sdl-img
+diff -u cl-sdl.orig/sdl-img.asd cl-sdl/sdl-img.asd
+--- cl-sdl.orig/sdl-img.asd 2002-12-10 17:27:56.000000000 -0600
++++ cl-sdl/sdl-img.asd 2003-10-17 13:06:44.368161120 -0500
+@@ -3,7 +3,7 @@
+ ;;;; ASDF System Definition
+ (in-package #:asdf)
+
+-(defsystem sdl-img
++#-clisp (defsystem sdl-img
+ :components ((:module :sdl-img
+ :components ((:file "sdl-img"
+ :depends-on ("lib"))
+Common subdirectories: cl-sdl.orig/sdl-mix and cl-sdl/sdl-mix
+diff -u cl-sdl.orig/sdl-mix.asd cl-sdl/sdl-mix.asd
+--- cl-sdl.orig/sdl-mix.asd 2002-12-10 17:27:56.000000000 -0600
++++ cl-sdl/sdl-mix.asd 2003-10-17 13:06:50.749191056 -0500
+@@ -3,7 +3,7 @@
+ ;;;; ASDF System Definition
+ (in-package #:asdf)
+
+-(defsystem sdl-mix
++#-clisp (defsystem sdl-mix
+ :components ((:module :sdl-mix
+ :components ((:file "sdl-mix"
+ :depends-on ("lib"))
+Common subdirectories: cl-sdl.orig/sdl-ttf and cl-sdl/sdl-ttf
+diff -u cl-sdl.orig/sdl-ttf.asd cl-sdl/sdl-ttf.asd
+--- cl-sdl.orig/sdl-ttf.asd 2002-12-18 18:43:30.000000000 -0600
++++ cl-sdl/sdl-ttf.asd 2003-10-17 13:06:56.721283160 -0500
+@@ -3,7 +3,7 @@
+ ;;;; ASDF System Definition
+ (in-package #:asdf)
+
+-(defsystem sdl-ttf
++#-clisp (defsystem sdl-ttf
+ :components ((:module :sdl-ttf
+ :components ((:file "sdl-ttf"
+ :depends-on ("lib"))
+diff -u cl-sdl.orig/sdl.asd cl-sdl/sdl.asd
+--- cl-sdl.orig/sdl.asd 2002-12-18 18:43:30.000000000 -0600
++++ cl-sdl/sdl.asd 2003-10-17 13:07:02.305434240 -0500
+@@ -4,7 +4,7 @@
+
+ (in-package #:asdf)
+
+-(defsystem sdl
++#-clisp (defsystem sdl
+ :components ((:module :sdl
+ :components
+ ((:file "sdl")