summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-07-23 20:38:39 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-07-23 20:38:39 +0000
commitc5f56748af5797e5ca36303930889c0476fa3111 (patch)
treee86d86a914b3e7e556e3bc4249a94a6cae25e099 /dev-lisp/cl-ltk/cl-ltk-0.90.ebuild
parentVersion bump as per bug #140885. (diff)
downloadhistorical-c5f56748af5797e5ca36303930889c0476fa3111.tar.gz
historical-c5f56748af5797e5ca36303930889c0476fa3111.tar.bz2
historical-c5f56748af5797e5ca36303930889c0476fa3111.zip
New upstream version; Remove old ebuilds.
Package-Manager: portage-2.1.1_pre3-r3
Diffstat (limited to 'dev-lisp/cl-ltk/cl-ltk-0.90.ebuild')
-rw-r--r--dev-lisp/cl-ltk/cl-ltk-0.90.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-lisp/cl-ltk/cl-ltk-0.90.ebuild b/dev-lisp/cl-ltk/cl-ltk-0.90.ebuild
new file mode 100644
index 000000000000..395f25b8d59e
--- /dev/null
+++ b/dev-lisp/cl-ltk/cl-ltk-0.90.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-ltk/cl-ltk-0.90.ebuild,v 1.1 2006/07/23 20:38:39 mkennedy Exp $
+
+inherit common-lisp eutils
+
+DESCRIPTION="LTK is a Common Lisp binding for the Tk graphics toolkit which does not require any Tk knowledge for its usage."
+HOMEPAGE="http://www.peter-herth.de/ltk/"
+SRC_URI="http://www.peter-herth.de/ltk/${P#cl-}.tgz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+RDEPEND="${DEPEND}
+ dev-lang/tk"
+
+CLPACKAGE=ltk
+
+S=${WORKDIR}/${P#cl-}
+
+src_install() {
+ common-lisp-install *.lisp ltk.asd remote.tcl
+ common-lisp-system-symlink
+ dodoc *.{txt,pdf}
+}