summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-21 17:46:41 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-21 17:46:41 +0000
commitb9584ab7518f2ecfad77724846bf448e97da2499 (patch)
treef587383e859597bc632b901fc91c2883d89ccd37 /dev-libs
parent*** empty log message *** (diff)
downloadhistorical-b9584ab7518f2ecfad77724846bf448e97da2499.tar.gz
historical-b9584ab7518f2ecfad77724846bf448e97da2499.tar.bz2
historical-b9584ab7518f2ecfad77724846bf448e97da2499.zip
New version with avifile, libmpeg3 and libflash support
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/DirectFB/DirectFB-0.9.3.ebuild67
-rw-r--r--dev-libs/DirectFB/files/digest-DirectFB-0.9.31
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-libs/DirectFB/DirectFB-0.9.3.ebuild b/dev-libs/DirectFB/DirectFB-0.9.3.ebuild
new file mode 100644
index 000000000000..6247297ba4c4
--- /dev/null
+++ b/dev-libs/DirectFB/DirectFB-0.9.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.3.ebuild,v 1.1 2001/06/21 17:46:41 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="DirectFB is a thin library on top of the Linux fb devices"
+SRC_URI="http://www.directfb.org/download/DirectFB/${A}"
+HOMEPAGE="http://www.directfb.org"
+
+DEPEND="virtual/glibc sys-devel/perl >=media-libs/freetype-2.0.1 >=media-libs/jpeg-6
+ >=media-libs/libpng-1.0.10 >=media-libs/libflash-0.4.10
+ avifile? ( >=media-video/avifile-0.6.0 )
+ libmpeg3? ( >=media-libs/libmpeg3-1.2.3 )"
+
+RDEPEND="virtual/glibc >=media-libs/freetype-2.0.1 >=media-libs/jpeg-6
+ >=media-libs/libpng-1.0.10 >=media-libs/libflash-0.4.10
+ avifile? ( >=media-video/avifile-0.6.0 )
+ libmpeg3? ( >=media-libs/libmpeg3-1.2.3 )"
+
+src_compile() {
+ if [ "`use mmx`" ] ; then
+ myconf="--enable-mmx"
+ else
+ myconf="--disable-mmx"
+ fi
+ if [ "`use avifile`" ] ; then
+ myconf="$myconf --enable-avifile"
+ else
+ myconf="$myconf --disable-avifile"
+ fi
+ if [ "`use libmpeg3`" ] ; then
+ myconf="$myconf --with-libmpeg3=/usr/include/libmpeg3"
+ mkdir ${S}/interfaces/IDirectFBVideoProvider/no
+ cp /usr/lib/libmpeg3.a ${S}/interfaces/IDirectFBVideoProvider/no
+ else
+ myconf="$myconf --without-libmpeg3"
+ fi
+ if [ "$DEBUG" ] ; then
+ myconf="$myconf --enable-debug"
+ else
+ myconf="$myconf --disable-debug"
+ fi
+ try ./configure --prefix=/usr --host=${CHOST} $myconf \
+ --enable-jpeg --enable-png --enable-gif
+# cp Makefile Makefile.orig
+# sed -e "s:examples::" Makefile.orig > Makefile
+ if [ "`use libmpeg3`" ] ; then
+ try make LIBMPEG3_DIR=/usr/lib LIBMPEG3_LIBS=-lmpeg3
+ else
+ try make
+ fi
+
+}
+
+src_install () {
+ if [ "`use libmpeg3`" ] ; then
+ try make LIBMPEG3_DIR=/usr/lib LIBMPEG3_LIBS=-lmpeg3 DESTDIR=${D} install
+ else
+ try make DESTDIR=${D} install
+ fi
+ dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
+ docinto html
+ dodoc docs/html/*.{png,html}
+}
+
diff --git a/dev-libs/DirectFB/files/digest-DirectFB-0.9.3 b/dev-libs/DirectFB/files/digest-DirectFB-0.9.3
new file mode 100644
index 000000000000..756681659a9d
--- /dev/null
+++ b/dev-libs/DirectFB/files/digest-DirectFB-0.9.3
@@ -0,0 +1 @@
+MD5 596a09a13b70bdaf38dd8a70727894d3 DirectFB-0.9.3.tar.gz