summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-08-11 10:22:11 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-08-11 10:22:11 +0000
commit8204bc55d7748f72795211a3a42aab4c5b99817e (patch)
treee7fcd9fdc79b44a3c5ca74674b9efac769b0a577 /dev-libs
parentStable on amd64 wrt bug #332193 (diff)
downloadhistorical-8204bc55d7748f72795211a3a42aab4c5b99817e.tar.gz
historical-8204bc55d7748f72795211a3a42aab4c5b99817e.tar.bz2
historical-8204bc55d7748f72795211a3a42aab4c5b99817e.zip
Respect CC,CFLAGS,LDFLAGS. Bug #331849. Thanks to Diego E. 'Flameeyes' Pettenò <flameeyes@gentoo.org> for reporting
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/luaevent-prosody/ChangeLog7
-rw-r--r--dev-libs/luaevent-prosody/Manifest4
-rw-r--r--dev-libs/luaevent-prosody/luaevent-prosody-0.1.1.ebuild11
3 files changed, 16 insertions, 6 deletions
diff --git a/dev-libs/luaevent-prosody/ChangeLog b/dev-libs/luaevent-prosody/ChangeLog
index c3094f9aecc7..7169a63fc7b3 100644
--- a/dev-libs/luaevent-prosody/ChangeLog
+++ b/dev-libs/luaevent-prosody/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/luaevent-prosody
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/luaevent-prosody/ChangeLog,v 1.2 2010/07/13 12:50:28 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/luaevent-prosody/ChangeLog,v 1.3 2010/08/11 10:22:11 hwoarang Exp $
+
+ 11 Aug 2010; Markos Chandras <hwoarang@gentoo.org>
+ luaevent-prosody-0.1.1.ebuild:
+ Respect CC,CFLAGS,LDFLAGS. Bug #331849. Thanks to Diego E. 'Flameeyes'
+ Pettenò <flameeyes@gentoo.org> for reporting
13 Jul 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
metadata.xml:
diff --git a/dev-libs/luaevent-prosody/Manifest b/dev-libs/luaevent-prosody/Manifest
index 11c38cc278c2..e864a50050dc 100644
--- a/dev-libs/luaevent-prosody/Manifest
+++ b/dev-libs/luaevent-prosody/Manifest
@@ -1,4 +1,4 @@
DIST luaevent-prosody-0.1.1.tar.gz 28957 RMD160 4d7612fa33df9a7c5f7b38acb6368b334a7b0f1f SHA1 cd9f4149b324ff26764f3142001398416d909a2c SHA256 accf6a514a2735d26bb1c30b37e956e42a5fa491ce620eed131e023307a95760
-EBUILD luaevent-prosody-0.1.1.ebuild 1335 RMD160 6260194bc20be00c1d9e05cc5562e79c8bccfcbf SHA1 e089cfa7b94c6208f181671e04b3ac4dc6a3392c SHA256 5b41a5c457e32ff70c860bb3876bf8fc5661304460720d09d2775111258e61b7
-MISC ChangeLog 534 RMD160 493612cf4abb86ecd88cafb6b087cf175c24ddf6 SHA1 d8b206274b0dceb97d3a83f40363015efdff2ac0 SHA256 fbae4bdba8b5518096d44948af83569678455e73d319623ebc3d36323866a0b2
+EBUILD luaevent-prosody-0.1.1.ebuild 1476 RMD160 1c541716ef300e441a978c53a32753b6292710b6 SHA1 cc20bf1bd72dc8ac021cf0afb5bc70c64d142378 SHA256 ea7d009b1430ef9f3502b08c8e7a034e066f474a2617e23622e6ede68ff25fe9
+MISC ChangeLog 739 RMD160 36bf13c34747df590cc70868429b5e0aaeab9128 SHA1 37c0ab8d5fec14186b3f630c1c9c68cf14bbf914 SHA256 39e67708638bc149c7b55b7b4e5cc13235f9b48723f2ae7036553f19ffcf76d0
MISC metadata.xml 227 RMD160 a678a3b5783cc916b2b150bd9da8b8d54492f8ca SHA1 ba7d19940993fe78fc8f7901ac808c620b5c1006 SHA256 cf59866b69efc8418b66c84da5c00c9299b530cd7296791ffa5121bb6ed5446b
diff --git a/dev-libs/luaevent-prosody/luaevent-prosody-0.1.1.ebuild b/dev-libs/luaevent-prosody/luaevent-prosody-0.1.1.ebuild
index 0dc200d40ae6..e48170d7472d 100644
--- a/dev-libs/luaevent-prosody/luaevent-prosody-0.1.1.ebuild
+++ b/dev-libs/luaevent-prosody/luaevent-prosody-0.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/luaevent-prosody/luaevent-prosody-0.1.1.ebuild,v 1.1 2010/07/12 07:50:53 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/luaevent-prosody/luaevent-prosody-0.1.1.ebuild,v 1.2 2010/08/11 10:22:11 hwoarang Exp $
EAPI=2
@@ -31,7 +31,8 @@ src_prepare() {
src_compile() {
append-flags -fPIC -c
emake \
- CFLAGS="${CFLAGS}" \
+ CFLAGS="${LDFLAGS} ${CFLAGS}" \
+ LDFLAGS="${LDFLAGS} -shared" \
CC="$(tc-getCC)" \
LD="$(tc-getCC) -shared" \
all \
@@ -39,5 +40,9 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" install || die "Install failed"
+ emake \
+ CFLAGS="${LDFLAGS} ${CFLAGS}" \
+ LDFLAGS="${LDFLAGS} -shared" \
+ CC="$(tc-getCC)" \
+ DESTDIR="${D}" install || die "Install failed"
}