summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-03-06 06:05:34 +0000
committerAchim Gottinger <achim@gentoo.org>2001-03-06 06:05:34 +0000
commit5f8ec88fd90caf83853b8b5857fdf138ae75ad24 (patch)
tree3ff649abcd01e5f57a32beffa4fce1f21195d2f6 /dev-libs
parent*** empty log message *** (diff)
downloadhistorical-5f8ec88fd90caf83853b8b5857fdf138ae75ad24.tar.gz
historical-5f8ec88fd90caf83853b8b5857fdf138ae75ad24.tar.bz2
historical-5f8ec88fd90caf83853b8b5857fdf138ae75ad24.zip
Updates
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/rep-gtk/rep-gtk-0.15-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/rep-gtk/rep-gtk-0.15-r1.ebuild b/dev-libs/rep-gtk/rep-gtk-0.15-r1.ebuild
new file mode 100644
index 000000000000..1fbc2c75dad2
--- /dev/null
+++ b/dev-libs/rep-gtk/rep-gtk-0.15-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/rep-gtk/rep-gtk-0.15-r1.ebuild,v 1.1 2001/03/06 06:05:34 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="GTK/GDK bindings for the librep Lisp environment"
+SRC_URI="ftp://rep-gtk.sourceforge.net/pub/rep-gtk/"${A}
+HOMEPAGE="http://rep-gtk.sourceforge.net/"
+
+DEPEND=">=x11-libs/gtk+-1.2.9
+ >=dev-libs/librep-0.13.4
+ gnome? ( >=gnome-base/libglade-0.16
+ >=gnome-base/gdk-pixbuf-0.9.0-r1 )"
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ if [ -n "`use gnome`" ]
+ then
+ try ./configure --host=${CHOST} --with-gnome --with-libglade
+ else
+ try ./configure --host=${CHOST} --without-gnome --without-libglade \
+ --without-gdk-pixbuf --without-gnome-canvas-pixbuf
+ fi
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make DESTDIR=${D} install
+ dodoc AUTHORS BUGS COPYING ChangeLog README* TODO
+ docinto examples
+ dodoc examples/*
+}