summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-06-15 06:29:43 +0000
committerNed Ludd <solar@gentoo.org>2004-06-15 06:29:43 +0000
commit1e19e7a2d9df97a0cc291478ad9932e4f3cfc4ab (patch)
treefed41aaa6414e2fdf42e50fdad032498cec2c483 /dev-libs
parentUSE= cleanups and added uclibc (diff)
downloadhistorical-1e19e7a2d9df97a0cc291478ad9932e4f3cfc4ab.tar.gz
historical-1e19e7a2d9df97a0cc291478ad9932e4f3cfc4ab.tar.bz2
historical-1e19e7a2d9df97a0cc291478ad9932e4f3cfc4ab.zip
added uclibc patch for configure target
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/expat/ChangeLog6
-rw-r--r--dev-libs/expat/expat-1.95.6-r1.ebuild4
-rw-r--r--dev-libs/expat/files/expat-1.95.6-uclibc.patch48
-rw-r--r--dev-libs/openssl/Manifest18
-rw-r--r--dev-libs/popt/ChangeLog8
-rw-r--r--dev-libs/popt/files/popt-1.7-uclibc.patch96
-rw-r--r--dev-libs/popt/popt-1.7-r1.ebuild7
7 files changed, 173 insertions, 14 deletions
diff --git a/dev-libs/expat/ChangeLog b/dev-libs/expat/ChangeLog
index 4f2fb5a9d254..f4455602e844 100644
--- a/dev-libs/expat/ChangeLog
+++ b/dev-libs/expat/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/expat
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/ChangeLog,v 1.30 2004/05/15 09:21:23 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/ChangeLog,v 1.31 2004/06/15 06:26:16 solar Exp $
+
+ 15 Jun 2004; <solar@gentoo.org> expat-1.95.6-r1.ebuild,
+ files/expat-1.95.6-uclibc.patch:
+ added uclibc patch for configure target
15 May 2004; Bryan Østergaard <kloeri@gentoo.org> expat-1.95.7.ebuild:
Stable on alpha.
diff --git a/dev-libs/expat/expat-1.95.6-r1.ebuild b/dev-libs/expat/expat-1.95.6-r1.ebuild
index f62edbd287c7..14630450a94b 100644
--- a/dev-libs/expat/expat-1.95.6-r1.ebuild
+++ b/dev-libs/expat/expat-1.95.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-1.95.6-r1.ebuild,v 1.14 2004/03/21 11:23:42 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-1.95.6-r1.ebuild,v 1.15 2004/06/15 06:26:16 solar Exp $
inherit eutils gnuconfig
@@ -18,6 +18,8 @@ src_unpack() {
unpack ${A}
cd ${S}/lib
epatch ${FILESDIR}/xmlstatus.patch
+ cd ${S}
+ epatch ${FILESDIR}/expat-1.95.6-uclibc.patch
}
src_compile() {
diff --git a/dev-libs/expat/files/expat-1.95.6-uclibc.patch b/dev-libs/expat/files/expat-1.95.6-uclibc.patch
new file mode 100644
index 000000000000..a43f18407cea
--- /dev/null
+++ b/dev-libs/expat/files/expat-1.95.6-uclibc.patch
@@ -0,0 +1,48 @@
+--- expat-1.95.6.old/configure 2003-01-28 07:04:08.000000000 +0100
++++ expat-1.95.6/configure 2004-06-14 19:57:50.000000000 +0200
+@@ -2741,6 +2741,11 @@
+ esac
+ lt_cv_file_magic_test_file=`echo /lib/libc.so* /lib/libc-*.so`
+ ;;
++
++linux-uclibc*)
++ lt_cv_deplibs_check_method=pass_all
++ lt_cv_file_magic_test_file=`echo /lib/libuClibc*.so`
++ ;;
+
+ netbsd*)
+ if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
+@@ -3993,7 +3998,7 @@ fi
+
+ # Transform linux* to *-*-linux-gnu*, to support old configure scripts.
+ case $host_os in
+-linux-gnu*) ;;
++linux-gnu*|linux-uclibc*) ;;
+ linux*) host=`echo $host | sed 's/^\(.*-.*-linux\)\(.*\)$/\1-gnu\2/'`
+ esac
+
+@@ -5582,6 +5587,24 @@
+ dynamic_linker='GNU/Linux ld.so'
+ ;;
+
++linux-uclibc*)
++ version_type=linux
++ need_lib_prefix=no
++ need_version=no
++ library_names_spec='${libname}${release}.so$versuffix ${libname}${release}.so$major $libname.so'
++ soname_spec='${libname}${release}.so$major'
++ finish_cmds='PATH="\$PATH:/sbin" ldconfig -n $libdir'
++ shlibpath_var=LD_LIBRARY_PATH
++ shlibpath_overrides_runpath=no
++ # This implies no fast_install, which is unacceptable.
++ # Some rework will be needed to allow for fast_install
++ # before this can be enabled.
++ # Note: copied from linux-gnu, and may not be appropriate.
++ hardcode_into_libs=yes
++ # Assume using the uClibc dynamic linker.
++ dynamic_linker="uClibc ld.so"
++ ;;
++
+ netbsd*)
+ version_type=sunos
+ need_lib_prefix=no
diff --git a/dev-libs/openssl/Manifest b/dev-libs/openssl/Manifest
index 622600d6078f..b8441e9cf9a7 100644
--- a/dev-libs/openssl/Manifest
+++ b/dev-libs/openssl/Manifest
@@ -1,15 +1,15 @@
-MD5 3855f0260eb54ae27a18f84bae3eab9d openssl-0.9.7d.ebuild 7776
-MD5 996a9098984bfeaa47142b0090c9c273 openssl-0.9.7c.ebuild 4966
-MD5 55df006cb3b9be5f22c7913a19959029 openssl-0.9.7c-r1.ebuild 7028
-MD5 a8c9438b3052922ee974cd4556e5273a ChangeLog 13755
+MD5 b6927072a8344f86f32347449852f7f1 ChangeLog 13849
MD5 37236013e0d26d43c6bff35a8a48e8ec metadata.xml 220
-MD5 4a349fd613cc0f7dc5e1024be48ad6a5 openssl-0.9.6m.ebuild 3093
-MD5 7483d6f0412e857e9063dce4aecf2991 files/openssl-0.9.7c-gentoo.diff 936
-MD5 7483d6f0412e857e9063dce4aecf2991 files/openssl-0.9.7d-gentoo.diff 936
+MD5 b65e8bccb932a7bd7187d3d04ef72772 openssl-0.9.6m.ebuild 3094
+MD5 43d995ada0e1f67a3015904a865b6ea3 openssl-0.9.7d.ebuild 7793
+MD5 7c037c04f4f051f5e125867b9671bf03 openssl-0.9.7c.ebuild 4967
+MD5 55df006cb3b9be5f22c7913a19959029 openssl-0.9.7c-r1.ebuild 7028
MD5 2e6ed24d513a8f2b1b6f03709ab5ba18 files/digest-openssl-0.9.6m 67
-MD5 8ad6215b1b4c9d53c435ceff6b537e35 files/digest-openssl-0.9.7c 134
MD5 897d293325315cdeeb390745ed5cdd1b files/digest-openssl-0.9.7d 134
-MD5 f8b9ae9e3ed08f964620aa832aec4d0c files/digest-openssl-0.9.7c-r1 134
MD5 cebd09d1819c07b0fab14ad90b0da884 files/openssl-0.9.6m-gentoo.diff 1591
+MD5 8ad6215b1b4c9d53c435ceff6b537e35 files/digest-openssl-0.9.7c 134
+MD5 7483d6f0412e857e9063dce4aecf2991 files/openssl-0.9.7d-gentoo.diff 936
MD5 744b358cd3b68b2ca6561c214c541fc0 files/addppc64support.diff 1327
MD5 b901850df9952252974316e78775673b files/openssl-0.9.6-mips.diff 1487
+MD5 7483d6f0412e857e9063dce4aecf2991 files/openssl-0.9.7c-gentoo.diff 936
+MD5 f8b9ae9e3ed08f964620aa832aec4d0c files/digest-openssl-0.9.7c-r1 134
diff --git a/dev-libs/popt/ChangeLog b/dev-libs/popt/ChangeLog
index 63fce4ca4862..39186dc2546c 100644
--- a/dev-libs/popt/ChangeLog
+++ b/dev-libs/popt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/popt
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/popt/ChangeLog,v 1.17 2003/03/28 07:07:30 seemant Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/popt/ChangeLog,v 1.18 2004/06/15 06:29:42 solar Exp $
+
+ 15 Jun 2004; <solar@gentoo.org> popt-1.7-r1.ebuild,
+ files/popt-1.7-uclibc.patch:
+ added uclibc patch for configure target
*popt-1.7-r1 (20 Mar 2003)
diff --git a/dev-libs/popt/files/popt-1.7-uclibc.patch b/dev-libs/popt/files/popt-1.7-uclibc.patch
new file mode 100644
index 000000000000..f4672ed8d7f1
--- /dev/null
+++ b/dev-libs/popt/files/popt-1.7-uclibc.patch
@@ -0,0 +1,96 @@
+--- popt-1.7/configure.uclibc~ 2002-08-31 15:22:20.000000000 +0200
++++ popt-1.7/configure 2004-06-14 20:41:51.000000000 +0200
+@@ -4476,6 +4476,11 @@ linux-gnu*)
+ esac
+ lt_cv_file_magic_test_file=`echo /lib/libc.so* /lib/libc-*.so`
+ ;;
++
++linux-uclibc*)
++ lt_cv_deplibs_check_method=pass_all
++ lt_cv_file_magic_test_file=`echo /lib/libuClibc*.so`
++ ;;
+
+ netbsd*)
+ if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
+@@ -5329,7 +5334,7 @@ fi
+
+ # Transform linux* to *-*-linux-gnu*, to support old configure scripts.
+ case $host_os in
+-linux-gnu*) ;;
++linux-gnu*|linux-uclibc*) ;;
+ linux*) host=`echo $host | sed 's/^\(.*-.*-linux\)\(.*\)$/\1-gnu\2/'`
+ esac
+
+@@ -6880,6 +6885,24 @@ linux-gnu*)
+ dynamic_linker='GNU/Linux ld.so'
+ ;;
+
++linux-uclibc*)
++ version_type=linux
++ need_lib_prefix=no
++ need_version=no
++ library_names_spec='${libname}${release}.so$versuffix ${libname}${release}.so$major $libname.so'
++ soname_spec='${libname}${release}.so$major'
++ finish_cmds='PATH="\$PATH:/sbin" ldconfig -n $libdir'
++ shlibpath_var=LD_LIBRARY_PATH
++ shlibpath_overrides_runpath=no
++ # This implies no fast_install, which is unacceptable.
++ # Some rework will be needed to allow for fast_install
++ # before this can be enabled.
++ # Note: copied from linux-gnu, and may not be appropriate.
++ hardcode_into_libs=yes
++ # Assume using the uClibc dynamic linker.
++ dynamic_linker="uClibc ld.so"
++ ;;
++
+ netbsd*)
+ version_type=sunos
+ need_lib_prefix=no
+--- popt-1.7/aclocal.m4.uclibc~ 2002-08-31 15:22:08.000000000 +0200
++++ popt-1.7/aclocal.m4 2004-06-14 20:41:51.000000000 +0200
+@@ -1758,7 +1758,7 @@ fi
+
+ # Transform linux* to *-*-linux-gnu*, to support old configure scripts.
+ case $host_os in
+-linux-gnu*) ;;
++linux-gnu*|linux-uclibc*) ;;
+ linux*) host=`echo $host | sed 's/^\(.*-.*-linux\)\(.*\)$/\1-gnu\2/'`
+ esac
+
+@@ -3117,6 +3117,24 @@ linux-gnu*)
+ dynamic_linker='GNU/Linux ld.so'
+ ;;
+
++linux-uclibc*)
++ version_type=linux
++ need_lib_prefix=no
++ need_version=no
++ library_names_spec='${libname}${release}.so$versuffix ${libname}${release}.so$major $libname.so'
++ soname_spec='${libname}${release}.so$major'
++ finish_cmds='PATH="\$PATH:/sbin" ldconfig -n $libdir'
++ shlibpath_var=LD_LIBRARY_PATH
++ shlibpath_overrides_runpath=no
++ # This implies no fast_install, which is unacceptable.
++ # Some rework will be needed to allow for fast_install
++ # before this can be enabled.
++ # Note: copied from linux-gnu, and may not be appropriate.
++ hardcode_into_libs=yes
++ # Assume using the uClibc dynamic linker.
++ dynamic_linker="uClibc ld.so"
++ ;;
++
+ netbsd*)
+ version_type=sunos
+ need_lib_prefix=no
+@@ -4306,6 +4324,11 @@ linux-gnu*)
+ esac
+ lt_cv_file_magic_test_file=`echo /lib/libc.so* /lib/libc-*.so`
+ ;;
++
++linux-uclibc*)
++ lt_cv_deplibs_check_method=pass_all
++ lt_cv_file_magic_test_file=`echo /lib/libuClibc*.so`
++ ;;
+
+ netbsd*)
+ if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
diff --git a/dev-libs/popt/popt-1.7-r1.ebuild b/dev-libs/popt/popt-1.7-r1.ebuild
index aae02dcb3cca..fa5d79a2cc72 100644
--- a/dev-libs/popt/popt-1.7-r1.ebuild
+++ b/dev-libs/popt/popt-1.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/popt/popt-1.7-r1.ebuild,v 1.10 2004/04/26 01:15:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/popt/popt-1.7-r1.ebuild,v 1.11 2004/06/15 06:29:43 solar Exp $
inherit libtool gnuconfig
@@ -15,6 +15,11 @@ IUSE="nls"
DEPEND="nls? ( sys-devel/gettext )"
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-uclibc.patch
+}
+
src_compile() {
gnuconfig_update
elibtoolize